summaryrefslogtreecommitdiffstats
path: root/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/qbittorrent-vuetorrent-bin/PKGBUILD')
-rw-r--r--linhes/qbittorrent-vuetorrent-bin/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/linhes/qbittorrent-vuetorrent-bin/PKGBUILD b/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
new file mode 100644
index 0000000..498f6c8
--- /dev/null
+++ b/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: zoorat <zoorat [at] protonmail [dot] com>
+# Contributor: Falk Höppner <falk hoppner se>
+
+pkgname=qbittorrent-vuetorrent-bin
+_pkgname=vuetorrent
+pkgver=2.8.0
+pkgrel=1
+
+pkgdesc='The sleekest looking WebUI for qBittorrent made with Vue.js!'
+arch=('any')
+url='https://github.com/WDaan/VueTorrent'
+license=('GPL3')
+
+provides=("qbittorrent-${_pkgname}")
+conflicts=("qbittorrent-${_pkgname}")
+optdepends=(
+ 'qbittorrent: for use with qbittorrent'
+ 'qbittorrent-nox: for use with qbittorrent-nox'
+)
+install=qbittorrent-vuetorrent.install
+
+source=("${_pkgname}-$pkgver.zip::${url}/releases/download/v$pkgver/${_pkgname}.zip")
+sha512sums=('87213f659db3f50e37be214993a86948b3e86c979cc56556322828ca2d4201e12627be4bcf574a107701cef949a83b493c8d2624a2ec44d4c8c44e5862608bf0')
+
+package() {
+ cd "$srcdir/vuetorrent"
+ find . -type f -exec install -D '{}' "$pkgdir/usr/share/$pkgname/{}" ';'
+}
+# vim:set ts=2 sw=2 et: