summaryrefslogtreecommitdiffstats
path: root/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/qbittorrent-vuetorrent-bin/PKGBUILD')
-rw-r--r--linhes/qbittorrent-vuetorrent-bin/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/linhes/qbittorrent-vuetorrent-bin/PKGBUILD b/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
new file mode 100644
index 0000000..58271c1
--- /dev/null
+++ b/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: zoorat <zoorat [at] protonmail [dot] com>
+# Contributor: Falk Höppner <falk hoppner se>
+
+pkgname=qbittorrent-vuetorrent-bin
+_pkgname=vuetorrent
+pkgver=2.7.2
+pkgrel=1
+
+pkgdesc='The sleekest looking WebUI for qBittorrent made with Vue.js!'
+arch=('any')
+url='https://github.com/WDaan/VueTorrent'
+license=('GPL3')
+
+provides=("qbittorrent-${_pkgname}")
+conflicts=("qbittorrent-${_pkgname}")
+optdepends=(
+ 'qbittorrent: for use with qbittorrent'
+ 'qbittorrent-nox: for use with qbittorrent-nox'
+)
+install=qbittorrent-vuetorrent.install
+
+source=("${_pkgname}-$pkgver.zip::${url}/releases/download/v$pkgver/${_pkgname}.zip")
+sha512sums=('e34703647ba7fc61f0ef9e45f396aada647d6ee5df8b728a7a8c5ceb1ccd14375f0e2b60d9a56341b2dab613a287c1b4634569f75288aa89b4f021feb7c1640e')
+
+package() {
+ cd "$srcdir/vuetorrent"
+ find . -type f -exec install -D '{}' "$pkgdir/usr/share/$pkgname/{}" ';'
+}
+# vim:set ts=2 sw=2 et: