summaryrefslogtreecommitdiffstats
path: root/linhes/qt5-webkit/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/qt5-webkit/PKGBUILD')
-rw-r--r--linhes/qt5-webkit/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/linhes/qt5-webkit/PKGBUILD b/linhes/qt5-webkit/PKGBUILD
index e706560..466f53e 100644
--- a/linhes/qt5-webkit/PKGBUILD
+++ b/linhes/qt5-webkit/PKGBUILD
@@ -1,25 +1,29 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
+# Contributor: Zen Wen <zen.8841@gmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt5-webkit
_pkgver=5.212.0-alpha4
_basever=5.15.3
pkgver=${_pkgver/-/}
-pkgrel=18
+pkgrel=19
arch=(x86_64)
url='https://github.com/qtwebkit/qtwebkit'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
source=("https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz"
+ "https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/qtwebkit-cstdint.patch"
icu68.patch
glib-2.68.patch
- qt5-webkit-python-3.9.patch::"https://github.com/qtwebkit/qtwebkit/commit/78360c01.patch"
- qt5-webkit-bison-3.7.patch::"https://github.com/qtwebkit/qtwebkit/commit/d92b11fe.patch")
+ qt5-webkit-python-3.9.patch
+ qt5-webkit-bison-3.7.patch)
depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen woff2)
makedepends=(cmake ruby gperf python qt5-doc qt5-tools)
optdepends=('gst-plugins-good: Webm codec support')
sha256sums=('9ca126da9273664dd23a3ccd0c9bebceb7bb534bddd743db31caf6a5a6d4a9e6'
+ '4c71c958eae45cae65c9f002024eb1369d06029b668e595158138ff7971e64f1'
'0b40ed924f03ff6081af610bb0ee01560b7bd1fb68f8af02053304a01d4ccdf0'
'4969dd03e482155e2490b50307dada81dda7bbc9e5398e3a53c20bc474f7c04e'
'6e0cee08e4fa57b04752e80817f33562f48aa42608a3a620930b6040259b4932'
@@ -32,6 +36,7 @@ prepare() {
patch -p1 -i ../glib-2.68.patch # https://github.com/qtwebkit/qtwebkit/issues/1057
patch -p1 -i ../qt5-webkit-python-3.9.patch # Fix build with python 3.9
patch -p1 -i ../qt5-webkit-bison-3.7.patch # Fix build with bison 3.7
+ patch -p1 -i ../qtwebkit-cstdint.patch # gcc 11.1
}
build() {