summaryrefslogtreecommitdiffstats
path: root/linhes/wxedid/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/wxedid/PKGBUILD')
-rw-r--r--linhes/wxedid/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/linhes/wxedid/PKGBUILD b/linhes/wxedid/PKGBUILD
new file mode 100644
index 0000000..7fdbe3c
--- /dev/null
+++ b/linhes/wxedid/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=wxedid
+pkgver=0.0.29
+pkgrel=1
+pkgdesc="wxWidgets-based EDID (Extended Display Identification Data) editor"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/wxedid/"
+license=('GPL3')
+depends=('wxwidgets-gtk3')
+options=('!buildflags')
+source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('3fc9e1814ae990752defbd48a14670ec')
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf -f -i
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: