From 0157f62bdbfc25b73a902f63742f47f798422fa8 Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Mon, 10 Aug 2009 17:00:37 -0400
Subject: Play a half second of silence before status audio, to work around an
 ALSA bug with digital audio; also restore /etc/asound.state, if available

---
 abs/core-testing/LinHES-system/PKGBUILD         | 2 +-
 abs/core-testing/LinHES-system/bin/backupcommon | 5 +++--
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 8a2518f..aca4c13 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=63
+pkgrel=64
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/LinHES-system/bin/backupcommon b/abs/core-testing/LinHES-system/bin/backupcommon
index 3491b2a..d112341 100644
--- a/abs/core-testing/LinHES-system/bin/backupcommon
+++ b/abs/core-testing/LinHES-system/bin/backupcommon
@@ -16,7 +16,7 @@ BACKUP_LIST="./root ./home ./etc
 RESTORE_LIST="./root ./home ./etc/mythtv/modules ./etc/lirc
               ./etc/X11/xorg.conf ./etc/asound.conf ./etc/default/aumix
               ./var/lib/alsa/asound.state ./etc/mplayer/mplayer.conf
-              ./etc/localtime ./etc/timezone"
+              ./etc/localtime ./etc/timezone ./etc/asound.state"
 # Both BLACK_LIST and IGNORE_LIST need to have only one file per line
 # They also can't have any extra whitespace...
 # Files and directories we should refuse to restore
@@ -55,6 +55,7 @@ UPDATE_SQL="/usr/share/mythtv/sql/0.11-to-0.12.sql"
 UPDATE_FILES="$UTIL_DIR/restore_fixups.sh"
 COMPRESSION=".gz"
 SOUNDS="/usr/share/sounds"
+SILENCE="$SOUNDS/half_second_of_silence.wav"
 PLAYER="/usr/bin/aplay"
 #----------------------------------------------------------------------------
 AWK=/bin/awk
@@ -98,7 +99,7 @@ require file+r+x $AWK $BASH $BUNZIP2 $BZIP2 $CAT $CHMOD $CHOWN $EGREP $GREP \
 require dir+r+w+x /tmp "$BACKUP_DIR" "$DATABASE_DIR"
 
 play_sound () {
-    ($PLAYER $SOUNDS/$1 >& /dev/null)&
+    ($PLAYER $SILENCE $SOUNDS/$1 >& /dev/null)&
 }
 
 # Filter against an exclude list like the black list or the ignore list above
-- 
cgit v0.12