From e019db2c0c29ab1e825f983987275b3b1a597d4f Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 10 Dec 2008 23:06:21 -0800
Subject: Fixed LinHES-release.  PKGBUILD for MythAppleTrailers.

---
 abs/core-testing/LinHES-config/LinHES-release      |  4 ----
 abs/extra-testing/mythappletrailers/PKGBUILD       | 26 ++++++++++++++++++++++
 .../mythappletrailers/mythappletrailers.install    | 17 ++++++++++++++
 abs/extra-testing/mythappletrailers/trailers       |  2 ++
 4 files changed, 45 insertions(+), 4 deletions(-)
 create mode 100644 abs/extra-testing/mythappletrailers/PKGBUILD
 create mode 100644 abs/extra-testing/mythappletrailers/mythappletrailers.install
 create mode 100755 abs/extra-testing/mythappletrailers/trailers

diff --git a/abs/core-testing/LinHES-config/LinHES-release b/abs/core-testing/LinHES-config/LinHES-release
index fc10c90..0e9e72b 100644
--- a/abs/core-testing/LinHES-config/LinHES-release
+++ b/abs/core-testing/LinHES-config/LinHES-release
@@ -1,5 +1 @@
-<<<<<<< HEAD:abs/core-testing/LinHES-config/LinHES-release
-LinHES R6.00.05
-=======
 LinHES R6.00.04 
->>>>>>> origin/HEAD:abs/core-testing/LinHES-config/LinHES-release
diff --git a/abs/extra-testing/mythappletrailers/PKGBUILD b/abs/extra-testing/mythappletrailers/PKGBUILD
new file mode 100644
index 0000000..73f7add
--- /dev/null
+++ b/abs/extra-testing/mythappletrailers/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=mythappletrailers
+pkgver=0.04.3
+pkgrel=6
+pkgdesc="Unofficial Add-on for MythTV to get Apple.com Movie Trailers."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.mythtv.org/wiki/index.php/Myth_Apple_Trailers"
+depends=('php')
+install=mythappletrailers.install
+source=('http://colt45.chemlab.org/misc_scripts/mythtrailer/0.4/mythappletrailer-0.04.3.tar'
+	'trailers')
+
+build() {
+  mkdir -p $startdir/pkg/usr/bin
+  mkdir -p $startdir/pkg/etc/cron.daily
+  mkdir -p $startdir/pkg/home/mythtv/
+  mkdir -p $startdir/pkg/usr/share/mythtv/
+  touch $startdir/pkg/home/mythtv/appletrailer.xml
+  chown 1000:1000 $startdir/pkg/home/mythtv/appletrailer.xml
+  chmod 755 trailers
+  chmod 755 myth*/myth*
+  cp trailers $startdir/pkg/etc/cron.daily
+}
diff --git a/abs/extra-testing/mythappletrailers/mythappletrailers.install b/abs/extra-testing/mythappletrailers/mythappletrailers.install
new file mode 100644
index 0000000..22dada0
--- /dev/null
+++ b/abs/extra-testing/mythappletrailers/mythappletrailers.install
@@ -0,0 +1,17 @@
+# arg 1:  the new package version
+post_install() {
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  ln -s /home/mythtv/appletrailer.xml /usr/share/mythtv/appletrailer.xml
+}
+
+# arg 1:  the old package version
+post_remove() {
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/extra-testing/mythappletrailers/trailers b/abs/extra-testing/mythappletrailers/trailers
new file mode 100755
index 0000000..61567ec
--- /dev/null
+++ b/abs/extra-testing/mythappletrailers/trailers
@@ -0,0 +1,2 @@
+#!/bin/sh
+su mythtv -c '/usr/bin/php -q /usr/bin/myth_trailers_grabber.php > /home/mythtv/appletrailer.xml'
-- 
cgit v0.12