From cb3979cd33a441ea393fd26664de7497688420d1 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 22 Jun 2009 17:49:15 -0500
Subject: mpd & mpc: add them to community

---
 abs/extra-testing/community/mpc/ChangeLog   | 15 ++++++++++
 abs/extra-testing/community/mpc/PKGBUILD    | 26 +++++++++++++++++
 abs/extra-testing/community/mpd/PKGBUILD    | 44 +++++++++++++++++++++++++++++
 abs/extra-testing/community/mpd/mpd         | 42 +++++++++++++++++++++++++++
 abs/extra-testing/community/mpd/mpd.install | 23 +++++++++++++++
 5 files changed, 150 insertions(+)
 create mode 100644 abs/extra-testing/community/mpc/ChangeLog
 create mode 100644 abs/extra-testing/community/mpc/PKGBUILD
 create mode 100644 abs/extra-testing/community/mpd/PKGBUILD
 create mode 100755 abs/extra-testing/community/mpd/mpd
 create mode 100644 abs/extra-testing/community/mpd/mpd.install

diff --git a/abs/extra-testing/community/mpc/ChangeLog b/abs/extra-testing/community/mpc/ChangeLog
new file mode 100644
index 0000000..b645e19
--- /dev/null
+++ b/abs/extra-testing/community/mpc/ChangeLog
@@ -0,0 +1,15 @@
+2009-03-11  Alexander Fehr  <pizzapunk gmail com>
+
+  * mpc-0.15-1:
+  New upstream release.
+  Changed license to GPL2.
+
+2008-12-22  Alexander Fehr  <pizzapunk gmail com>
+
+  * mpc-0.14-1:
+  New upstream release.
+  New maintainer.
+  Changed url.
+  Added !emptydirs option.
+  Changed download location to downloads.sourceforge.net.
+  Added ChangeLog.
diff --git a/abs/extra-testing/community/mpc/PKGBUILD b/abs/extra-testing/community/mpc/PKGBUILD
new file mode 100644
index 0000000..345a2d6
--- /dev/null
+++ b/abs/extra-testing/community/mpc/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 33671 2009-04-04 15:49:53Z alexanderf $
+# Maintainer: Alexander Fehr <pizzapunk gmail com>
+# Contributor: Link Dupont <link@subpop.net>
+
+pkgname=mpc
+pkgver=0.15
+pkgrel=1
+pkgdesc="Minimalist command line interface to MPD"
+arch=('i686' 'x86_64')
+url="http://mpd.wikia.com/wiki/Client:Mpc"
+license=('GPL2')
+depends=('glibc')
+options=('!emptydirs')
+source=(http://downloads.sourceforge.net/musicpd/mpc-$pkgver.tar.bz2)
+md5sums=('48897aeb3a7ee5c64f30e56789f105a8')
+
+build() {
+  cd "$srcdir/mpc-$pkgver"
+
+  ./configure --prefix=/usr || return 1
+  make || return 1
+  make DESTDIR="$pkgdir" install || return 1
+
+  # Install bash completion file
+  install -D -m644 doc/mpc-bashrc "$pkgdir/etc/bash_completion.d/mpc" || return 1
+}
diff --git a/abs/extra-testing/community/mpd/PKGBUILD b/abs/extra-testing/community/mpd/PKGBUILD
new file mode 100644
index 0000000..240a5f8
--- /dev/null
+++ b/abs/extra-testing/community/mpd/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 27462 2009-02-22 02:31:36Z eric $
+# Maintainer: Damir Perisa <damir.perisa@bluewin.ch>
+# Contributor: Ben <ben@benmazer.net>
+
+pkgname=mpd
+pkgver=0.14.2
+pkgrel=1
+pkgdesc="Music daemon that plays MP3, FLAC, and Ogg Vorbis files"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://musicpd.org"
+depends=('libid3tag' 'libmad' 'flac>=1.1.3' 'audiofile' 'faad2>=2.6' 'libmikmod'
+         'alsa-lib' 'libshout' 'libmpcdec>=1.2.5' 'libsamplerate' 'libao' 'ffmpeg'
+	 'wavpack' 'glib2' 'curl')
+install=mpd.install
+source=(http://downloads.sourceforge.net/musicpd/${pkgname}-${pkgver}.tar.gz
+        'mpd')
+md5sums=('64177135f64aca555887ba378de8cdfb' 'b1fd15de359db08e4b9ae4b199640f0e')
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  ./configure --prefix=/usr \
+    --sysconfdir=/etc \
+    --disable-jack \
+    --enable-ao --enable-mod \
+    --with-zeroconf=no
+  make || return 1
+  make DESTDIR=${pkgdir} install
+
+  # set ours dirs in mpd.conf file
+  sed -i 's|music_directory.*$|#music_directory "path_to_your_music_collection"|1' doc/mpdconf.example
+  sed -i 's|playlist_directory.*$|playlist_directory "/var/lib/mpd/playlists"|1' doc/mpdconf.example
+  sed -i 's|db_file.*$|db_file "/var/lib/mpd/mpd.db"|1' doc/mpdconf.example
+  sed -i 's|log_file.*$|log_file "/var/log/mpd/mpd.log"|1' doc/mpdconf.example
+  sed -i 's|error_file.*$|error_file "/var/log/mpd/mpd.error"|1' doc/mpdconf.example
+  sed -i 's|#pid_file.*$|pid_file "/var/run/mpd/mpd.pid"|1' doc/mpdconf.example
+  sed -i 's|#state_file.*$|state_file "/var/lib/mpd/mpdstate"|1' doc/mpdconf.example
+  sed -i 's|#user.*$|user "mpd"|1' doc/mpdconf.example
+
+  install -Dm644 doc/mpdconf.example ${pkgdir}/etc/mpd.conf.example || return 1
+
+  install -D ${srcdir}/mpd ${pkgdir}/etc/rc.d/mpd || return 1
+  install -d ${pkgdir}/var/lib/mpd/playlists ${pkgdir}/var/log/mpd ${pkgdir}/var/run/mpd
+}
diff --git a/abs/extra-testing/community/mpd/mpd b/abs/extra-testing/community/mpd/mpd
new file mode 100755
index 0000000..76ec1c0
--- /dev/null
+++ b/abs/extra-testing/community/mpd/mpd
@@ -0,0 +1,42 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+  start)
+    stat_busy "Starting Music Player Daemon"
+    /usr/bin/mpd /etc/mpd.conf &> /dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      add_daemon mpd
+      stat_done
+    fi
+    ;;
+  stop)
+    stat_busy "Stopping Music Player Daemon"
+    /usr/bin/mpd --kill /etc/mpd.conf &> /dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      rm_daemon mpd
+      stat_done
+    fi
+    ;;
+  create-db)
+    stat_busy "Creating mpd's database ..."
+	logpath="/var/log/mpd/mpd.db-creation"
+    /usr/bin/mpd --create-db /etc/mpd.conf > $logpath \
+        && stat_busy "Output written to $logpath"
+              stat_done
+    ;;
+  restart)
+    $0 stop
+    sleep 1
+    $0 start
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart|create-db}"
+esac
+exit 0
diff --git a/abs/extra-testing/community/mpd/mpd.install b/abs/extra-testing/community/mpd/mpd.install
new file mode 100644
index 0000000..e44c9be
--- /dev/null
+++ b/abs/extra-testing/community/mpd/mpd.install
@@ -0,0 +1,23 @@
+# arg 1:  the new package version
+post_install() {
+  echo "==> mpd: Create a config under /etc/mpd.conf before using MPD (Example: /etc/mpd.conf.example)"
+  groupadd -g 45 mpd &>/dev/null
+  useradd -u 45 -g mpd -d /var/lib/mpd -s /bin/true mpd &>/dev/null
+  gpasswd -a mpd audio &>/dev/null
+  chown mpd:mpd -R /var/{lib,log,run}/mpd
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  if [ "$(vercmp $2 0.12)" -lt 0 ]; then
+    echo "==> mpd: upgrade from 0.11 -> 0.12: configuration file syntax changed, "
+    echo "==> mpd: make sure to update your configuration file! example conf: /etc/mpd.conf.example"
+  fi
+  chown mpd:mpd -R /var/{lib,log,run}/mpd
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  userdel mpd &>/dev/null
+}
-- 
cgit v0.12