From d0d7703bbe818afa92f0800fd6dbabaafe0a0543 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 4 Oct 2009 13:43:48 -0700
Subject: libjpeg6:Added install file for ld.so.conf.

---
 abs/core-testing/libjpeg6/PKGBUILD         |  3 ++-
 abs/core-testing/libjpeg6/libjpeg6.install | 31 ++++++++++++++++++++++++++++++
 2 files changed, 33 insertions(+), 1 deletion(-)
 create mode 100644 abs/core-testing/libjpeg6/libjpeg6.install

diff --git a/abs/core-testing/libjpeg6/PKGBUILD b/abs/core-testing/libjpeg6/PKGBUILD
index 285532e..a66b92e 100644
--- a/abs/core-testing/libjpeg6/PKGBUILD
+++ b/abs/core-testing/libjpeg6/PKGBUILD
@@ -3,7 +3,7 @@
 # Committer: Judd Vinet <jvinet@zeroflux.org>
 pkgname=libjpeg6
 pkgver=6b
-pkgrel=8
+pkgrel=9
 pkgdesc="Library of JPEG support functions"
 arch=('i686' 'x86_64')
 url="http://ijg.org"
@@ -11,6 +11,7 @@ license=('custom')
 depends=('glibc')
 makedepends=('libtool')
 options=(!libtool)
+install=libjpeg6.install
 source=(ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v$pkgver.tar.gz)
 md5sums=('dbd5f3b47ed13132f04c685d608a7547')
 
diff --git a/abs/core-testing/libjpeg6/libjpeg6.install b/abs/core-testing/libjpeg6/libjpeg6.install
new file mode 100644
index 0000000..dfb8ede
--- /dev/null
+++ b/abs/core-testing/libjpeg6/libjpeg6.install
@@ -0,0 +1,31 @@
+# arg 1:  the new package version
+post_install() {
+	if qrep -q libjpeg6 /etc/ld.so.conf
+	then
+		exit
+	else
+		echo "/opt/libjpeg6/include" >> /etc/ld.so.conf
+		ldconfig
+	fi
+}
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+	if qrep -q libjpeg6 /etc/ld.so.conf
+	then
+		exit
+	else
+		echo "/opt/libjpeg6/include" >> /etc/ld.so.conf
+		ldconfig
+	fi
+}
+# arg 1:  the old package version
+post_remove() {
+	grep -v libjpeg6 /etc/ld.so.conf > /tmp/ld.so.conf
+	mv /tmp/ld.so.conf /etc/ld.so.conf
+	ldconfig
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12