From a2c0883f206547f76d207a8477afc82a07cf0a30 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 27 Mar 2010 12:31:02 -0500
Subject: linhes-config: correct error when writing out /etc/hosts.  it's best
 to append instead of overwrite

closes #666
---
 abs/core-testing/LinHES-config/PKGBUILD      | 36 +++++++++++++++++++++++++++-
 abs/core-testing/LinHES-config/mv_network.py |  8 +++----
 2 files changed, 39 insertions(+), 5 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 60c6b07..942dc4d 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.1
-pkgrel=27
+pkgrel=28
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted' 
@@ -98,3 +98,37 @@ build() {
     install -m 0755 issue $startdir/pkg/etc/issue
 
 }
+md5sums=('297441b8d85820698c19e7c0ad5a3dfe'
+         '1a4694fcd694b362c339bda781ed0f3e'
+         'e36da536dd651ef182e7642337889e77'
+         '3baa23764e1b6bcb2d66d7d859096940'
+         'd7a8cd4a0060399ae22e69f74e04eb07'
+         '7a45287a07145fde5aa664583d4f6fba'
+         'f88d2fb88339a4bf8ec9217a3fbcdef7'
+         '8ac1cfd2eca0f641737da0d0aca416a7'
+         'd8a4a1699e04eed9ee69d58616069f33'
+         '4620f6f498ef4523398635cb0bd59425'
+         '06188493e5ed79cb501d3c5694dee8ca'
+         'e459ed069317bccb20351f037a9df3d2'
+         '26ee0932243b79484b37eb8f6cf04cd4'
+         '6aff504ed5e860adc1b7317cd0780900'
+         '55fccb1da0417a896b724f7cfc32dd5a'
+         'ab2aa42c2947148c2b1cac0ade6d1d55'
+         'd429b59d3cfb37b0624c6a4a71a7c2c0'
+         'a225143e3df6f56d451c2875e54ddbae'
+         '687555968d4ca688d8f95c8f13e1d8d4'
+         '3d1e4a119f38cff0498bf8a67e94e4b3'
+         '37401edf67296d3a4467ad178958d177'
+         '4fa90a581278115c914fd356391b656f'
+         '322cd6d5ce36f5d21bd84c3ca4ddfeec'
+         '86d6d1672bf2bc1bdde18dd35b31383d'
+         '8eb056f2ba0045e9f95578915dfecd22'
+         '65d93f15ac85adf8299552581789a731'
+         '5d774c28dbee0f495ff6eabd30b459f6'
+         '32385482ecc1275409b71f08d8b03acc'
+         'da0a2fb1e3cdbabac1f62e8b908c5d7f'
+         '1afc8d33021852d0254ae4a4d1f60888'
+         'f19917bed3a1e00cbe08838bee18b4b7'
+         '3c9adbbc1242d4e0a646af2e723924c7'
+         '4ae4b8cd9d40e072697d29ef85d18dc8'
+         'cf60e7ba4cf3467bb5539d5c51da61b6')
diff --git a/abs/core-testing/LinHES-config/mv_network.py b/abs/core-testing/LinHES-config/mv_network.py
index b80e4cc..2a55c63 100755
--- a/abs/core-testing/LinHES-config/mv_network.py
+++ b/abs/core-testing/LinHES-config/mv_network.py
@@ -50,7 +50,7 @@ def get_ip(ifname):
     )[20:24])
 
 def get_default_route(iface):
-    rcroute = "127.0.0.1" 
+    rcroute = "127.0.0.1"
     f = open ('/proc/net/route', 'r')
     for line in f:
         words = string.split (line)
@@ -107,7 +107,7 @@ def setup_MTYH_DNS():
       for line in f:
           if line.startswith("nameserver"):
               print line
-              returndns = line.split()[1]  
+              returndns = line.split()[1]
               break
     except:
       logging.debug("   Couldn't open /etc/resolv.conf for myth_dns")
@@ -158,7 +158,7 @@ def setup_hostname(systemconfig):
     except:
         logging.critical("    *Hostname could not be set")
         logging.info("    Using default value of me")
-        hostname = "me"
+        hostname = "diamonds"
     logging.info("    Setting the hostname to %s", hostname)
     cmd = ''' echo %s > /etc/hostname ''' %hostname
     mv_common.runcmd(cmd)
@@ -168,7 +168,7 @@ def setup_hostname(systemconfig):
         logging.debug("    not using dhcp")
         cmd = ''' echo 127.0.0.1 localhost  > /etc/hosts '''
         mv_common.runcmd(cmd)
-        cmd = ''' echo %s %s  > /etc/hosts ''' %(systemconfig["mythip"], systemconfig["hostname"])
+        cmd = ''' echo %s %s  >> /etc/hosts ''' %(systemconfig["mythip"], systemconfig["hostname"])
         mv_common.runcmd(cmd)
     else:
         cmd = ''' echo 127.0.0.1 %s localhost  > /etc/hosts ''' %systemconfig["hostname"]
-- 
cgit v0.12