From 3f7f6755080dc75184b8dbcf7c76ac96202cbec8 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Fri, 18 Sep 2009 01:10:24 -0700
Subject: linhes-scripts:added script to view upgradable packages.

---
 abs/core-testing/linhes-scripts/PKGBUILD          | 3 ++-
 abs/core-testing/linhes-scripts/linhes_update.sh  | 1 +
 abs/core-testing/linhes-scripts/linhes_update3.sh | 9 +++++++++
 3 files changed, 12 insertions(+), 1 deletion(-)
 create mode 100644 abs/core-testing/linhes-scripts/linhes_update3.sh

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index 924acfd..a8e1f1e 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=27
+pkgrel=29
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -31,6 +31,7 @@ screenshooter.sh
 run-limit-mythcommflag
 linhes_update.sh
 linhes_update2.sh
+linhes_update3.sh
 )
 
 build() {
diff --git a/abs/core-testing/linhes-scripts/linhes_update.sh b/abs/core-testing/linhes-scripts/linhes_update.sh
index 6890d26..89d39d8 100644
--- a/abs/core-testing/linhes-scripts/linhes_update.sh
+++ b/abs/core-testing/linhes-scripts/linhes_update.sh
@@ -32,6 +32,7 @@ chck ()  {
   		mv /tmp/linhes.xml.tmp /usr/share/mythtv/linhes.xml
   		dsply
 	fi
+	grep Target /tmp/check_update > /tmp/to_be_upgraded
 }
 dsply
 chck
diff --git a/abs/core-testing/linhes-scripts/linhes_update3.sh b/abs/core-testing/linhes-scripts/linhes_update3.sh
new file mode 100644
index 0000000..82722b8
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/linhes_update3.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+if [ -s /tmp/to_be_upgraded ]
+	then
+	sudo killall osd_cat
+	cat /tmp/to_be_upgraded | osd_cat -p top -f"-adobe-courier-bold-*-*-*-34-*-*-*-*-*" -d 1 -A centre -l 20 -w
+	else
+	sudo killall osd_cat
+	echo -e "No updates at this time." | osd_cat -p middle -s 5 -f"-adobe-courier-bold-*-*-*-34-*-*-*-*-*" -d 5 -A centre &
+fi
-- 
cgit v0.12