From 2bac69d1f9fd1c40cb48fcf12272f11cc88e3e40 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Mon, 26 Jan 2009 23:06:25 -0800
Subject: Patches to fix crashing w/ MythMusic.  Bumped version.

---
 .../libvisual-plugins/01_disable-gforce-dfsg.patch |  52 +++
 .../libvisual-plugins/02_64-bit_JESS_fix.patch     |  58 ++++
 .../03_build_against_gl_fixes.patch                | 372 +++++++++++++++++++++
 .../04_lv_analyzer_build_fix.patch                 |  12 +
 .../libvisual-plugins/05_fix_po.patch              | 127 +++++++
 abs/extra-testing/libvisual-plugins/PKGBUILD       |  21 +-
 6 files changed, 639 insertions(+), 3 deletions(-)
 create mode 100644 abs/extra-testing/libvisual-plugins/01_disable-gforce-dfsg.patch
 create mode 100644 abs/extra-testing/libvisual-plugins/02_64-bit_JESS_fix.patch
 create mode 100644 abs/extra-testing/libvisual-plugins/03_build_against_gl_fixes.patch
 create mode 100644 abs/extra-testing/libvisual-plugins/04_lv_analyzer_build_fix.patch
 create mode 100644 abs/extra-testing/libvisual-plugins/05_fix_po.patch

diff --git a/abs/extra-testing/libvisual-plugins/01_disable-gforce-dfsg.patch b/abs/extra-testing/libvisual-plugins/01_disable-gforce-dfsg.patch
new file mode 100644
index 0000000..686bde1
--- /dev/null
+++ b/abs/extra-testing/libvisual-plugins/01_disable-gforce-dfsg.patch
@@ -0,0 +1,52 @@
+diff -Nur libvisual-plugins-0.4.0/configure.ac libvisual-plugins-0.4.0.new/configure.ac
+--- libvisual-plugins-0.4.0/configure.ac	2006-03-17 03:50:41.000000000 +1100
++++ libvisual-plugins-0.4.0.new/configure.ac	2007-07-04 18:01:57.000000000 +1000
+@@ -414,7 +414,7 @@
+   AS_HELP_STRING([--disable-gforce],
+     [Do not build the G-Force plugin @<:@default=enabled@:>@]),
+     [ENABLE_GFORCE=$enableval],
+-    [ENABLE_GFORCE=yes])
++    [ENABLE_GFORCE=no])
+ 
+ if test "$ENABLE_GFORCE" = "yes"; then
+   build_actor_plugins="$build_actor_plugins G-Force"
+@@ -558,28 +558,6 @@
+ 	plugins/actor/nastyfft/Makefile
+ 	plugins/actor/oinksie/Makefile
+ 	plugins/actor/pseudotoad_flower/Makefile
+-	plugins/actor/G-Force/Makefile
+-	plugins/actor/G-Force/docs/Makefile
+-	plugins/actor/G-Force/Common/Makefile
+-	plugins/actor/G-Force/Common/GeneralTools/Makefile
+-	plugins/actor/G-Force/Common/GeneralTools/Headers/Makefile
+-	plugins/actor/G-Force/Common/io/Makefile
+-	plugins/actor/G-Force/Common/io/Headers/Makefile
+-	plugins/actor/G-Force/Common/math/Makefile
+-	plugins/actor/G-Force/Common/math/Headers/Makefile
+-	plugins/actor/G-Force/Common/UI/Makefile
+-	plugins/actor/G-Force/Common/UI/Headers/Makefile
+-	plugins/actor/G-Force/GForceCommon/Makefile
+-	plugins/actor/G-Force/GForceCommon/Headers/Makefile
+-	plugins/actor/G-Force/unix/Makefile
+-	plugins/actor/G-Force/unix/Headers/Makefile
+-	plugins/actor/G-Force/unix/libmfl/Makefile
+-	plugins/actor/G-Force/unix/libvisual/Makefile
+-	plugins/actor/G-Force/GForceColorMaps/Makefile
+-	plugins/actor/G-Force/GForceDeltaFields/Makefile
+-	plugins/actor/G-Force/GForceParticles/Makefile
+-	plugins/actor/G-Force/GForceWaveShapes/Makefile
+-	plugins/actor/G-Force/NotWorkingWaveShapes/Makefile
+ 	plugins/input/Makefile
+ 	plugins/input/esd/Makefile
+ 	plugins/input/alsa/Makefile
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/Makefile.am	2006-03-17 03:50:41.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/Makefile.am	2007-07-04 18:02:30.000000000 +1000
+@@ -4,7 +4,6 @@
+ DIST_SUBDIRS = \
+   bumpscope \
+   corona \
+-  G-Force \
+   gdkpixbuf \
+   gstreamer \
+   infinite \
diff --git a/abs/extra-testing/libvisual-plugins/02_64-bit_JESS_fix.patch b/abs/extra-testing/libvisual-plugins/02_64-bit_JESS_fix.patch
new file mode 100644
index 0000000..1d7f99e
--- /dev/null
+++ b/abs/extra-testing/libvisual-plugins/02_64-bit_JESS_fix.patch
@@ -0,0 +1,58 @@
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/JESS/renderer.c libvisual-plugins-0.4.0.new/plugins/actor/JESS/renderer.c
+--- libvisual-plugins-0.4.0/plugins/actor/JESS/renderer.c	2006-02-06 05:47:26.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/JESS/renderer.c	2007-07-04 18:12:58.000000000 +1000
+@@ -282,7 +282,7 @@
+ 
+ void render_deformation(JessPrivate *priv, int defmode)
+ {
+-	uint32_t bmax;
++	intptr_t bmax;
+ 	uint32_t *tab1 = NULL, *tab2, *tab3, *tab4, i;
+ 	uint8_t *pix = priv->pixel, *buf = priv->buffer, *aux;
+ 
+@@ -294,7 +294,7 @@
+ 		tab2 = priv->table2;
+ 		tab3 = priv->table3;
+ 		tab4 = priv->table4;
+-		bmax = priv->resx * priv->resy + (uint32_t) priv->pixel;
++		bmax = priv->resx * priv->resy + (intptr_t) priv->pixel;
+ 
+ 		switch(defmode)
+ 		{
+@@ -352,7 +352,7 @@
+ 		}
+ 		for (i = 0; i < priv->resy * priv->resx; i++)
+ 		{
+-			aux  =  (uint8_t *) ((*(tab1) << 2 ) + (uint32_t) priv->buffer);
++			aux  =  (uint8_t *) ((*(tab1) << 2 ) + (intptr_t) priv->buffer);
+ 			*(pix++) = *(aux++) ;
+ 			*(pix++) = *(aux++);  
+ 			*(pix++) = *(aux);  
+@@ -373,7 +373,8 @@
+ 	/* j'ai mis pixel par defaut... */
+ 
+ 	uint8_t *pix = priv->pixel;
+-	uint32_t bmax,pitch_4;
++	intptr_t bmax;
++	uint32_t pitch_4;
+ 	
+ 	pix = priv->pixel;
+ 	if (priv->pixel == NULL)
+@@ -387,7 +388,7 @@
+ 	if (priv->video == 8)
+ 	{
+ 		if (visual_cpu_get_mmx ()) {
+-			bmax = priv->resx * (priv->resy-1) + (uint32_t) priv->pixel;
++			bmax = priv->resx * (priv->resy-1) + (intptr_t) priv->pixel;
+ #if defined(VISUAL_ARCH_X86) || defined(VISUAL_ARCH_X86_64)
+ 			__asm __volatile
+ 				("\n\t pxor %%mm6, %%mm6"
+@@ -423,7 +424,7 @@
+ 	else
+ 	{
+ 		pitch_4 = priv->pitch+4;
+-		bmax = priv->pitch*(priv->resy-1) + (uint32_t) priv->pixel;
++		bmax = priv->pitch*(priv->resy-1) + (intptr_t) priv->pixel;
+ 
+ 		if (visual_cpu_get_mmx ()) {
+ #if defined(VISUAL_ARCH_X86) || defined(VISUAL_ARCH_X86_64)
diff --git a/abs/extra-testing/libvisual-plugins/03_build_against_gl_fixes.patch b/abs/extra-testing/libvisual-plugins/03_build_against_gl_fixes.patch
new file mode 100644
index 0000000..b215582
--- /dev/null
+++ b/abs/extra-testing/libvisual-plugins/03_build_against_gl_fixes.patch
@@ -0,0 +1,372 @@
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/bumpscope/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/bumpscope/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/bumpscope/Makefile.am	2006-02-23 20:03:24.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/bumpscope/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_bumpscope.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_bumpscope_la_LDFLAGS = -module -avoid-version 
++actor_bumpscope_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_bumpscope_la_SOURCES = actor_bumpscope.c \
+ 			  actor_bumpscope.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/corona/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/corona/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/corona/Makefile.am	2006-02-23 20:03:24.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/corona/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_corona.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CXXFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+ 
+ actor_corona_la_LDFLAGS = -module -avoid-version
++actor_corona_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_corona_la_SOURCES = actor_corona.cpp \
+ 			  autopal.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/gdkpixbuf/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/gdkpixbuf/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/gdkpixbuf/Makefile.am	2006-02-24 00:34:48.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/gdkpixbuf/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_gdkpixbuf.la
+ 
+-LIBS += $(LIBVISUAL_LIBS) $(GTK_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS) $(GTK_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_gdkpixbuf_la_LDFLAGS = -module -avoid-version 
++actor_gdkpixbuf_la_LIBADD = $(LIBVISUAL_LIBS) $(GTK_LIBS)
+ 
+ actor_gdkpixbuf_la_SOURCES = actor_gdkpixbuf.c
+ 
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/gstreamer/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/gstreamer/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/gstreamer/Makefile.am	2006-02-23 20:03:27.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/gstreamer/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,14 +2,13 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_gstreamer.la
+ 
+-LIBS += $(LIBVISUAL_LIBS) $(GSTREAMER_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS) $(GSTREAMER_CFLAGS)
+ 
+ INCLUDES = $(all_includes) \
+ 	-I$(top_srcdir) 
+ 
+ actor_gstreamer_la_LDFLAGS = -module -avoid-version 
++actor_gstreamer_la_LIBADD = $(LIBVISUAL_LIBS) $(GSTREAMER_LIBS)
+ 
+ actor_gstreamer_la_SOURCES = actor_gstreamer.c
+ 
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/infinite/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/infinite/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/infinite/Makefile.am	2006-02-23 20:03:27.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/infinite/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_infinite.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_infinite_la_LDFLAGS = -module -avoid-version 
++actor_infinite_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_infinite_la_SOURCES = compute.c compute.h \
+ 			    display.c display.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/jakdaw/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/jakdaw/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/jakdaw/Makefile.am	2006-02-23 20:03:28.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/jakdaw/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_jakdaw.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_jakdaw_la_LDFLAGS = -module -avoid-version 
++actor_jakdaw_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_jakdaw_la_SOURCES = actor_jakdaw.c \
+ 			  actor_jakdaw.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/JESS/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/JESS/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/JESS/Makefile.am	2006-02-23 20:03:24.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/JESS/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_JESS.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_JESS_la_LDFLAGS = -module -avoid-version
++actor_JESS_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_JESS_la_SOURCES = analyser.c analyser.h analyser_struct.h\
+ 			distorsion.c distorsion.h\
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/lv_analyzer/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/lv_analyzer/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/lv_analyzer/Makefile.am	2006-02-23 20:03:28.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/lv_analyzer/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,14 +2,13 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_lv_analyzer.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) \
+ 	-I$(top_srcdir) 
+ 
+ actor_lv_analyzer_la_LDFLAGS = -module -avoid-version 
++actor_lv_analyzer_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_lv_analyzer_la_SOURCES = actor_lv_analyzer.c
+ 
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/lv_gltest/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/lv_gltest/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/lv_gltest/Makefile.am	2006-02-24 22:24:49.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/lv_gltest/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -4,5 +4,5 @@
+ 
+ actor_lv_gltest_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) $(X_CFLAGS)
+ actor_lv_gltest_la_LDFLAGS = -module -avoid-version 
+-actor_lv_gltest_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU 
++actor_lv_gltest_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU 
+ actor_lv_gltest_la_SOURCES = actor_lv_gltest.c
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/lv_scope/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/lv_scope/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/lv_scope/Makefile.am	2006-02-23 20:03:29.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/lv_scope/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_lv_scope.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_lv_scope_la_LDFLAGS = -module -avoid-version 
++actor_lv_scope_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_lv_scope_la_SOURCES = actor_lv_scope.c
+ 
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/madspin/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/madspin/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/madspin/Makefile.am	2006-02-24 22:24:49.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/madspin/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -10,5 +10,5 @@
+ 
+ actor_madspin_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) -DSTAR_DIR=\""$(imagesdir)/"\"
+ actor_madspin_la_LDFLAGS = -module -avoid-version 
+-actor_madspin_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL 
++actor_madspin_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL 
+ actor_madspin_la_SOURCES = madspin.c
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/nastyfft/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/nastyfft/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/nastyfft/Makefile.am	2006-02-24 22:24:50.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/nastyfft/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -4,5 +4,5 @@
+ 
+ actor_nastyfft_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) $(X_CFLAGS)
+ actor_nastyfft_la_LDFLAGS = -module -avoid-version 
+-actor_nastyfft_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
++actor_nastyfft_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
+ actor_nastyfft_la_SOURCES = actor_nastyfft.c
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/oinksie/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/oinksie/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/oinksie/Makefile.am	2006-02-23 20:03:31.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/oinksie/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ actor_plugin_LTLIBRARIES = actor_oinksie.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ actor_oinksie_la_LDFLAGS = -module -avoid-version 
++actor_oinksie_la_LIBADD = $(LIBVISUAL_LIBS)
+ 
+ actor_oinksie_la_SOURCES = actor_oinksie.c\
+ 			   oinksie.c oinksie.h\
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/pseudotoad_flower/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/pseudotoad_flower/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/pseudotoad_flower/Makefile.am	2006-03-09 00:06:58.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/pseudotoad_flower/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -4,7 +4,7 @@
+ 
+ actor_flower_la_LDFLAGS = -module -avoid-version 
+ actor_flower_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) $(X_CFLAGS)
+-actor_flower_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU 
++actor_flower_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU 
+ 
+ actor_flower_la_SOURCES = \
+ 	actor_flower.c \
+diff -Nur libvisual-plugins-0.4.0/plugins/input/alsa/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/alsa/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/alsa/Makefile.am	2006-02-23 20:03:35.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/alsa/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,12 +2,11 @@
+ 
+ input_plugin_LTLIBRARIES = input_alsa.la
+ 
+-LIBS += $(ALSA_LIBS) $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(ALSA_CFLAGS) $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) -I$(top_builddir)
+ 
+ input_alsa_la_LDFLAGS = -module -avoid-version 
++input_alsa_la_LIBADD = $(ALSA_LIBS) $(LIBVISUAL_LIBS)
+ 
+ input_alsa_la_SOURCES = input_alsa.c
+diff -Nur libvisual-plugins-0.4.0/plugins/input/debug/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/debug/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/debug/Makefile.am	2006-02-23 20:03:36.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/debug/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+ 
+ input_plugin_LTLIBRARIES = input_debug.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) -I$(top_builddir)
+ 
+ input_debug_la_LDFLAGS = -module -avoid-version 
++input_debug_la_LIBADD = $(LIBVISUAL_LIBS)
+ input_debug_la_SOURCES = input_debug.c
+diff -Nur libvisual-plugins-0.4.0/plugins/input/esd/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/esd/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/esd/Makefile.am	2006-02-23 20:03:37.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/esd/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+ 
+ input_plugin_LTLIBRARIES = input_esd.la
+ 
+-LIBS += $(LIBESD_LIBS) $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBESD_CFLAGS) $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+ 
+ input_esd_la_LDFLAGS = -module -avoid-version 
++input_esd_la_LIBADD = $(LIBESD_LIBS) $(LIBVISUAL_LIBS)
+ input_esd_la_SOURCES = input_esd.c
+diff -Nur libvisual-plugins-0.4.0/plugins/input/jack/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/jack/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/jack/Makefile.am	2006-02-23 20:03:37.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/jack/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+ 
+ input_plugin_LTLIBRARIES = input_jack.la
+ 
+-LIBS += $(LIBJACK_LIBS) $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBJACK_CFLAGS) $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ input_jack_la_LDFLAGS = -module -avoid-version 
++input_jack_la_LIBADD = $(LIBJACK_LIBS) $(LIBVISUAL_LIBS)
+ 
+ input_jack_la_SOURCES = input_jack.c
+ 
+diff -Nur libvisual-plugins-0.4.0/plugins/input/mplayer/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/mplayer/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/mplayer/Makefile.am	2006-02-23 20:03:38.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/mplayer/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,12 +2,11 @@
+ 
+ input_plugin_LTLIBRARIES = input_mplayer.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ input_mplayer_la_LDFLAGS = -module -avoid-version 
++input_mplayer_la_LIBADD = $(LIBVISUAL_LIBS)
+ input_mplayer_la_SOURCES = input_mplayer.c
+ 
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/alphablend/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/alphablend/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/alphablend/Makefile.am	2006-02-23 20:03:38.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/alphablend/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+ 
+ morph_plugin_LTLIBRARIES = morph_alphablend.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ morph_alphablend_la_LDFLAGS = -module -avoid-version 
++morph_alphablend_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_alphablend_la_SOURCES = morph_alphablend.c
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/flash/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/flash/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/flash/Makefile.am	2006-02-23 20:03:39.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/flash/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+ 
+ morph_plugin_LTLIBRARIES = morph_flash.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ morph_flash_la_LDFLAGS = -module -avoid-version 
++morph_flash_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_flash_la_SOURCES = morph_flash.c
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/slide/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/slide/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/slide/Makefile.am	2006-02-23 20:03:39.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/slide/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+ 
+ morph_plugin_LTLIBRARIES = morph_slide.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ morph_slide_la_LDFLAGS = -module -avoid-version 
++morph_slide_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_slide_la_SOURCES = morph_slide.c
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/tentacle/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/tentacle/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/tentacle/Makefile.am	2006-02-23 20:03:39.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/tentacle/Makefile.am	2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+ 
+ morph_plugin_LTLIBRARIES = morph_tentacle.la
+ 
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+ 
+ INCLUDES = $(all_includes) -I$(top_srcdir) 
+ 
+ morph_tentacle_la_LDFLAGS = -module -avoid-version 
++morph_tentacle_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_tentacle_la_SOURCES = morph_tentacle.c
diff --git a/abs/extra-testing/libvisual-plugins/04_lv_analyzer_build_fix.patch b/abs/extra-testing/libvisual-plugins/04_lv_analyzer_build_fix.patch
new file mode 100644
index 0000000..1fc5f7f
--- /dev/null
+++ b/abs/extra-testing/libvisual-plugins/04_lv_analyzer_build_fix.patch
@@ -0,0 +1,12 @@
+diff -Nur libvisual-plugins-0.4.0/configure.ac libvisual-plugins-0.4.0.new/configure.ac
+--- libvisual-plugins-0.4.0/configure.ac	2006-03-17 03:50:41.000000000 +1100
++++ libvisual-plugins-0.4.0.new/configure.ac	2007-07-04 18:22:38.000000000 +1000
+@@ -361,7 +361,7 @@
+   [ENABLE_ANALYZER=$enableval],
+   [ENABLE_ANALYZER=yes])
+ 
+-if test "$ENABLE_ANALYZER" = xyes; then
++if test "$ENABLE_ANALYZER" = "yes"; then
+   build_actor_plugins="$build_actor_plugins lv_analyzer"
+ fi
+ 
diff --git a/abs/extra-testing/libvisual-plugins/05_fix_po.patch b/abs/extra-testing/libvisual-plugins/05_fix_po.patch
new file mode 100644
index 0000000..a5413ef
--- /dev/null
+++ b/abs/extra-testing/libvisual-plugins/05_fix_po.patch
@@ -0,0 +1,127 @@
+diff -Nur libvisual-plugins-0.4.0/po/Makefile.in.in libvisual-plugins-0.4.0.new/po/Makefile.in.in
+--- libvisual-plugins-0.4.0/po/Makefile.in.in	2006-03-21 05:48:28.000000000 +1100
++++ libvisual-plugins-0.4.0.new/po/Makefile.in.in	2007-07-09 21:50:13.000000000 +1000
+@@ -28,7 +28,7 @@
+ 
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = mkinstalldirs
+ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+ 
+ GMSGFMT = @GMSGFMT@
+diff -Nur libvisual-plugins-0.4.0/po/mkinstalldirs libvisual-plugins-0.4.0.new/po/mkinstalldirs
+--- libvisual-plugins-0.4.0/po/mkinstalldirs	1970-01-01 10:00:00.000000000 +1000
++++ libvisual-plugins-0.4.0.new/po/mkinstalldirs	2006-03-21 05:48:42.000000000 +1100
+@@ -0,0 +1,111 @@
++#! /bin/sh
++# mkinstalldirs --- make directory hierarchy
++# Author: Noah Friedman <friedman@prep.ai.mit.edu>
++# Created: 1993-05-16
++# Public domain
++
++errstatus=0
++dirmode=""
++
++usage="\
++Usage: mkinstalldirs [-h] [--help] [-m mode] dir ..."
++
++# process command line arguments
++while test $# -gt 0 ; do
++  case $1 in
++    -h | --help | --h*)         # -h for help
++      echo "$usage" 1>&2
++      exit 0
++      ;;
++    -m)                         # -m PERM arg
++      shift
++      test $# -eq 0 && { echo "$usage" 1>&2; exit 1; }
++      dirmode=$1
++      shift
++      ;;
++    --)                         # stop option processing
++      shift
++      break
++      ;;
++    -*)                         # unknown option
++      echo "$usage" 1>&2
++      exit 1
++      ;;
++    *)                          # first non-opt arg
++      break
++      ;;
++  esac
++done
++
++for file
++do
++  if test -d "$file"; then
++    shift
++  else
++    break
++  fi
++done
++
++case $# in
++  0) exit 0 ;;
++esac
++
++case $dirmode in
++  '')
++    if mkdir -p -- . 2>/dev/null; then
++      echo "mkdir -p -- $*"
++      exec mkdir -p -- "$@"
++    fi
++    ;;
++  *)
++    if mkdir -m "$dirmode" -p -- . 2>/dev/null; then
++      echo "mkdir -m $dirmode -p -- $*"
++      exec mkdir -m "$dirmode" -p -- "$@"
++    fi
++    ;;
++esac
++
++for file
++do
++  set fnord `echo ":$file" | sed -ne 's/^:\//#/;s/^://;s/\// /g;s/^#/\//;p'`
++  shift
++
++  pathcomp=
++  for d
++  do
++    pathcomp="$pathcomp$d"
++    case $pathcomp in
++      -*) pathcomp=./$pathcomp ;;
++    esac
++
++    if test ! -d "$pathcomp"; then
++      echo "mkdir $pathcomp"
++
++      mkdir "$pathcomp" || lasterr=$?
++
++      if test ! -d "$pathcomp"; then
++  	errstatus=$lasterr
++      else
++  	if test ! -z "$dirmode"; then
++	  echo "chmod $dirmode $pathcomp"
++    	  lasterr=""
++  	  chmod "$dirmode" "$pathcomp" || lasterr=$?
++
++  	  if test ! -z "$lasterr"; then
++  	    errstatus=$lasterr
++  	  fi
++  	fi
++      fi
++    fi
++
++    pathcomp="$pathcomp/"
++  done
++done
++
++exit $errstatus
++
++# Local Variables:
++# mode: shell-script
++# sh-indentation: 2
++# End:
++# mkinstalldirs ends here
diff --git a/abs/extra-testing/libvisual-plugins/PKGBUILD b/abs/extra-testing/libvisual-plugins/PKGBUILD
index 825c169..8cab849 100644
--- a/abs/extra-testing/libvisual-plugins/PKGBUILD
+++ b/abs/extra-testing/libvisual-plugins/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=libvisual-plugins
 pkgver=0.4.0
-pkgrel=2
+pkgrel=3
 pkgdesc="plugins for libvisual"
 arch=("i686" "x86_64")
 license=('GPL')
@@ -11,12 +11,27 @@ url="http://www.localhost.nl/~synap/libvisual/"
 depends=('libvisual>=0.4.0' 'gtk2' 'mesa' 'alsa-lib' 'esd' 'jack-audio-connection-kit')
 makedepends=(pkgconfig)
 install=libvisual-plugins.install
-source=("http://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-${pkgver}.tar.gz")
-md5sums=('4330e9287f9d6fae02f482f428a1e77b')
+source=("http://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-${pkgver}.tar.gz"
+	'01_disable-gforce-dfsg.patch'
+	'02_64-bit_JESS_fix.patch'
+	'03_build_against_gl_fixes.patch'
+	'04_lv_analyzer_build_fix.patch'
+	'05_fix_po.patch')
+md5sums=('4330e9287f9d6fae02f482f428a1e77b'
+	 '600969a691372c8894c90765de84f732'
+	 'f9cfb607bfcbfef60830fae4e7dc6963'
+	 '116701408747dbb87dc134434478ebe2'
+	 '01678a8f1584c76a44e59d81003a1109'
+	 '6189b7427c4e11c8b8d6c6266d6a1629')
 options=(!libtool)
 
 build() {
   cd ${startdir}/src/${pkgname}-${pkgver}
+  patch -p1 < ../01_disable-gforce-dfsg.patch
+  patch -p1 < ../02_64-bit_JESS_fix.patch
+  patch -p1 < ../03_build_against_gl_fixes.patch
+  patch -p1 < ../04_lv_analyzer_build_fix.patch
+  patch -p1 < ../05_fix_po.patch
   ./configure --prefix=/usr  --enable-alsa --disable-gstreamer-plugin
   make || return 1
   make DESTDIR=${startdir}/pkg install
-- 
cgit v0.12