From 7df303b374a3f43a9bf85c4d572c8a2f08ed93e3 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 10 Apr 2009 11:45:27 -0500
Subject: fbsplash: comment out setting up splash. Added a default value for  
 bootsteps

---
 abs/core-testing/fbsplash/PKGBUILD           | 22 +++++++++++-----------
 abs/core-testing/fbsplash/__changelog        |  4 ++++
 abs/core-testing/fbsplash/fbsplash.bootsteps |  1 +
 abs/core-testing/fbsplash/fbsplash.inithooks |  4 ++--
 4 files changed, 18 insertions(+), 13 deletions(-)
 create mode 100644 abs/core-testing/fbsplash/__changelog
 create mode 100644 abs/core-testing/fbsplash/fbsplash.bootsteps

diff --git a/abs/core-testing/fbsplash/PKGBUILD b/abs/core-testing/fbsplash/PKGBUILD
index 9a047d5..5c20232 100644
--- a/abs/core-testing/fbsplash/PKGBUILD
+++ b/abs/core-testing/fbsplash/PKGBUILD
@@ -2,12 +2,12 @@
 
 pkgname=fbsplash
 pkgver=1.5.4.3
-pkgrel=8
+pkgrel=12
 pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
 arch=('i686' 'x86_64')
 url="http://fbsplash.berlios.de"
 license=('GPL')
-backup=('etc/conf.d/fbsplash.conf')
+backup=('etc/conf.d/fbsplash.conf' 'etc/conf.d/fbsplash.bootsteps')
 makedepends=('klibc')
 depends=('initscripts' 'miscsplashutils' 'libjpeg' 'libpng' 'freetype2-static' 'gpm' 'libmng' 'which' 'linhes-splash') 
 conflicts=('bootsplash' 'gensplash')
@@ -18,15 +18,7 @@ source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2 \
 	splash-functions-arch.sh \
 	fbsplash.conf \
 	fbsplash.initcpio_install \
-	fbsplash.daemon)
-md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
-         '4ea33e99330abf4a9a468ac8c0ba48ca'
-         '44375e92025ce07b3434773efb282127'
-         '8ffb29400a2518b16f3dbca653855268'
-         '82ef6f37c2795db1b4fec0e6f8443c66'
-         '21380586a5dafbf7045886ea4374ab65'
-         'bb5154529e4b5fbc701cf4540c15a61a')
-
+	fbsplash.daemon fbsplash.bootsteps)
 build() {
 	cd ${startdir}/src/splashutils-${pkgver}
 
@@ -46,6 +38,7 @@ build() {
 	install -D -m644 ${startdir}/src/fbsplash.conf ${startdir}/pkg/etc/conf.d/fbsplash.conf
 	install -D -m744 ${startdir}/src/fbsplash.daemon ${startdir}/pkg/etc/rc.d/fbsplash
 	install -D -m744 ${startdir}/src/splash-functions-arch.sh ${startdir}/pkg/sbin/splash-functions-arch.sh
+	install -D -m755 $startdir/src/fbsplash.bootsteps ${startdir}/pkg/etc/conf.d/fbsplash.bootsteps
 
 	# install darch fbsplash theme
 	cp -r ${startdir}/src/darch ${startdir}/pkg/etc/splash/darch
@@ -54,3 +47,10 @@ build() {
 	install -D -m744 ${startdir}/src/fbsplash.inithooks ${startdir}/pkg/etc/rc.d/functions.d/fbsplash.sh
 
 }
+md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
+         '4ea33e99330abf4a9a468ac8c0ba48ca'
+         '33b3c7c2050670db0e8b2efd9e088ed9'
+         '8ffb29400a2518b16f3dbca653855268'
+         '82ef6f37c2795db1b4fec0e6f8443c66'
+         '21380586a5dafbf7045886ea4374ab65'
+         'bb5154529e4b5fbc701cf4540c15a61a')
diff --git a/abs/core-testing/fbsplash/__changelog b/abs/core-testing/fbsplash/__changelog
new file mode 100644
index 0000000..d673fc0
--- /dev/null
+++ b/abs/core-testing/fbsplash/__changelog
@@ -0,0 +1,4 @@
+modify  splash-functions to not use chvt for verbose
+modify  fbsplash.inithooks to not display "setting up splash"
+added default value for fbsplash.bootsteps
+
diff --git a/abs/core-testing/fbsplash/fbsplash.bootsteps b/abs/core-testing/fbsplash/fbsplash.bootsteps
new file mode 100644
index 0000000..7273c0f
--- /dev/null
+++ b/abs/core-testing/fbsplash/fbsplash.bootsteps
@@ -0,0 +1 @@
+25
diff --git a/abs/core-testing/fbsplash/fbsplash.inithooks b/abs/core-testing/fbsplash/fbsplash.inithooks
index dbf7b13..0e8c60c 100644
--- a/abs/core-testing/fbsplash/fbsplash.inithooks
+++ b/abs/core-testing/fbsplash/fbsplash.inithooks
@@ -58,7 +58,7 @@ start_daemon() {
 
 # rc.sysinit #
 if [ $CALLER == '/etc/rc.sysinit' ]; then
-	echo "fbsplash: Setting up splash..."
+#	echo "fbsplash: Setting up splash..."
 	splash_cache_prep
 	SPLASH_MAX_STEPS=$(load_boot_steps)
 	SPLASH_STEP_NR=0
@@ -77,7 +77,7 @@ fi
 
 # rc.shutdown #
 if [ $CALLER == '/etc/rc.shutdown' ]; then
-	echo "fbsplash: Setting up splash..."
+#	echo "fbsplash: Setting up splash..."
 	splash_cache_prep
 	SPLASH_MAX_STEPS=$(load_shutdown_steps)
 	SPLASH_SHUTDOWN_STEPS=1
-- 
cgit v0.12