From dedb21e5a8c02976e73586a04b825fdcdabbefc0 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 14 Jun 2009 11:51:50 -0500
Subject: windowmaker: add another windowmanager

---
 abs/extra-testing/windowmaker/PKGBUILD             |  31 +++++++++++++++++++++
 .../windowmaker/windowmaker-gcc4.patch.tar.bz2     | Bin 0 -> 39677 bytes
 2 files changed, 31 insertions(+)
 create mode 100644 abs/extra-testing/windowmaker/PKGBUILD
 create mode 100644 abs/extra-testing/windowmaker/windowmaker-gcc4.patch.tar.bz2

diff --git a/abs/extra-testing/windowmaker/PKGBUILD b/abs/extra-testing/windowmaker/PKGBUILD
new file mode 100644
index 0000000..5422f87
--- /dev/null
+++ b/abs/extra-testing/windowmaker/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 27785 2009-02-25 23:32:40Z eric $
+# Maintainer: aurelien <aurelien@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+pkgname=windowmaker
+pkgver=0.92.0
+pkgrel=5
+pkgdesc="An X11 window manager with a NEXTSTEP look and feel"
+arch=(i686 x86_64)
+url="http://www.windowmaker.info/"
+license=('GPL' 'custom')
+depends=('libxinerama' 'libpng' 'libxpm' 'libxft' 'libtiff' 'giflib')
+options=('!libtool')
+source=(http://windowmaker.info/pub/source/release/WindowMaker-$pkgver.tar.bz2 windowmaker-gcc4.patch.tar.bz2)
+md5sums=('aaac5421b686ed2d3e6ab65229c98097' 'd9fb6a9c255f5c03d0e0c83dc3cd2320')
+
+build() {
+  cd $srcdir/WindowMaker-$pkgver
+  patch -Np1 -i ../windowmaker-gcc4.patch || return 1
+  libtoolize --force --copy || return 1
+  aclocal || return 1
+  autoconf || return 1
+  automake || return 1
+  [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+  ./configure --prefix=/usr --sysconfdir=/etc \
+    --with-gnustepdir=/usr/share/GNUstep --with-nlsdir=/usr/share/locale \
+    --enable-xinerama  || return 1
+  make || return 1
+  make DESTDIR=$pkgdir install || return 1
+  install -D -m644 COPYING.WTFPL $pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL
+}
+
diff --git a/abs/extra-testing/windowmaker/windowmaker-gcc4.patch.tar.bz2 b/abs/extra-testing/windowmaker/windowmaker-gcc4.patch.tar.bz2
new file mode 100644
index 0000000..fae12a9
Binary files /dev/null and b/abs/extra-testing/windowmaker/windowmaker-gcc4.patch.tar.bz2 differ
-- 
cgit v0.12


From 1f1a531059fcee08f76660abd29a140de8b2b144 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 14 Jun 2009 11:52:25 -0500
Subject: wpa_supplicant: update to 0.6.9

---
 abs/core-testing/wpa_supplicant/PKGBUILD           |  29 ++--
 abs/core-testing/wpa_supplicant/config             | 146 ++++++++++++++++-----
 .../wpa_supplicant/wpa_supplicant.install          |  15 ---
 3 files changed, 124 insertions(+), 66 deletions(-)
 delete mode 100644 abs/core-testing/wpa_supplicant/wpa_supplicant.install

diff --git a/abs/core-testing/wpa_supplicant/PKGBUILD b/abs/core-testing/wpa_supplicant/PKGBUILD
index 2f6d45b..3ecc4a8 100644
--- a/abs/core-testing/wpa_supplicant/PKGBUILD
+++ b/abs/core-testing/wpa_supplicant/PKGBUILD
@@ -1,32 +1,31 @@
-# Contributor: iztok pizorn <pizorn@gmail.com>
-# Contributor: William Rea <sillywilly@gmail.com>
+# $Id: PKGBUILD 32196 2009-03-29 14:55:53Z thomas $
+# Maintainer: Thomas Baechler <thomas@archlinux.org>
+
 pkgname=wpa_supplicant
-pkgver=0.5.11
-_madwifi_ver=0.9.4
+pkgver=0.6.9
+#_madwifi_ver=0.9.4
 pkgrel=1
 pkgdesc="A utility providing key negotiation for WPA wireless networks"
 arch=('i686' 'x86_64')
-makedepends=('kernel26>=2.6.28' 'kernel26<2.6.29')
-depends=('openssl' 'dbus-core>=1.2.4')
+depends=('openssl' 'dbus-core>=1.2.4' 'readline' 'libnl')
 optdepends=('wpa_supplicant_gui: wpa_gui program')
 license=('GPL')
 groups=('base')
 backup=('etc/wpa_supplicant.conf')
 url="http://hostap.epitest.fi/wpa_supplicant"
 source=(http://hostap.epitest.fi/releases/wpa_supplicant-$pkgver.tar.gz
-        config
-	http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
-md5sums=('ad320af63f735531878e592f1ffd9b06'
-         '94fb8071fc440dca8294c9591486921f'
-         '399d20de8d855a59f20058857c2178ad')
+        config)
+        #http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
+md5sums=('0efb8fcedf0a8acf6f423dfdb0658fdd'
+         'd472554904cca44e1090e25dea7b03c9')
+         #'399d20de8d855a59f20058857c2178ad')
 
 build() {
   cd "${srcdir}"
-  mv madwifi-${_madwifi_ver} madwifi
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  cp ../config ./.config
+  #mv madwifi-${_madwifi_ver} madwifi
+  cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
+  cp ${srcdir}/config ./.config
   sed -i 's@/usr/local@$(PREFIX)@g' Makefile
-  sed -i 's@dynamic_eap_methods@@g' Makefile
   make || return 1
   make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
   install -m755 -d "${pkgdir}/etc"
diff --git a/abs/core-testing/wpa_supplicant/config b/abs/core-testing/wpa_supplicant/config
index 6ca1d3e..e3582bf 100644
--- a/abs/core-testing/wpa_supplicant/config
+++ b/abs/core-testing/wpa_supplicant/config
@@ -41,7 +41,7 @@
 
 
 # Driver interface for Host AP driver
-CONFIG_DRIVER_HOSTAP=y
+#CONFIG_DRIVER_HOSTAP=y
 
 # Driver interface for Agere driver
 #CONFIG_DRIVER_HERMES=y
@@ -50,14 +50,14 @@ CONFIG_DRIVER_HOSTAP=y
 #CFLAGS += -I../../include/wireless
 
 # Driver interface for madwifi driver
-CONFIG_DRIVER_MADWIFI=y
-# Change include directories to match with the local setup
-CFLAGS += -I../madwifi
+#CONFIG_DRIVER_MADWIFI=y
+# Set include directory to the madwifi source tree
+#CFLAGS += -I../../madwifi
 
 # Driver interface for Prism54 driver
 # (Note: Prism54 is not yet supported, i.e., this will not work as-is and is
 # for developers only)
-CONFIG_DRIVER_PRISM54=y
+#CONFIG_DRIVER_PRISM54=y
 
 # Driver interface for ndiswrapper
 CONFIG_DRIVER_NDISWRAPPER=y
@@ -65,17 +65,26 @@ CONFIG_DRIVER_NDISWRAPPER=y
 # Driver interface for Atmel driver
 CONFIG_DRIVER_ATMEL=y
 
-# Driver interface for Broadcom driver
+# Driver interface for old Broadcom driver
+# Please note that the newer Broadcom driver ("hybrid Linux driver") supports
+# Linux wireless extensions and does not need (or even work) with the old
+# driver wrapper. Use CONFIG_DRIVER_WEXT=y with that driver.
 #CONFIG_DRIVER_BROADCOM=y
 # Example path for wlioctl.h; change to match your configuration
 #CFLAGS += -I/opt/WRT54GS/release/src/include
 
 # Driver interface for Intel ipw2100/2200 driver
-CONFIG_DRIVER_IPW=y
+#CONFIG_DRIVER_IPW=y
+
+# Driver interface for Ralink driver
+#CONFIG_DRIVER_RALINK=y
 
 # Driver interface for generic Linux wireless extensions
 CONFIG_DRIVER_WEXT=y
 
+# Driver interface for Linux drivers using the nl80211 kernel interface
+CONFIG_DRIVER_NL80211=y
+
 # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
 #CONFIG_DRIVER_BSD=y
 #CFLAGS += -I/usr/local/include
@@ -103,6 +112,9 @@ CONFIG_DRIVER_WEXT=y
 # Driver interface for wired Ethernet drivers
 CONFIG_DRIVER_WIRED=y
 
+# Driver interface for the Broadcom RoboSwitch family
+#CONFIG_DRIVER_ROBOSWITCH=y
+
 # Enable IEEE 802.1X Supplicant (automatically included if any EAP method is
 # included)
 CONFIG_IEEE8021X_EAPOL=y
@@ -122,6 +134,13 @@ CONFIG_EAP_PEAP=y
 # EAP-TTLS
 CONFIG_EAP_TTLS=y
 
+# EAP-FAST
+# Note: Default OpenSSL package does not include support for all the
+# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
+# the OpenSSL library must be patched (openssl-0.9.8d-tls-extensions.patch)
+# to add the needed functions.
+#CONFIG_EAP_FAST=y
+
 # EAP-GTC
 CONFIG_EAP_GTC=y
 
@@ -143,6 +162,13 @@ CONFIG_EAP_LEAP=y
 # EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used)
 #CONFIG_EAP_AKA=y
 
+# EAP-AKA' (enable CONFIG_PCSC, if EAP-AKA' is used).
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
+# Enable USIM simulator (Milenage) for EAP-AKA
+#CONFIG_USIM_SIMULATOR=y
+
 # EAP-SAKE
 #CONFIG_EAP_SAKE=y
 
@@ -151,6 +177,15 @@ CONFIG_EAP_LEAP=y
 # Include support for optional SHA256 cipher suite in EAP-GPSK
 #CONFIG_EAP_GPSK_SHA256=y
 
+# EAP-TNC and related Trusted Network Connect support (experimental)
+#CONFIG_EAP_TNC=y
+
+# Wi-Fi Protected Setup (WPS)
+CONFIG_WPS=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
 # PKCS#12 (PFX) support (used to read private key and certificate file from
 # a file that usually has extension .p12 or .pfx)
 CONFIG_PKCS12=y
@@ -166,13 +201,10 @@ CONFIG_SMARTCARD=y
 # Development testing
 #CONFIG_EAPOL_TEST=y
 
-# Replace native Linux implementation of packet sockets with libdnet/libpcap.
-# This will be automatically set for non-Linux OS.
-#CONFIG_DNET_PCAP=y
-
 # Select control interface backend for external programs, e.g, wpa_cli:
 # unix = UNIX domain sockets (default for Linux/*BSD)
-# udp = UDP sockets (default for Windows)
+# udp = UDP sockets using localhost (127.0.0.1)
+# named_pipe = Windows Named Pipe (default for Windows)
 # y = use default (backwards compatibility)
 # If this option is commented out, control interface is not included in the
 # build.
@@ -182,7 +214,7 @@ CONFIG_CTRL_IFACE=y
 # When building a wpa_cli binary for distribution, please note that these
 # libraries are licensed under GPL and as such, BSD license may not apply for
 # the resulting binary.
-#CONFIG_READLINE=y
+CONFIG_READLINE=y
 
 # Remove debugging code that is printing out debug message to stdout.
 # This can be used to reduce the size of the wpa_supplicant considerably
@@ -199,16 +231,39 @@ CONFIG_CTRL_IFACE=y
 # or 6 kB if building for WPA-Enterprise.
 #CONFIG_NO_WPA2=y
 
+# Remove IEEE 802.11i/WPA-Personal ASCII passphrase support
+# This option can be used to reduce code size by removing support for
+# converting ASCII passphrases into PSK. If this functionality is removed, the
+# PSK can only be configured as the 64-octet hexstring (e.g., from
+# wpa_passphrase). This saves about 0.5 kB in code size.
+#CONFIG_NO_WPA_PASSPHRASE=y
+
 # Remove AES extra functions. This can be used to reduce code size by about
 # 1.5 kB by removing extra AES modes that are not needed for commonly used
 # client configurations (they are needed for some EAP types).
 #CONFIG_NO_AES_EXTRAS=y
 
+# Disable scan result processing (ap_mode=1) to save code size by about 1 kB.
+# This can be used if ap_scan=1 mode is never enabled.
+#CONFIG_NO_SCAN_PROCESSING=y
+
 # Select configuration backend:
-# file = text file (e.g., wpa_supplicant.conf)
+# file = text file (e.g., wpa_supplicant.conf; note: the configuration file
+#	path is given on command line, not here; this option is just used to
+#	select the backend that allows configuration files to be used)
 # winreg = Windows registry (see win_example.reg for an example)
 CONFIG_BACKEND=file
 
+# Remove configuration write functionality (i.e., to allow the configuration
+# file to be updated based on runtime configuration changes). The runtime
+# configuration can still be changed, the changes are just not going to be
+# persistent over restarts. This option can be used to reduce code size by
+# about 3.5 kB.
+#CONFIG_NO_CONFIG_WRITE=y
+
+# Remove support for configuration blobs to reduce code size by about 1.5 kB.
+#CONFIG_NO_CONFIG_BLOBS=y
+
 # Select program entry point implementation:
 # main = UNIX/POSIX like main() function (default)
 # main_winsvc = Windows service (read parameters from registry)
@@ -236,13 +291,15 @@ CONFIG_BACKEND=file
 # none = Empty template
 #CONFIG_L2_PACKET=linux
 
-# IEEE 802.11i/IEEE 802.11e STAKey negotiation for direct link connection
-#CONFIG_STAKEY=y
-
-# Proposed replacement for STAKey negotiation: PeerKey handshake for
-# Station to Station Link
+# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
 CONFIG_PEERKEY=y
 
+# IEEE 802.11w (management frame protection)
+# This version is an experimental implementation based on IEEE 802.11w/D1.0
+# draft and is subject to change since the standard has not yet been finalized.
+# Driver support is also needed for IEEE 802.11w.
+#CONFIG_IEEE80211W=y
+
 # Select TLS implementation
 # openssl = OpenSSL (default)
 # gnutls = GnuTLS (needed for TLS/IA, see also CONFIG_GNUTLS_EXTRA)
@@ -259,14 +316,22 @@ CONFIG_PEERKEY=y
 #CONFIG_GNUTLS_EXTRA=y
 
 # If CONFIG_TLS=internal is used, additional library and include paths are
-# needed for LibTomCrypt and TomsFastMath.
-#LTC_PATH=/usr/src/libtomcrypt-1.11
-#TFM_PATH=/usr/src/tomsfastmath-0.09
-#CFLAGS += -I$(LTC_PATH)/src/headers
-#LIBS += -L$(LTC_PATH) -L$(TFM_PATH)
-#LIBS_p += -L$(LTC_PATH) -L$(TFM_PATH)
-
-# Integrate ndis_events.exe functionality into wpa_supplicant.
+# needed for LibTomMath. Alternatively, an integrated, minimal version of
+# LibTomMath can be used. See beginning of libtommath.c for details on benefits
+# and drawbacks of this option.
+#CONFIG_INTERNAL_LIBTOMMATH=y
+#ifndef CONFIG_INTERNAL_LIBTOMMATH
+#LTM_PATH=/usr/src/libtommath-0.39
+#CFLAGS += -I$(LTM_PATH)
+#LIBS += -L$(LTM_PATH)
+#LIBS_p += -L$(LTM_PATH)
+#endif
+# At the cost of about 4 kB of additional binary size, the internal LibTomMath
+# can be configured to include faster routines for exptmod, sqr, and div to
+# speed up DH and RSA calculation considerably
+#CONFIG_INTERNAL_LIBTOMMATH_FAST=y
+
+# Include NDIS event processing through WMI into wpa_supplicant/wpasvc.
 # This is only for Windows builds and requires WMI-related header files and
 # WbemUuid.Lib from Platform SDK even when building with MinGW.
 #CONFIG_NDIS_EVENTS_INTEGRATED=y
@@ -294,15 +359,24 @@ CONFIG_CTRL_IFACE_DBUS=y
 # Please also note that using dynamic libraries will increase the total binary
 # size. Thus, it may not be the best option for targets that have limited
 # amount of memory/flash.
-CONFIG_DYNAMIC_EAP_METHODS=y
+#CONFIG_DYNAMIC_EAP_METHODS=y
 
 # Include client MLME (management frame processing).
-# This can be used to move MLME processing of Devicescape IEEE 802.11 stack
-# into user space.
+# This can be used to move MLME processing of Linux mac80211 stack into user
+# space. Please note that this is currently only available with
+# driver_nl80211.c and only with a modified version of Linux kernel and
+# wpa_supplicant.
 #CONFIG_CLIENT_MLME=y
-# Currently, driver_devicescape.c build requires some additional parameters
-# to be able to include some of the kernel header files. Following lines can
-# be used to set these (WIRELESS_DEV must point to the root directory of the
-# wireless-dev.git tree).
-WIRELESS_DEV=/lib/modules/2.6.27-ARCH/build
-CFLAGS += -I$(WIRELESS_DEV)/net/mac80211
+
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
+#CONFIG_IEEE80211R=y
+
+# Add support for writing debug log to a file (/tmp/wpa_supplicant-log-#.txt)
+#CONFIG_DEBUG_FILE=y
+
+# Enable privilege separation (see README 'Privilege separation' for details)
+#CONFIG_PRIVSEP=y
+
+# Enable mitigation against certain attacks against TKIP by delaying Michael
+# MIC error reports by a random amount of time between 0 and 60 seconds
+#CONFIG_DELAYED_MIC_ERROR_REPORT=y
diff --git a/abs/core-testing/wpa_supplicant/wpa_supplicant.install b/abs/core-testing/wpa_supplicant/wpa_supplicant.install
deleted file mode 100644
index 0c31765..0000000
--- a/abs/core-testing/wpa_supplicant/wpa_supplicant.install
+++ /dev/null
@@ -1,15 +0,0 @@
-# arg 1:  the new package version
-post_install() {
-  post_upgrade
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-  echo "==> For wpa_gui please install 'wpa_supplicant_gui'"
-}
-
-op=$1
-shift
-
-$op $* 
-- 
cgit v0.12


From 55162685e6bc46ba6ab048a1b69cffbab82a4354 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 14 Jun 2009 12:21:08 -0500
Subject: linhes-config: add support for WPA/WEP/NONE using wpa_supplicant.
 Currently it only works when using dhcp, but this is an upstream problem with
 etcnet. new mythvantage

---
 abs/core-testing/LinHES-config/PKGBUILD      |   2 +-
 abs/core-testing/LinHES-config/mv_network.py | 103 +++++++++++++++++++++++----
 2 files changed, 92 insertions(+), 13 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 2091f09..36a9184 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=10
+pkgrel=11
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
diff --git a/abs/core-testing/LinHES-config/mv_network.py b/abs/core-testing/LinHES-config/mv_network.py
index ca29c7d..3978f95 100755
--- a/abs/core-testing/LinHES-config/mv_network.py
+++ b/abs/core-testing/LinHES-config/mv_network.py
@@ -82,6 +82,64 @@ def setup_hostname(systemconfig):
     cmd = '''cat /tmp/hosts >> /etc/hosts '''
     mv_common.runcmd(cmd)
 
+
+def write_wpafile(line,netdev):
+    logging.debug("    writing out wpa_supplicant.conf file")
+    logging.debug(line)
+    wpafile = etcnetdir+"/"+netdev+"/wpa_supplicant.conf"
+    try:
+        f = open(wpafile,'w')
+        f.write(line)
+        f.close()
+    except:
+        logging.debug("    Couldn't write to %s",wpafile)
+
+def setup_wpa(netinfo,netdev):
+    logging.info("    %s will use wpa for encryption",netdev)
+    line = '''
+#This file was automaticly generated, any changes may be lost
+ctrl_interface=/var/run/wpa_supplicant
+network={
+    ssid="%s"
+    # Preshared key as an ASCII passphrase
+    psk="%s"
+    scan_ssid=1
+    key_mgmt=WPA-EAP WPA-PSK NONE
+    pairwise=CCMP TKIP
+    proto=WPA RSN
+}''' %(netinfo["ESSID"],netinfo["KEY"])
+    write_wpafile(line,netdev)
+
+def setup_wep(netinfo,netdev):
+    logging.info("    %s will use wep for encryption",netdev)
+    logging.debug("    When a packet comes along, you must wep it")
+    line='''
+#This file was automaticly generated, any changes may be lost
+ctrl_interface=/var/run/wpa_supplicant
+network={
+        ssid="%s"
+        key_mgmt=NONE
+        wep_key0=%s
+        wep_tx_keyidx=0
+        scan_ssid=1
+        auth_alg=SHARED
+}
+''' %(netinfo["ESSID"],netinfo["KEY"])
+    write_wpafile(line,netdev)
+
+
+def setup_none(netinfo,netdev):
+    logging.info("    %s will not use encryption",netdev)
+    line = '''
+#This file was automaticly generated, any changes may be lost
+ctrl_interface=/var/run/wpa_supplicant
+network={
+        ssid="%s"
+        key_mgmt=NONE
+}
+''' %netinfo["ESSID"]
+    write_wpafile(line,netdev)
+
 def setup_interface(netdev,systemconfig):
     logging.debug("    _Start of setup_interface for %s",netdev)
     nettrans = {'Hostip':'ip',
@@ -93,7 +151,7 @@ def setup_interface(netdev,systemconfig):
                 'HostMTU':'mtu',
                 'HOST_iswireless':"wireless",
                 'HostESSID':'ESSID',
-                'HostKey':'key',
+                'HostKey':'KEY',
                 'HostUseEncryption':'ENCRYPT'}
     netinfo = {}
     #populate the netinfo dict
@@ -120,20 +178,26 @@ def setup_interface(netdev,systemconfig):
         change_iface_state(netdev,"disabled")
 
     if netinfo["wireless"] == "1" :
+
         logging.info("    Enabling wireless extensions")
         cmd = ''' sed -i -e 's/^CONFIG_WIRELESS=.*$/CONFIG_WIRLESS=yes/g'  %s/%s/options''' %(etcnetdir,netdev)
         mv_common.runcmd(cmd)
-        #set the key and essid
-        cmd = '''  echo "essid  %s" > %s/%s/iwconfig ''' %(netinfo["ESSID"], etcnetdir, netdev)
-        mv_common.runcmd(cmd)
-        if netinfo["ENCRYPT"] == "1":
-            logging.info("    Enabling encryption")
-            cmd = '''echo "key %s" >>  %s/%s/iwconfig ''' %(netinfo["KEY"], etcnetdir, netdev)
-            mv_common.runcmd(cmd)
+        if netinfo["ENCRYPT"] == "WEP":
+            setup_wep(netinfo,netdev)
+        elif netinfo["ENCRYPT"] == "WPA":
+            setup_wpa(netinfo,netdev)
+        elif netinfo["ENCRYPT"] == "none":
+            setup_none(netinfo,netdev)
+
     else:
         logging.info("    Disabling wireless extensions")
         cmd = '''sed -i -e 's/^CONFIG_WIRLESS=.*$/CONFIG_WIRLESS=no/g' %s/%s/options''' %(etcnetdir, netdev)
         mv_common.runcmd(cmd)
+        try:
+            wpafile=etcnetdir+"/"+netdev+"/wpa_supplicant.conf"
+            os.remove(wpafile)
+        except:
+            logging.debug("    Couldn't remove %s",wpafile)
 
     if netinfo["UseDHCP"] == "0" :
         logging.info("    Enabling DHCP support")
@@ -179,8 +243,16 @@ def change_iface_state(netdev, state):
         cmd = "ip address flush %s" %netdev
         mv_common.runcmd(cmd)
 
+def devcheck(netdev):
+    cmd = ''' /sbin/ifconfig %s''' %netdev
+    rc = mv_common.runcmd(cmd)
+    if rc == 0 :
+        return True
+    else:
+        return False
+
 def find_active(systemconfig):
-    interfacelist=('eth0', 'eth1', 'wlan0', 'wlan1')
+    interfacelist=('eth0', 'eth1', 'wlan0', 'wlan1', 'ath0')
     logging.debug("    _Start of find_active")
 
     if systemconfig["mythdhcp"] == "1":
@@ -199,9 +271,15 @@ def find_active(systemconfig):
             systemconfig[currentnet]
         except:
             logging.debug("    %s is not defined",currentnet)
+            change_iface_state(netdev, "disabled")
             continue
         if systemconfig[currentnet] == "1" :
-            setup_interface(netdev,systemconfig)
+            #check if device is present
+            if devcheck(netdev) :
+                setup_interface(netdev,systemconfig)
+            else:
+                logging.debug("    Interface %s not found in config", netdev)
+                #change_iface_state(netdev, "disabled")
         else:
             change_iface_state(netdev, "disabled")
 
@@ -232,7 +310,7 @@ def start_network():
         logging.info("    Restarting network")
         cmd ="/etc/net/scripts/network.init reload"
         mv_common.runcmd(cmd)
-        cmd ="/etc/net/scripts/network.init reload"
+        cmd ="/etc/net/scripts/network.init restart"
         mv_common.runcmd(cmd)
     else:
         logging.info("    Will not restart network due to netboot/vnc")
@@ -244,7 +322,7 @@ def stop_network():
         cmd ="/etc/net/scripts/network.init stop"
         mv_common.runcmd(cmd)
         kill_dhcp("")
-        interfacelist=('eth0', 'eth1', 'wlan0', 'wlan1')
+        interfacelist=('eth0', 'eth1', 'wlan0', 'wlan1', 'ath0')
         for i in interfacelist:
             flush(i)
     else:
@@ -258,6 +336,7 @@ def setup_network (systemconfig):
     logging.info("    Setting up the network")
     setup_hostname(systemconfig)
     find_active(systemconfig)
+    start_network()
     logging.info("__End of network\n")
 
 
-- 
cgit v0.12


From 118dc4012d2fa8f62dc55b9790c463e26bba842c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 14 Jun 2009 15:58:04 -0500
Subject: etcnet: updated to latest version 0.9.8

---
 abs/core-testing/etcnet/10-defaults     |  4 +++-
 abs/core-testing/etcnet/PKGBUILD        | 26 ++++++++++++--------------
 abs/core-testing/etcnet/functions.patch |  9 ++++-----
 3 files changed, 19 insertions(+), 20 deletions(-)

diff --git a/abs/core-testing/etcnet/10-defaults b/abs/core-testing/etcnet/10-defaults
index 5897a89..3aeac58 100644
--- a/abs/core-testing/etcnet/10-defaults
+++ b/abs/core-testing/etcnet/10-defaults
@@ -3,7 +3,9 @@ DHCP_ARGS=-L
 IP=/usr/sbin/ip
 TC=/usr/sbin/tc
 LSMOD=/bin/lsmod
-IFGROUP[1]='eth wlan plip usb dvb bnep tuntap'
+IFGROUP[1]='eth wlan plip usb dvb bnep tuntap ath0'
 IFRENAME=/usr/sbin/ifrename
 IPTABLES=/usr/sbin/iptables
 IP6TABLES=/usr/sbin/ip6tables
+AUTO_BROADCAST=on
+
diff --git a/abs/core-testing/etcnet/PKGBUILD b/abs/core-testing/etcnet/PKGBUILD
index 4b7e386..5b9ba2f 100755
--- a/abs/core-testing/etcnet/PKGBUILD
+++ b/abs/core-testing/etcnet/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=etcnet
-pkgver=0.9.7
-pkgrel=11
+pkgver=0.9.8
+pkgrel=5
 pkgdesc="/etc/net network configuration subsystem"
 url="http://etcnet.org/"
 depends=('bash' 'grep' 'sed' 'iproute' 'wireless_tools' 'iptables' 'dhcpcd')
@@ -13,20 +13,15 @@ build() {
   cd $startdir/src/$pkgname-$pkgver
   mkdir -p $startdir/pkg/var/lib/etcnet
   mkdir -p $startdir/pkg/etc/sysconfig
-
-
-
-
-
-  #cp $startdir/src/functions.patch ./etc/net
   cd etc/net
-  patch -p0 < $startdir/src/functions.patch
-
+  patch -p0 < $startdir/src/functions.patch || return 1
+   
+  install -D -m 644 $startdir/src/10-defaults  $startdir/pkg/etc/net/options.d/10-defaults
+  install -D -m 644 $startdir/src/network $startdir/pkg/etc/sysconfig/network
+  cp -rp $startdir/src/$pkgname-$pkgver/docs   $startdir/pkg/etc/net
+  cp -rp $startdir/src/$pkgname-$pkgver/examples   $startdir/pkg/etc/net
 
-   install -D -m 644 $startdir/src/10-defaults  $startdir/pkg/etc/net/options.d/10-defaults
-   install -D -m 644 $startdir/src/network $startdir/pkg/etc/sysconfig/network
-   cp -rp $startdir/src/$pkgname-$pkgver/docs   $startdir/pkg/etc/net
-#setup default for eth0  
+   #setup default for eth0  
   mkdir -p $startdir/pkg/etc/net/ifaces/eth0
   cp $startdir/src/options $startdir/pkg/etc/net/ifaces/eth0/options
   cp $startdir/src/ipv4route $startdir/pkg/etc/net/ifaces/eth0/ipv4route
@@ -35,5 +30,8 @@ build() {
   cd $startdir/src/$pkgname-$pkgver
   rm -Rf etc/sysconfig etc/net/{README.ALT,TODO,ChangeLog,ifaces/unknown}
   cp -Rf etc $startdir/pkg
+  cd $startdir/pkg/etc/net/scripts
+  ln -s ifup-ifplugd ifup-wireless
+  ln -s ifdown-ifplugd ifdown-wireless
    
 }
diff --git a/abs/core-testing/etcnet/functions.patch b/abs/core-testing/etcnet/functions.patch
index c2321b6..855ef90 100644
--- a/abs/core-testing/etcnet/functions.patch
+++ b/abs/core-testing/etcnet/functions.patch
@@ -1,12 +1,11 @@
---- scripts/functions.orig	2008-09-02 03:10:21.000000000 +0000
-+++ scripts/functions	2008-09-02 03:10:49.000000000 +0000
-@@ -16,7 +16,8 @@
+--- scripts/functions.orig	2009-06-14 17:24:46.000000000 +0000
++++ scripts/functions	2009-06-14 17:25:24.000000000 +0000
+@@ -16,7 +16,7 @@
  DEFAULT_IFPLUGSTATUS=/usr/sbin/ifplugstatus
  DEFAULT_IFPLUGD=/usr/sbin/ifplugd
  DEFAULT_IWPRIV=/sbin/iwpriv
 -DEFAULT_IWCONFIG=/sbin/iwconfig
-+#DEFAULT_IWCONFIG=/sbin/iwconfig
 +DEFAULT_IWCONFIG=/usr/sbin/iwconfig
+ DEFAULT_WLANCONFIG=/usr/sbin/wlanconfig
  DEFAULT_WPA_SUPPLICANT=/usr/sbin/wpa_supplicant
  DEFAULT_WPA_CLI=/usr/sbin/wpa_cli
- DEFAULT_PLIPCONFIG=/sbin/plipconfig
-- 
cgit v0.12


From 5aad939bf570591f61e59f0dab404be36a52cf8b Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 14 Jun 2009 15:58:40 -0500
Subject: linhes-config: fix problem which static ip's and network
 configuration. The netmask needed to be split.

---
 abs/core-testing/LinHES-config/PKGBUILD      | 2 +-
 abs/core-testing/LinHES-config/mv_network.py | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 36a9184..c000c02 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=11
+pkgrel=13
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
diff --git a/abs/core-testing/LinHES-config/mv_network.py b/abs/core-testing/LinHES-config/mv_network.py
index 3978f95..ae3aaf7 100755
--- a/abs/core-testing/LinHES-config/mv_network.py
+++ b/abs/core-testing/LinHES-config/mv_network.py
@@ -209,7 +209,7 @@ def setup_interface(netdev,systemconfig):
         mv_common.runcmd(cmd)
         cmd = '''echo "default via %s" > %s/%s/ipv4route''' %(netinfo["GW"], etcnetdir, netdev)
         mv_common.runcmd(cmd)
-        cmd = '''echo "%s%s" > %s/%s/ipv4address ''' %(netinfo["ip"], netinfo["netmask"], etcnetdir, netdev)
+        cmd = '''echo "%s%s" > %s/%s/ipv4address ''' %(netinfo["ip"], netinfo["netmask"].split()[0], etcnetdir, netdev)
         mv_common.runcmd(cmd)
         setup_nameserver(netinfo["dns"])
 
-- 
cgit v0.12