From 257586d195a7c79c270273b4ba85d2742c0a65c5 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 26 Jan 2009 16:40:42 -0600
Subject: cleanup of starting X Also fix status message for X not going to tty1

---
 abs/core-testing/LinHES-system/LinHES-session      |  2 +-
 abs/core-testing/LinHES-system/PKGBUILD            |  2 +-
 abs/core-testing/runit-scripts/PKGBUILD            |  2 +-
 .../runitscripts/services/frontend/finish          | 36 ++++++++++------------
 .../runitscripts/services/frontend/run             |  4 +++
 5 files changed, 23 insertions(+), 23 deletions(-)

diff --git a/abs/core-testing/LinHES-system/LinHES-session b/abs/core-testing/LinHES-system/LinHES-session
index 05fc6d1..52924d2 100755
--- a/abs/core-testing/LinHES-system/LinHES-session
+++ b/abs/core-testing/LinHES-system/LinHES-session
@@ -7,7 +7,7 @@ xhost +127.0.0.1
 xset -dpms s off
 export MALLOC_CHECK_=0
 #start fluxbox
-fluxbox
+fluxbox > /var/log/fluxbox.log 2>&1
 
 
 
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 90550e6..8989f9b 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=19
+pkgrel=20
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 0f84074..3811e1a 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=1.8.0
-pkgrel=28
+pkgrel=32
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/frontend/finish b/abs/core-testing/runit-scripts/runitscripts/services/frontend/finish
index e1e3e00..a01326c 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/frontend/finish
+++ b/abs/core-testing/runit-scripts/runitscripts/services/frontend/finish
@@ -7,24 +7,20 @@ STATUS=$?
         chvt 2
 else
 
-chvt 1
-if [ ! -d /etc/sv/frontend/.runtime ]
-then
-	mkdir  -p /etc/sv/frontend/.runtime
-fi
-
-touch /etc/sv/frontend/.runtime/`date +%s`
-sleep 0.2
-ps -U mythtv -ef |grep  "/bin/sh /usr/bin/startx"|grep -v grep|awk ' { print $2 } '|xargs kill -9  2> /dev/null
-
-
-cdate=`date`
-numfiles=`/usr/bin/file_time_offset.py   -s10 -d/etc/sv/frontend/.runtime`   
-
-if [ $numfiles -gt 2 ]
-then
- sv stop frontend
- rm -f /etc/sv/frontend/.runtime/*
- echo "Frontend is not able to start, disabling it"
-fi
+    chvt 1
+    if [ ! -d /etc/sv/frontend/.runtime ]
+    then
+	    mkdir  -p /etc/sv/frontend/.runtime
+    fi
+    touch /etc/sv/frontend/.runtime/`date +%s`
+    sleep 0.2
+    ps -U mythtv -ef |grep  "/bin/sh /usr/bin/startx"|grep -v grep|awk ' { print $2 } '|xargs kill -9  2> /dev/null
+    cdate=`date`
+    numfiles=`/usr/bin/file_time_offset.py   -s10 -d/etc/sv/frontend/.runtime`   
+    if [ $numfiles -gt 2 ]
+    then
+         sv stop frontend
+         rm -f /etc/sv/frontend/.runtime/*
+         echo "Frontend is not able to start, disabling it" >/dev/tty1
+    fi
 fi
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/frontend/run b/abs/core-testing/runit-scripts/runitscripts/services/frontend/run
index 12a787d..72423da 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/frontend/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/frontend/run
@@ -7,4 +7,8 @@ exec 2>&1
     sv down frontend
     exit 0
   fi
+touch /var/log/fluxbox.log
+chown mythtv:mythtv /var/log/fluxbox.log
+echo "Starting LinHES frontend" >/dev/tty1
 exec /bin/su - mythtv -l -c /usr/LH/bin/LinHES-start
+
-- 
cgit v0.12