From 12066094126b4b8d07e6c0df3dab6323d5d71571 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 20 Mar 2010 23:12:49 -0500
Subject: linhes-system: create cronjob for mythsmolt to checkin once a week
 with profile updates Also fixed myth_mtc.sh from being symlinked if it was
 already present on install/upgrade

closes 656
---
 abs/core-testing/LinHES-system/LinHES.install |  5 ++-
 abs/core-testing/LinHES-system/PKGBUILD       | 47 +++++++++++++++++++++++++--
 abs/core-testing/LinHES-system/smolt.cron     | 11 +++++++
 3 files changed, 59 insertions(+), 4 deletions(-)
 create mode 100644 abs/core-testing/LinHES-system/smolt.cron

diff --git a/abs/core-testing/LinHES-system/LinHES.install b/abs/core-testing/LinHES-system/LinHES.install
index 2d2bdf2..9f6a1c1 100644
--- a/abs/core-testing/LinHES-system/LinHES.install
+++ b/abs/core-testing/LinHES-system/LinHES.install
@@ -12,7 +12,10 @@ MVDIR=/usr/LH/bin
 #	ln -s  $MVDIR/backup_job /etc/cron.daily/backup_cron
 #	ln -s  $MVDIR/update_system  /etc/cron.daily/xupdate_system_cron
 #	ln -s  $MVDIR/repo_sync.sh  /etc/cron.daily/zrepo_sync.sh
-	ln -s  $MVDIR/myth_mtc.sh  /etc/cron.daily/myth_mtc.sh
+	if [ ! -e /etc/cron.daily/myth_mtc.sh ]
+	then
+		ln -s  $MVDIR/myth_mtc.sh  /etc/cron.daily/myth_mtc.sh
+	fi
 
 #LINE="mythtv    ALL = NOPASSWD: /sbin/sv stop mythbackend"
 LINE="mythtv 	ALL=(ALL)       NOPASSWD: ALL"
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index f9c1a97..5616746 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
-pkgver=1.0
-pkgrel=75
+pkgver=1.1
+pkgrel=9
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
@@ -8,7 +8,7 @@ install=LinHES.install
 pkgdesc="scripts and things related to having a automated system"
 depends=(linhes-sounds xdotool)
 backup=(etc/modprobe.d/alsa-base)
-binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh myth_mtc.lr"
+binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh myth_mtc.lr smolt.cron "
 
 source=(LinHES-session LinHES-profile.sh $binfiles alsa-base)
 
@@ -36,7 +36,48 @@ do
 
 done	
 install -m755 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base
+install -m755 -D $startdir/src/smolt.cron $startdir/pkg/etc/cron.weekly/smolt.cron
 mkdir $startdir/pkg/etc/logrotate.d
 cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
 }
 
+
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+         '5881bdb43d578ec3a79d1f77ea58a3db'
+         'a875ee97f86e46f34a741c2bc455f894'
+         'cdcbc530224215f8fcf7ebcd93d7eb0b'
+         'c60b6c66f498809a6e5ca18a8c97d336'
+         'ccae1296ef248fa52ec3a7cb820a476e'
+         '6112f32c48763a057341ccfb18d2375a'
+         '18a884a73344ff6eb74f63b49745e0f5'
+         'dc3eef2a624754e16805d72bbe488b67'
+         '72eb4117bb7d523691233c40e7535752'
+         'f1870a9522c79e6b248fcbf81dec3280'
+         '90a5d903e11e8bb457855d2ffd657e1e'
+         'eb879fee9603a05d5420d4ce8ed9e450')
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+         '5881bdb43d578ec3a79d1f77ea58a3db'
+         'a875ee97f86e46f34a741c2bc455f894'
+         'cdcbc530224215f8fcf7ebcd93d7eb0b'
+         'c60b6c66f498809a6e5ca18a8c97d336'
+         'ccae1296ef248fa52ec3a7cb820a476e'
+         '6112f32c48763a057341ccfb18d2375a'
+         '18a884a73344ff6eb74f63b49745e0f5'
+         'dc3eef2a624754e16805d72bbe488b67'
+         '72eb4117bb7d523691233c40e7535752'
+         'f1870a9522c79e6b248fcbf81dec3280'
+         'f891f01eac77a1a9cd3d638c28ae4b3a'
+         'eb879fee9603a05d5420d4ce8ed9e450')
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+         '5881bdb43d578ec3a79d1f77ea58a3db'
+         'a875ee97f86e46f34a741c2bc455f894'
+         'cdcbc530224215f8fcf7ebcd93d7eb0b'
+         'c60b6c66f498809a6e5ca18a8c97d336'
+         'ccae1296ef248fa52ec3a7cb820a476e'
+         '6112f32c48763a057341ccfb18d2375a'
+         '18a884a73344ff6eb74f63b49745e0f5'
+         'dc3eef2a624754e16805d72bbe488b67'
+         '72eb4117bb7d523691233c40e7535752'
+         'f1870a9522c79e6b248fcbf81dec3280'
+         'abe887472a170bd1a8e6da6a7b7e93e4'
+         'eb879fee9603a05d5420d4ce8ed9e450')
diff --git a/abs/core-testing/LinHES-system/smolt.cron b/abs/core-testing/LinHES-system/smolt.cron
new file mode 100644
index 0000000..f418df1
--- /dev/null
+++ b/abs/core-testing/LinHES-system/smolt.cron
@@ -0,0 +1,11 @@
+#!/bin/bash
+. /etc/profile
+if  [ -f  /home/mythtv/.mythtv/MythSmolt/hw-uuid ] 
+then
+	cd /usr/share/mythtv/mythsmolt/scripts
+	touch /var/log/smolt.update
+	chown mythtv /var/log/smolt.update
+	random=$((RANDOM%2000))
+	sleep $random
+	su mythtv -c "./sendProfile.py -a" > /var/log/smolt.update
+fi
-- 
cgit v0.12