From e24c0d85c9e4a0d6ec770aa5f930daef20ca0fd5 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 27 Mar 2010 20:53:53 -0500
Subject: mythsmolt:  added smolt_init_login.sh This file is run on login, and
 if the user is root or mythtv is prompts if they want to run mythsmolt. It
 will only ask once, after the initial prompt logins return to normal. However
 if the real or fake hw-uuid file is removed the prompt will return

closes #668
---
 .../mythtv/stable-0.22/mythsmolt/PKGBUILD          |  9 ++++----
 .../stable-0.22/mythsmolt/smolt_init_login.sh      | 24 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 4 deletions(-)
 create mode 100644 abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh

diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
index e609048..42674dd 100644
--- a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
@@ -1,12 +1,12 @@
 pkgname=mythsmolt
 pkgver=0.22
-pkgrel=16
+pkgrel=17
 pkgdesc="mythsmolt, a hardware profileing tool"
 arch=('i686' 'x86_64')
 url="http://www.mythvantage.com"
 license=('GPL')
 depends=("mythtv>=${pkgver}" urlgrabber python-simplejson)
-source=("http://www.mythvantage.com/request.php?4")
+source=("http://www.mythvantage.com/request.php?4" 'smolt_init_login.sh' )
 
 groups=('mythtv-extras')
 
@@ -15,6 +15,7 @@ build() {
    ./configure.sh
    make || return 1
    make INSTALL_ROOT=$startdir/pkg install
+   install -D -m 755 $srcdir/smolt_init_login.sh $pkgdir/etc/profile.d/smolt_init_login.sh
 }
-md5sums=('b8e9b79db0d8f428ba127c6e42577761')
-md5sums=('fdf68ec5c78827aefca6f09ad82296a4')
+md5sums=('fdf68ec5c78827aefca6f09ad82296a4'
+         'c6789befd70278a453dc6be73ed240e7')
diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
new file mode 100644
index 0000000..f22a09e
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
@@ -0,0 +1,24 @@
+if [ $UID = 0  -o  $UID = 1000 ]
+then
+    if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+    then
+        echo ""
+        echo "####################################################"
+        echo "It appears you have not yet run smolt"
+        echo "Please take the time to submit your hardware profile"
+        echo ""
+        echo "press any key to continue:"
+        echo "####################################################"
+        read a
+        if [ $UID = 0 ]
+        then
+            su   mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py"
+            su mythtv -c "touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+        else
+            /usr/share/mythtv/mythsmolt/scripts/sendProfile.py
+            touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid
+        fi
+        
+    fi
+fi
+
-- 
cgit v0.12