From 1f3b4ba1dd55908ecb5b5d2ab307d4cd1b108ca2 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 4 Sep 2010 16:46:21 -0700
Subject: libldap:Bumped/Updated for LinHES 7.

---
 abs/core-testing/libldap/PKGBUILD   |  74 +++++++++++--------
 abs/core-testing/libldap/ntlm.patch | 139 +++++++++++++++++++++++-------------
 2 files changed, 133 insertions(+), 80 deletions(-)

diff --git a/abs/core-testing/libldap/PKGBUILD b/abs/core-testing/libldap/PKGBUILD
index 616e6a3..06babfd 100644
--- a/abs/core-testing/libldap/PKGBUILD
+++ b/abs/core-testing/libldap/PKGBUILD
@@ -1,62 +1,74 @@
-# $Id: PKGBUILD 1627 2008-05-14 03:02:30Z eric $
-# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+# $Id: PKGBUILD 83737 2010-06-22 18:32:52Z andrea $
+# Maintainer:
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
 pkgname=libldap
-pkgver=2.4.11
+pkgver=2.4.22
 pkgrel=1
-pkgdesc="LDAP client libraries"
-arch=(i686 x86_64)
+pkgdesc="Lightweight Directory Access Protocol (LDAP) client libraries"
+arch=('i686' 'x86_64')
 license=('custom')
 url="http://www.openldap.org/"
 backup=(etc/openldap/ldap.conf)
-depends=('libsasl' 'openssl>=0.9.8f')
-options=('!libtool' '!makeflags')
+depends=('libsasl' 'openssl')
 makedepends=('tcp_wrappers')
-source=(ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/openldap-${pkgver}.tgz
-	ntlm.patch
-	peercred.patch)
+options=('!libtool')
+source=("ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/openldap-${pkgver}.tgz"
+        'ntlm.patch')
+md5sums=('ef01b52255ce8e3fbf8aa34f6fe7598b'
+         'dfa9eb6f2fd9d0a3dab0e1860923489e')
 
 build() {
-  cd ${startdir}/src/openldap-${pkgver}
-#  patch -Np0 -i ${startdir}/src/ntlm.patch || return 1
-  patch -Np0 -i ${startdir}/src/peercred.patch || return 1
+  cd ${srcdir}/openldap-${pkgver}
+
+  patch -Np1 -i ${srcdir}/ntlm.patch
 
   ./configure --prefix=/usr \
               --libexecdir=/usr/sbin \
               --sysconfdir=/etc \
+	      --mandir=/usr/share/man \
               --localstatedir=/var/lib/openldap \
               --enable-crypt --enable-dynamic \
               --with-threads --enable-wrappers \
 	      --enable-spasswd --with-cyrus-sasl \
 	      --disable-bdb --disable-hdb
+
   cd include
-  make || return 1
-  make DESTDIR=${startdir}/pkg install
+  make
 
   cd ../libraries
   make depend
-  make || return 1
-
-  make DESTDIR=${startdir}/pkg install
+  make
 
   cd ../doc/man/man3
   make
-  make DESTDIR=${startdir}/pkg install
+  
+  cd ../man5
+  make
+}
+
+package() {
+  cd ${srcdir}/openldap-${pkgver}
+
+  cd include
+  make DESTDIR=${pkgdir} install
+
+  cd ../libraries
+  make DESTDIR=${pkgdir} install
+
+  cd ../doc/man/man3
+  make DESTDIR=${pkgdir} install
 
   cd ../man5
-  make 
-  mkdir -p ${startdir}/pkg/usr/man/man5
-  install -m644 ldap.conf.5.tmp ${startdir}/pkg/usr/man/man5/ldap.conf.5
+  install -Dm644 ldap.conf.5.tmp \
+    ${pkgdir}/usr/share/man/man5/ldap.conf.5
   
   # get rid of duplicate default conf files
-  rm ${startdir}/pkg/etc/openldap/*.default
+  rm ${pkgdir}/etc/openldap/*.default
 
-  ln -sf liblber.so ${startdir}/pkg/usr/lib/liblber.so.2
-  ln -sf libldap.so ${startdir}/pkg/usr/lib/libldap.so.2
+  ln -sf liblber.so ${pkgdir}/usr/lib/liblber.so.2
+  ln -sf libldap.so ${pkgdir}/usr/lib/libldap.so.2
 
-  mkdir -p ${startdir}/pkg/usr/share/licenses/openldap
-  install -m644 ${startdir}/src/openldap-${pkgver}/LICENSE \
-    ${startdir}/pkg/usr/share/licenses/openldap/
+  install -Dm644 ${srcdir}/openldap-${pkgver}/LICENSE \
+    ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
 }
-md5sums=('920fedbbb5bc61c2ca52c56edeef770a'
-         '64c539d5f01f46f329b9d5c1324be4e9'
-	 'acc4112845522a6a1a517064c216f781')
diff --git a/abs/core-testing/libldap/ntlm.patch b/abs/core-testing/libldap/ntlm.patch
index fca806b..a4fe4d4 100644
--- a/abs/core-testing/libldap/ntlm.patch
+++ b/abs/core-testing/libldap/ntlm.patch
@@ -1,25 +1,50 @@
---- libraries/libldap/Makefile.in.orig	2004-01-01 13:16:29.000000000 -0500
-+++ libraries/libldap/Makefile.in	2004-07-14 13:37:23.000000000 -0400
-@@ -20,7 +20,7 @@
- SRCS	= bind.c open.c result.c error.c compare.c search.c \
- 	controls.c messages.c references.c extended.c cyrus.c \
- 	modify.c add.c modrdn.c delete.c abandon.c \
--	sasl.c sbind.c kbind.c unbind.c cancel.c  \
-+	sasl.c ntlm.c sbind.c kbind.c unbind.c cancel.c  \
- 	filter.c free.c sort.c passwd.c whoami.c \
- 	getdn.c getentry.c getattr.c getvalues.c addentry.c \
- 	request.c os-ip.c url.c sortctrl.c vlvctrl.c \
-@@ -29,7 +29,7 @@
- OBJS	= bind.lo open.lo result.lo error.lo compare.lo search.lo \
- 	controls.lo messages.lo references.lo extended.lo cyrus.lo \
- 	modify.lo add.lo modrdn.lo delete.lo abandon.lo \
--	sasl.lo sbind.lo kbind.lo unbind.lo cancel.lo \
-+	sasl.lo ntlm.lo sbind.lo kbind.lo unbind.lo cancel.lo \
- 	filter.lo free.lo sort.lo passwd.lo whoami.lo \
- 	getdn.lo getentry.lo getattr.lo getvalues.lo addentry.lo \
- 	request.lo os-ip.lo url.lo sortctrl.lo vlvctrl.lo \
---- /dev/null	1970-01-01 01:00:00.000000000 +0100
-+++ libraries/libldap/ntlm.c	2005-12-02 09:47:08.226364500 +0100
+Patch from evolution-exchange (2.10.3).  The ldap_ntlm_bind function is
+actually called by evolution-data-server, checked at version 1.12.2.
+Without this patch, the Exchange addressbook integration uses simple binds
+with cleartext passwords.
+
+Russ checked with openldap-software for upstream's opinion on this patch
+on 2007-12-21.  Upstream had never received it as a patch submission and
+given that it's apparently only for older Exchange servers that can't do
+SASL and DIGEST-MD5, it's not very appealing.
+
+Bug#457374 filed against evolution-data-server asking if this support is
+still required on 2007-12-21.
+
+Index: trunk/include/ldap.h
+===================================================================
+--- trunk.orig/include/ldap.h
++++ trunk/include/ldap.h
+@@ -2461,5 +2461,25 @@
+ 	LDAPControl	**ctrls,
+ 	LDAPDerefRes	**drp ));
+ 
++/*
++ * hacks for NTLM
++ */
++#define LDAP_AUTH_NTLM_REQUEST ((ber_tag_t) 0x8aU)
++#define LDAP_AUTH_NTLM_RESPONSE  ((ber_tag_t) 0x8bU)
++LDAP_F( int )
++ldap_ntlm_bind LDAP_P((
++      LDAP    *ld,
++      LDAP_CONST char *dn,
++      ber_tag_t tag,
++      struct berval *cred,
++      LDAPControl **sctrls,
++      LDAPControl **cctrls,
++      int   *msgidp ));
++LDAP_F( int )
++ldap_parse_ntlm_bind_result LDAP_P((
++      LDAP    *ld,
++      LDAPMessage *res,
++      struct berval *challenge));
++
+ LDAP_END_DECL
+ #endif /* _LDAP_H */
+Index: trunk/libraries/libldap/ntlm.c
+===================================================================
+--- /dev/null
++++ trunk/libraries/libldap/ntlm.c
 @@ -0,0 +1,138 @@
 +/* $OpenLDAP: pkg/ldap/libraries/libldap/ntlm.c,v 1.1.4.10 2002/01/04 20:38:21 kurt Exp $ */
 +/*
@@ -159,31 +184,47 @@
 + return( ld->ld_errno );
 +}
 +
---- include/ldap.h.orig
-+++ include/ldap.h
-@@ -2115,5 +2115,25 @@
- ldap_passwordpolicy_err2txt LDAP_P(( LDAPPasswordPolicyError ));
- #endif /* LDAP_CONTROL_PASSWORDPOLICYREQUEST */
+Index: trunk/libraries/libldap/Makefile.in
+===================================================================
+--- trunk.orig/libraries/libldap/Makefile.in
++++ trunk/libraries/libldap/Makefile.in
+@@ -27,7 +27,7 @@
+ 	init.c options.c print.c string.c util-int.c schema.c \
+ 	charray.c os-local.c dnssrv.c utf-8.c utf-8-conv.c \
+ 	tls2.c tls_o.c tls_g.c tls_m.c \
+-	turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c \
++	turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c ntlm.c \
+ 	assertion.c deref.c
  
-+/*
-+ * hacks for NTLM
-+ */
-+#define LDAP_AUTH_NTLM_REQUEST ((ber_tag_t) 0x8aU)
-+#define LDAP_AUTH_NTLM_RESPONSE  ((ber_tag_t) 0x8bU)
-+LDAP_F( int )
-+ldap_ntlm_bind LDAP_P((
-+      LDAP    *ld,
-+      LDAP_CONST char *dn,
-+      ber_tag_t tag,
-+      struct berval *cred,
-+      LDAPControl **sctrls,
-+      LDAPControl **cctrls,
-+      int   *msgidp ));
-+LDAP_F( int )
-+ldap_parse_ntlm_bind_result LDAP_P((
-+      LDAP    *ld,
-+      LDAPMessage *res,
-+      struct berval *challenge));
-+
- LDAP_END_DECL
- #endif /* _LDAP_H */
+ OBJS	= bind.lo open.lo result.lo error.lo compare.lo search.lo \
+@@ -40,7 +40,7 @@
+ 	init.lo options.lo print.lo string.lo util-int.lo schema.lo \
+ 	charray.lo os-local.lo dnssrv.lo utf-8.lo utf-8-conv.lo \
+ 	tls2.lo tls_o.lo tls_g.lo tls_m.lo \
+-	turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo \
++	turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo ntlm.lo \
+ 	assertion.lo deref.lo
+ 
+ LDAP_INCDIR= ../../include       
+Index: trunk/libraries/libldap_r/Makefile.in
+===================================================================
+--- trunk.orig/libraries/libldap_r/Makefile.in
++++ trunk/libraries/libldap_r/Makefile.in
+@@ -29,7 +29,7 @@
+ 	init.c options.c print.c string.c util-int.c schema.c \
+ 	charray.c os-local.c dnssrv.c utf-8.c utf-8-conv.c \
+ 	tls2.c tls_o.c tls_g.c tls_m.c \
+-	turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c \
++	turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c ntlm.c \
+ 	assertion.c deref.c
+ SRCS	= threads.c rdwr.c rmutex.c tpool.c rq.c \
+ 	thr_posix.c thr_cthreads.c thr_thr.c thr_lwp.c thr_nt.c \
+@@ -47,7 +47,7 @@
+ 	init.lo options.lo print.lo string.lo util-int.lo schema.lo \
+ 	charray.lo os-local.lo dnssrv.lo utf-8.lo utf-8-conv.lo \
+ 	tls2.lo tls_o.lo tls_g.lo tls_m.lo \
+-	turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo \
++	turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo ntlm.lo \
+ 	assertion.lo deref.lo
+ 
+ LDAP_INCDIR= ../../include       
-- 
cgit v0.12