From 246c0471433375b63988e3fb2ca69c1670bed340 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 6 May 2009 20:29:05 -0500
Subject: mv_install: add install type for format_disk. Add try:except for
 MVROOT on full_install

---
 abs/core-testing/LinHES-config/PKGBUILD      | 2 +-
 abs/core-testing/LinHES-config/mv_install.py | 7 ++++++-
 2 files changed, 7 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 64929f0..44fe66f 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=405
+pkgrel=407
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted )
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index f9359e4..33a74a4 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -787,6 +787,11 @@ def restore_default_settings():
 
 def full_install(hostoptions):
     logging.info("______Start of full install______")
+    try:
+        MVROOT=os.environ["MV_ROOT"]
+    except:
+        logging.debug("     MVROOT was not defined, using the default value")
+        MVROOT="/usr/MythVantage"
 
     try:
         os.remove("/tmp/.this_is_upgrade")
@@ -806,7 +811,7 @@ def full_install(hostoptions):
     statusmsg="Preparing  %s"  %( hostoptions["rootdisk"])
     update_status(statusmsg)
     progress(2)
-    format_disk()
+    format_disk("install")
 
 
 #   Mount partitions
-- 
cgit v0.12