From 11bee2d772896328092f5c6e5a62064ae7d1321b Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Fri, 24 Jul 2009 11:45:41 -0400
Subject: vdpinfo initial checkin for three nVidia driver versions

---
 abs/core-testing/vdpinfo-71xx/PKGBUILD | 25 ++++++++++++++++++++++++
 abs/core-testing/vdpinfo-71xx/vdpinfo  |  2 ++
 abs/core-testing/vdpinfo-96xx/PKGBUILD | 25 ++++++++++++++++++++++++
 abs/core-testing/vdpinfo-96xx/vdpinfo  |  2 ++
 abs/core-testing/vdpinfo/PKGBUILD      | 35 ++++++++++++++++++++++++++++++++++
 5 files changed, 89 insertions(+)
 create mode 100644 abs/core-testing/vdpinfo-71xx/PKGBUILD
 create mode 100755 abs/core-testing/vdpinfo-71xx/vdpinfo
 create mode 100644 abs/core-testing/vdpinfo-96xx/PKGBUILD
 create mode 100755 abs/core-testing/vdpinfo-96xx/vdpinfo
 create mode 100644 abs/core-testing/vdpinfo/PKGBUILD

diff --git a/abs/core-testing/vdpinfo-71xx/PKGBUILD b/abs/core-testing/vdpinfo-71xx/PKGBUILD
new file mode 100644
index 0000000..bf20d32
--- /dev/null
+++ b/abs/core-testing/vdpinfo-71xx/PKGBUILD
@@ -0,0 +1,25 @@
+# It is not expected that vdpau will work with the 71xx nVidia drivers, but we still want
+# 'vdpinfo' to return something when users run it, even if the real 'vdpinfo' won't build
+# for their nVidia driver version.
+
+pkgname=vdpinfo-71xx
+pkgver=1
+pkgrel=1
+pkgdesc="tells the user they can't handle vdpau"
+license=('GPLv2')
+arch=('i686' 'x86_64')
+depends=('nvidia-71xx-utils' 'nvidia-71xx')
+# Just let the dependency on the right nvidia and nvidia-utils versions
+# handle conflicts via those packages conflicts.
+# conflicts=()
+provides=('vdpinfo')
+source=(vdpinfo)
+md5sums=()
+
+build() {
+    LH_ROOT=/usr/LH
+    mkdir -p $startdir/pkg/$LH_ROOT/bin/
+
+    cd $startdir
+    install -m0755 -D vdpinfo $startdir/pkg/$LH_ROOT/bin/
+}
\ No newline at end of file
diff --git a/abs/core-testing/vdpinfo-71xx/vdpinfo b/abs/core-testing/vdpinfo-71xx/vdpinfo
new file mode 100755
index 0000000..9b237dc
--- /dev/null
+++ b/abs/core-testing/vdpinfo-71xx/vdpinfo
@@ -0,0 +1,2 @@
+#!/bin/bash
+echo "vdpau is unsupported"
diff --git a/abs/core-testing/vdpinfo-96xx/PKGBUILD b/abs/core-testing/vdpinfo-96xx/PKGBUILD
new file mode 100644
index 0000000..34391dd
--- /dev/null
+++ b/abs/core-testing/vdpinfo-96xx/PKGBUILD
@@ -0,0 +1,25 @@
+# It is not expected that vdpau will work with the 71xx nVidia drivers, but we still want
+# 'vdpinfo' to return something when users run it, even if the real 'vdpinfo' won't build
+# for their nVidia driver version.
+
+pkgname=vdpinfo-96xx
+pkgver=1
+pkgrel=1
+pkgdesc="tells the user they can't handle vdpau"
+license=('GPLv2')
+arch=('i686' 'x86_64')
+depends=('nvidia-96xx-utils' 'nvidia-96xx')
+# Just let the dependency on the right nvidia and nvidia-utils versions
+# handle conflicts via those packages conflicts.
+# conflicts=()
+provides=('vdpinfo')
+source=(vdpinfo)
+md5sums=()
+
+build() {
+    LH_ROOT=/usr/LH
+    mkdir -p $startdir/pkg/$LH_ROOT/bin/
+
+    cd $startdir
+    install -m0755 -D vdpinfo $startdir/pkg/$LH_ROOT/bin/
+}
\ No newline at end of file
diff --git a/abs/core-testing/vdpinfo-96xx/vdpinfo b/abs/core-testing/vdpinfo-96xx/vdpinfo
new file mode 100755
index 0000000..9b237dc
--- /dev/null
+++ b/abs/core-testing/vdpinfo-96xx/vdpinfo
@@ -0,0 +1,2 @@
+#!/bin/bash
+echo "vdpau is unsupported"
diff --git a/abs/core-testing/vdpinfo/PKGBUILD b/abs/core-testing/vdpinfo/PKGBUILD
new file mode 100644
index 0000000..d9bfadc
--- /dev/null
+++ b/abs/core-testing/vdpinfo/PKGBUILD
@@ -0,0 +1,35 @@
+# Because this requires parts of the nVidia driver, this parallels the PKGBUILD for
+# the nvidia package.
+
+pkgname=vdpinfo
+pkgver=185.18.14
+pkgrel=1
+pkgdesc="polls the GPU for nVidia vdpau capabilities"
+arch=('i686' 'x86_64')
+[ "$CARCH" = "i686"   ] && ARCH=x86
+[ "$CARCH" = "x86_64" ] && ARCH=x86_64
+url="http://www.cs.rug.nl/~wladimir/vdpinfo/"
+license=('MIT')
+depends=('nvidia-utils=185.18.14' 'nvidia=185.18.14')
+# Just let the dependency on the right nvidia and nvidia-utils versions
+# handle conflicts via those packages conflicts.
+# conflicts=()
+provides=('vdpinfo')
+source=(http://www.cs.rug.nl/~wladimir/vdpinfo/vdpinfo-0.0.5.tar.gz http://us.download.nvidia.com/XFree86/Linux-$ARCH/${pkgver}/NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run)
+md5sums=()
+
+build() {
+    LH_ROOT=/usr/LH
+    mkdir -p $startdir/pkg/$LH_ROOT/bin/
+
+    # Extract nVidia driver to get at the headers we need to build vdpau
+    cd $startdir/src/
+    sh NVIDIA-Linux-$ARCH-${pkgver}-pkg0.run --extract-only
+    
+    # build vdpinfo
+    cd $startdir/src/vdpinfo
+    #g++ -O3 -g -I../NVIDIA-Linux-x86-185.18.14-pkg0/usr/include -c -o vdpinfo.o vdpinfo.cpp
+    #g++ -O3 -g -I$startdir/src/usr/include -c -o vdpinfo.o vdpinfo.cpp
+    make
+    install -m0755 vdpinfo $startdir/pkg/$LH_ROOT/bin/
+}
\ No newline at end of file
-- 
cgit v0.12