From dbff62a9a2550bd0bed77860fa4164d74c90dfb3 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verison.net>
Date: Mon, 22 Mar 2010 19:35:17 +0000
Subject: network-ups-tools: trying to make it work with runit. added an
 infinite loop to the run file to keep it from exiting.

---
 abs/extra-testing/community/network-ups-tools/PKGBUILD | 4 ++--
 abs/extra-testing/community/network-ups-tools/run      | 6 +++++-
 2 files changed, 7 insertions(+), 3 deletions(-)

diff --git a/abs/extra-testing/community/network-ups-tools/PKGBUILD b/abs/extra-testing/community/network-ups-tools/PKGBUILD
index 515adf8..ddbe89e 100644
--- a/abs/extra-testing/community/network-ups-tools/PKGBUILD
+++ b/abs/extra-testing/community/network-ups-tools/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=network-ups-tools
 pkgver=2.4.3
-pkgrel=1
+pkgrel=2
 pkgdesc="NUT is a collection of programs for monitoring and administering UPS hardware"
 arch=('i686' 'x86_64')
 url="http://www.networkupstools.org/"
@@ -49,5 +49,5 @@ cd $srcdir/nut-$pkgver
   mv ${pkgdir}/etc/udev ${pkgdir}/lib
 }
 md5sums=('6f893b61b07915e7a139324fa3f79121'
-         '81cfad544c6342125057f9cb978515fb'
+         'a927b0803559e4498bb944d98250f011'
          'b5b2e266774acfbc80e64ddfbd4057ee')
diff --git a/abs/extra-testing/community/network-ups-tools/run b/abs/extra-testing/community/network-ups-tools/run
index f549950..c4985fd 100644
--- a/abs/extra-testing/community/network-ups-tools/run
+++ b/abs/extra-testing/community/network-ups-tools/run
@@ -7,7 +7,7 @@ PID=`pidof -o %PPID /usr/sbin/upsd`
 
                 stat_runit "Starting UPSd Daemon"
 		/usr/bin/upsdrvctl start &> /dev/null
-                [ -z "$PID" ] && /usr/sbin/upsd -f &>/dev/null
+                [ -z "$PID" ] && /usr/sbin/upsd &>/dev/null
                 /usr/sbin/upsmon &>/dev/null
                 if [ $? -gt 0 ]; then
                         stat_fail
@@ -15,3 +15,7 @@ PID=`pidof -o %PPID /usr/sbin/upsd`
                         add_daemon upsd
                         stat_done
                 fi
+
+                while [ -n $PID ] ; do
+                  sleep 60
+                done
-- 
cgit v0.12