From ba58f41e5bfbe2b8c589bb00d68cfeec888e48e9 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 14 Mar 2009 12:59:21 -0500
Subject: Missing ocaml, needed for unison. Moving usion to extra-testing.

---
 abs/core-testing/unison/PKGBUILD                   | 28 -------------------
 abs/core-testing/unison/ocaml-3.08-extnames.patch  | 14 ----------
 abs/core-testing/unison/unison.desktop             | 13 ---------
 abs/core-testing/unison/unison.install             | 32 ----------------------
 abs/extra-testing/ocaml/PKGBUILD                   | 29 ++++++++++++++++++++
 abs/extra-testing/unison/PKGBUILD                  | 28 +++++++++++++++++++
 abs/extra-testing/unison/ocaml-3.08-extnames.patch | 14 ++++++++++
 abs/extra-testing/unison/unison.desktop            | 13 +++++++++
 abs/extra-testing/unison/unison.install            | 32 ++++++++++++++++++++++
 9 files changed, 116 insertions(+), 87 deletions(-)
 delete mode 100644 abs/core-testing/unison/PKGBUILD
 delete mode 100644 abs/core-testing/unison/ocaml-3.08-extnames.patch
 delete mode 100644 abs/core-testing/unison/unison.desktop
 delete mode 100644 abs/core-testing/unison/unison.install
 create mode 100644 abs/extra-testing/ocaml/PKGBUILD
 create mode 100644 abs/extra-testing/unison/PKGBUILD
 create mode 100644 abs/extra-testing/unison/ocaml-3.08-extnames.patch
 create mode 100644 abs/extra-testing/unison/unison.desktop
 create mode 100644 abs/extra-testing/unison/unison.install

diff --git a/abs/core-testing/unison/PKGBUILD b/abs/core-testing/unison/PKGBUILD
deleted file mode 100644
index b1efa5b..0000000
--- a/abs/core-testing/unison/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-
-pkgname=unison
-pkgver=2.27.57
-pkgrel=1
-pkgdesc="Unison is a file-synchronization tool"
-arch=(i686 x86_64)
-license=('GPL2')
-url="http://www.cis.upenn.edu/~bcpierce/unison"
-depends=('glibc')
-#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
-makedepends=('ocaml' )
-source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
-        $pkgname.desktop)
-options=(!makeflags)
-install=unison.install
-
-build() {
-  cd $startdir/src/$pkgname-$pkgver
-  CFLAGS=""
-  make clean
-  make UISTYLE=text DEBUGGING=false THREADS=true || return 1
-  mkdir -p $startdir/pkg/usr/bin 
-  install -Dm755 unison $startdir/pkg/usr/bin/unison
-}
-md5sums=('4ba0a3e4bf4b4ad0c063f86391371f78'
-         '2daecba7705455a8e4b769e48b059872')
diff --git a/abs/core-testing/unison/ocaml-3.08-extnames.patch b/abs/core-testing/unison/ocaml-3.08-extnames.patch
deleted file mode 100644
index e959be2..0000000
--- a/abs/core-testing/unison/ocaml-3.08-extnames.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur unison-2.9.1/ubase/uprintf.ml unison-2.9.1.patched/ubase/uprintf.ml
---- unison-2.9.1/ubase/uprintf.ml	2002-04-11 07:13:23.000000000 +0200
-+++ unison-2.9.1.patched/ubase/uprintf.ml	2004-08-08 14:10:09.784776851 +0200
-@@ -10,8 +10,8 @@
- (*                                                                     *)
- (***********************************************************************)
- 
--external format_int: string -> int -> string = "format_int"
--external format_float: string -> float -> string = "format_float"
-+external format_int: string -> int -> string = "caml_format_int"
-+external format_float: string -> float -> string = "caml_format_float"
- 
- let fprintf outchan doafter format =
-   let format = (Obj.magic format : string) in
diff --git a/abs/core-testing/unison/unison.desktop b/abs/core-testing/unison/unison.desktop
deleted file mode 100644
index 3a7e1d7..0000000
--- a/abs/core-testing/unison/unison.desktop
+++ /dev/null
@@ -1,13 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=unison
-Name[de]=unison
-Comment=File synchronisation tool for X11
-Comment[de]=Datei Abgleicher und Synchronisierer
-TryExec=unison-x11
-Exec=unison-x11
-Terminal=false
-Type=Application
-Categories=GTK;Application;Network;
-Icon=unison.png
-StartupNotify=true
diff --git a/abs/core-testing/unison/unison.install b/abs/core-testing/unison/unison.install
deleted file mode 100644
index 70e70b0..0000000
--- a/abs/core-testing/unison/unison.install
+++ /dev/null
@@ -1,32 +0,0 @@
-# arg 1:  the new package version
-post_install() {
-  echo "NOTE:"
-  echo "  For gtk1 frontend please add 'gtk' package."
-  echo "  For gtk2 frontend please add 'gtk2' package."
-  echo "  Default X11 frontend is set to gtk2. "
-  echo ""
-  echo "  If you want to default to gtk1 unison:" 
-  echo "  'rm /usr/bin/unison-x11'"
-  echo "  'ln -s /usr/bin/unison-gtk /usr/bin/unison-x11'"
-  echo ""
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
- post_install $1
-}
-
-# arg 1:  the old package version
-pre_remove() {
-  /bin/true
-}
-
-# arg 1:  the old package version
-post_remove() {
-  /bin/true
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/extra-testing/ocaml/PKGBUILD b/abs/extra-testing/ocaml/PKGBUILD
new file mode 100644
index 0000000..1ca7fe5
--- /dev/null
+++ b/abs/extra-testing/ocaml/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 28732 2009-03-01 22:25:49Z tpowa $
+#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=ocaml	
+pkgver=3.11.0
+pkgrel=1
+pkgdesc="Ocaml compiler - Ocaml is a functional language with OO extensions"
+arch=(i686 x86_64)
+license=('LGPL2' 'custom: QPL-1.0')
+url="http://caml.inria.fr/"
+depends=('gdbm')
+makedepends=('tk' 'ncurses>=5.6-7' 'libx11')
+optdepends=('ncurses=5.6-7: advanced ncurses features' 'tk: advanced tk features')
+source=(http://caml.inria.fr/distrib/ocaml-3.11/$pkgname-$pkgver.tar.gz)
+options=('!makeflags' '!emptydirs')
+
+build() {
+  cd $srcdir/$pkgname-$pkgver
+  ./configure -prefix /usr
+  make world.opt || return 1
+  make PREFIX=$pkgdir/usr install || return 1
+   
+# Save >10MB with this one, makepkg only strips debug symbols.
+ find ${startdir}/pkg/usr/lib -type f -name '*.so.*' -exec strip --strip-unneeded {} \;
+
+# install license
+install -D -m 644 $startdir/src/$pkgname-$pkgver/LICENSE $startdir/pkg/usr/share/licenses/ocaml/LICENSE
+}
+md5sums=('be152066bdf09761ddf1c31291e5cb90')
diff --git a/abs/extra-testing/unison/PKGBUILD b/abs/extra-testing/unison/PKGBUILD
new file mode 100644
index 0000000..b1efa5b
--- /dev/null
+++ b/abs/extra-testing/unison/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=unison
+pkgver=2.27.57
+pkgrel=1
+pkgdesc="Unison is a file-synchronization tool"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.cis.upenn.edu/~bcpierce/unison"
+depends=('glibc')
+#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
+makedepends=('ocaml' )
+source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
+        $pkgname.desktop)
+options=(!makeflags)
+install=unison.install
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  CFLAGS=""
+  make clean
+  make UISTYLE=text DEBUGGING=false THREADS=true || return 1
+  mkdir -p $startdir/pkg/usr/bin 
+  install -Dm755 unison $startdir/pkg/usr/bin/unison
+}
+md5sums=('4ba0a3e4bf4b4ad0c063f86391371f78'
+         '2daecba7705455a8e4b769e48b059872')
diff --git a/abs/extra-testing/unison/ocaml-3.08-extnames.patch b/abs/extra-testing/unison/ocaml-3.08-extnames.patch
new file mode 100644
index 0000000..e959be2
--- /dev/null
+++ b/abs/extra-testing/unison/ocaml-3.08-extnames.patch
@@ -0,0 +1,14 @@
+diff -ur unison-2.9.1/ubase/uprintf.ml unison-2.9.1.patched/ubase/uprintf.ml
+--- unison-2.9.1/ubase/uprintf.ml	2002-04-11 07:13:23.000000000 +0200
++++ unison-2.9.1.patched/ubase/uprintf.ml	2004-08-08 14:10:09.784776851 +0200
+@@ -10,8 +10,8 @@
+ (*                                                                     *)
+ (***********************************************************************)
+ 
+-external format_int: string -> int -> string = "format_int"
+-external format_float: string -> float -> string = "format_float"
++external format_int: string -> int -> string = "caml_format_int"
++external format_float: string -> float -> string = "caml_format_float"
+ 
+ let fprintf outchan doafter format =
+   let format = (Obj.magic format : string) in
diff --git a/abs/extra-testing/unison/unison.desktop b/abs/extra-testing/unison/unison.desktop
new file mode 100644
index 0000000..3a7e1d7
--- /dev/null
+++ b/abs/extra-testing/unison/unison.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=unison
+Name[de]=unison
+Comment=File synchronisation tool for X11
+Comment[de]=Datei Abgleicher und Synchronisierer
+TryExec=unison-x11
+Exec=unison-x11
+Terminal=false
+Type=Application
+Categories=GTK;Application;Network;
+Icon=unison.png
+StartupNotify=true
diff --git a/abs/extra-testing/unison/unison.install b/abs/extra-testing/unison/unison.install
new file mode 100644
index 0000000..70e70b0
--- /dev/null
+++ b/abs/extra-testing/unison/unison.install
@@ -0,0 +1,32 @@
+# arg 1:  the new package version
+post_install() {
+  echo "NOTE:"
+  echo "  For gtk1 frontend please add 'gtk' package."
+  echo "  For gtk2 frontend please add 'gtk2' package."
+  echo "  Default X11 frontend is set to gtk2. "
+  echo ""
+  echo "  If you want to default to gtk1 unison:" 
+  echo "  'rm /usr/bin/unison-x11'"
+  echo "  'ln -s /usr/bin/unison-gtk /usr/bin/unison-x11'"
+  echo ""
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12