From 53ed8e22c9626d9dccf9676f0dfc95f6e7b9756c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 5 Nov 2008 17:13:29 -0600
Subject: create vg mount points for updates.

---
 abs/core-testing/live-installer/PKGBUILD             |  2 +-
 abs/core-testing/live-installer/install_functions.sh | 11 +++++++++--
 2 files changed, 10 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/live-installer/PKGBUILD b/abs/core-testing/live-installer/PKGBUILD
index 7eb5436..fe42458 100755
--- a/abs/core-testing/live-installer/PKGBUILD
+++ b/abs/core-testing/live-installer/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=live-installer
 pkgver=1.0
-pkgrel=77
+pkgrel=81
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan)
 arch=('i686')
diff --git a/abs/core-testing/live-installer/install_functions.sh b/abs/core-testing/live-installer/install_functions.sh
index bafb27a..511dc16 100755
--- a/abs/core-testing/live-installer/install_functions.sh
+++ b/abs/core-testing/live-installer/install_functions.sh
@@ -414,8 +414,15 @@ case $1 in
                      sed -i -e "s/.*swap\ .*$/UUID=$SWAPUUID swap swap defaults  0/g" /$mountpoint/etc/fstab
 
 #if Knoppmyth upgrade then loop through old fstab picking out vg
-
-
+                    if [  -f /tmp/etc/KnoppMyth-version ]
+                    then
+                        if [ -f /tmp/etc/fstab ]
+                        then
+                            grep /dev/vg /tmp/etc/fstab >> /$mountpoint/etc/fstab
+                            grep /dev/vg /tmp/etc/fstab | awk -v mount=$mountpoint ' { print "/" mount $2 }' |xargs mkdir
+                            grep /dev/vg /tmp/etc/fstab | awk -v mount=$mountpoint ' { print "/" mount $2 }' |xargs chown -R mythtv:users
+                        fi
+                    fi
         ;;
 
         grub_it )
-- 
cgit v0.12