From de9f5b121f4a0095e5e1343d7e3fc15adfbd4b91 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verison.net>
Date: Thu, 25 Mar 2010 02:26:23 +0000
Subject: apcupsd: fixed extraneous redirects in apcupsd exec line of run

---
 abs/extra-testing/apcupsd/PKGBUILD | 12 ++++++------
 abs/extra-testing/apcupsd/run      |  3 ++-
 2 files changed, 8 insertions(+), 7 deletions(-)

diff --git a/abs/extra-testing/apcupsd/PKGBUILD b/abs/extra-testing/apcupsd/PKGBUILD
index 9f66f5d..ad57d1a 100644
--- a/abs/extra-testing/apcupsd/PKGBUILD
+++ b/abs/extra-testing/apcupsd/PKGBUILD
@@ -3,8 +3,8 @@
 # Maintainer: Todd Musall <tmusall@comcast.net>
 
 pkgname=apcupsd
-pkgver=3.14.5
-pkgrel=2
+pkgver=3.14.8
+pkgrel=1
 pkgdesc="Apcupsd can be used for power mangement and controlling most of APC's UPS models on Unix and Windows machines."
 arch=(i686 x86_64)
 url="http://www.apcupsd.org"
@@ -17,10 +17,6 @@ source=(http://switch.dl.sf.net/sourceforge/apcupsd/$pkgname-$pkgver.tar.gz \
 	apcupsd
 	apcupsd.conf
 	run)
-md5sums=('4ac73ec91d8ab56f3fac894e172567c4'
-         '5eae3c4d921eeb81798a0250fe3dd111'
-	 '2f533aec32c9445510bb2127b453b175'
-	 'd4b8c755ecd30f57810f71a6d6435dd3')
 
 build() {
   cd $startdir/src/$pkgname-$pkgver
@@ -36,3 +32,7 @@ build() {
   mkdir -p  $startdir/pkg/etc/sv/apcupsd/supervise
   install -D -m755 ../run $startdir/pkg/etc/sv/apcupsd
 }
+md5sums=('cd17f0a903dc2220e55ed54e242359d2'
+         '5eae3c4d921eeb81798a0250fe3dd111'
+         '2f533aec32c9445510bb2127b453b175'
+         '32ae73bc096c1d0982c12d8ec46abee2')
diff --git a/abs/extra-testing/apcupsd/run b/abs/extra-testing/apcupsd/run
index a9dfa3d..bc5c22b 100644
--- a/abs/extra-testing/apcupsd/run
+++ b/abs/extra-testing/apcupsd/run
@@ -1,3 +1,4 @@
 #!/bin/sh
 exec 2>&1
-exec /sbin/apcupsd -b -f /etc/apcupsd/apcupsd.conf >/dev/null 2>/dev/null
+   stat_runit "Starting APC UPS Daemon"
+      exec /sbin/apcupsd -b -f /etc/apcupsd/apcupsd.conf
-- 
cgit v0.12