From f1aa9caeafea56ab0680d96992bfbf2dc4f2a55e Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Fri, 20 Feb 2009 14:55:13 -0500
Subject: builds fine, but not tested

---
 abs/core-testing/mythtv/trunk/morethemes/PKGBUILD  |  46 +++
 abs/core-testing/mythtv/trunk/myththemes/PKGBUILD  |  72 +++--
 abs/core-testing/mythtv/trunk/mythweather/PKGBUILD |  62 ++--
 abs/core-testing/mythtv/trunk/mythweb/PKGBUILD     |  73 +++--
 .../mythtv/trunk/mythweb/dblogininit.inc           |   6 -
 .../mythtv/trunk/mythweb/mythweb.install           |  35 +--
 .../mythtv/trunk/mythweb/mythweblighttpd.patch     |  13 -
 .../mythtv/trunk/mythweb/xris/dblogininit.inc      |   6 -
 .../mythtv/trunk/mythweb/xris/lighttpd.conf        | 332 ---------------------
 .../trunk/mythweb/xris/mythweblighttpd.patch       |  16 -
 .../mythtv/trunk/mythzoneminder/PKGBUILD           |  47 +++
 11 files changed, 218 insertions(+), 490 deletions(-)
 create mode 100644 abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
 mode change 100755 => 100644 abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
 delete mode 100755 abs/core-testing/mythtv/trunk/mythweb/dblogininit.inc
 mode change 100755 => 100644 abs/core-testing/mythtv/trunk/mythweb/mythweb.install
 delete mode 100755 abs/core-testing/mythtv/trunk/mythweb/mythweblighttpd.patch
 delete mode 100755 abs/core-testing/mythtv/trunk/mythweb/xris/dblogininit.inc
 delete mode 100755 abs/core-testing/mythtv/trunk/mythweb/xris/lighttpd.conf
 delete mode 100755 abs/core-testing/mythtv/trunk/mythweb/xris/mythweblighttpd.patch
 create mode 100644 abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD

diff --git a/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD b/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
new file mode 100644
index 0000000..befeb78
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=morethemes-svn
+pkgver=20019
+pkgrel=1
+pkgdesc="Additional themes for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn')
+conflicts=('morethemes')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+_svntrunk=http://cvs.mythtv.org/svn/trunk/themes
+_svnmod=themes
+
+
+build() {
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}
diff --git a/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD b/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
index 8cd0d04..af0764f 100755
--- a/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
@@ -1,36 +1,46 @@
-pkgname=mythv-themes-svn
-pkgver=15924                           
-pkgrel=4
-pkgdesc="themes for mythtv" 
-url="http://www.mythtv.org" 
-license="GPL" 
-depends=( ) 
-#makedepends=('sqlite3' 'sed') 
-conflicts=() 
-replaces=() 
-backup=() 
-#install='mythtv.install' 
-source=() 
-arch=('i686')
-md5sums=() 
+pkgname=myththemes-svn
+pkgver=20019
+pkgrel=1
+pkgdesc="Themes for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn')
+conflicts=('myththemes')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
 _svntrunk=http://cvs.mythtv.org/svn/trunk/myththemes
 _svnmod=myththemes
 
-build() { 
-echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-#svn co http://cvs.mythtv.org/svn/trunk/mythtv
-#svn co http://cvs.mythtv.org/svn/trunk/mythplugins
-#svn co http://cvs.mythtv.org/svn/trunk/myththemes
-cd $startdir/src/myththemes
-   make distclean
-    ./configure  
-    #./configure --disable-all --enable-mythweather --enable-fftw --disable-aac  
-   make  || return 1
-   make INSTALL_ROOT=$startdir/pkg install
-#   cd $startdir/src/$pkgname
-#   cd mythmovietime
-#   make || return 1
-#   make INSTALL_ROOT=$startdir/pkg install
+
+build() {
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
 
 }
diff --git a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
index 98542b9..02034d4 100644
--- a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
@@ -1,35 +1,47 @@
 pkgname=mythweather-svn
-pkgver=16153
-pkgrel=6
+pkgver=20019
+pkgrel=1
 pkgdesc="Weather checking plugin for MythTV"
 url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn' 'wget' 'perl-xml-sax' 'perl-soap-lite' 'perl-image-size'  'imagemagick')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
 license="GPL"
-source=()
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'wget')
+conflicts=('mythweather')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
 _svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
 _svnmod=mythplugins
 
 
 build() {
-	cd $startdir/src/
-	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- 	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-	cd $startdir/src/mythplugins
-	make distclean
-	PLUGIN=mythweather
-	grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-	if [ $? != 0 ]
-	then
-			echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
-				msg "appending program lib"
-			fi
-   ./configure  --enable-opengl --disable-all --enable-mythweather
- 
-   make -j 2 || return 1
-
-   make INSTALL_ROOT=$startdir/pkg install
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+	--enable-mythweather || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
 }
-md5sums=('2a9fbf45ae58a3a35857ce8d7c4d12db')
diff --git a/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
old mode 100755
new mode 100644
index 52eb059..9b51cbc
--- a/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
@@ -1,35 +1,48 @@
 pkgname=mythweb-svn
-pkgver=16153
-pkgrel=20
-pkgdesc="mythweb" 
-url="http://www.mythtv.org" 
-license="GPL" 
-arch=('i686')
-depends=(php fcgi libmysqlclient ) 
-conflicts=('mythweb' 'mythweb-fixes') 
-replaces=() 
-backup=() 
-install='mythweb.install' 
-source=(mythweblighttpd.patch dblogininit.inc ) 
-md5sums=() 
+pkgver=20019
+pkgrel=1
+pkgdesc="Web interface for MythTV's backend"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'lighttpd' 'php' 'local-website')
+conflicts=('mythweb')
+groups=('mythtv-extras-svn')
+install=mythweb.install
+
+patches=()
+source=(`echo ${patches[@]:0}`)
 _svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
 _svnmod=mythplugins
 
-build() { 
-echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-#svn co http://cvs.mythtv.org/svn/trunk/mythtv
-#svn co http://cvs.mythtv.org/svn/trunk/mythplugins
-#svn co http://cvs.mythtv.org/svn/trunk/myththemes
-cd $startdir/src/mythplugins
-
-#take care of fing mythweb
-mkdir -p $startdir/pkg/data/srv/httpd/htdocs/
-cp -rp mythweb $startdir/pkg/data/srv/httpd/htdocs/
-cp -f $startdir/src/dblogininit.inc $startdir/pkg/data/srv/httpd/htdocs/mythweb/includes/
-cd  $startdir/pkg/data/srv/httpd/htdocs/mythweb/includes
-patch -p0 < $startdir/src/mythweblighttpd.patch
-
-chown -R nobody:nobody $startdir/pkg/data/srv/httpd/htdocs/mythweb
-chmod -R  775 $startdir/pkg/data/srv/httpd/htdocs/mythweb
+DOCROOT=/data/srv/httpd/htdocs/mythweb
+
+build() {
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	mkdir -p $startdir/pkg/$DOCROOT/{image_cache,php_sessions}
+
+	cp -r $startdir/src/mythplugins/mythweb/* $startdir/pkg/$DOCROOT
+#   cp $startdir/src/mythplugins-$pkgver/mythweb/data/.htaccess $startdir/pkg/$DOCROOT
+	rm $startdir/pkg/srv/$DOCROOT/README
+	chown -R http:users $startdir/pkg/$DOCROOT
+	chmod g+rw $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
+
 }
diff --git a/abs/core-testing/mythtv/trunk/mythweb/dblogininit.inc b/abs/core-testing/mythtv/trunk/mythweb/dblogininit.inc
deleted file mode 100755
index c5395c5..0000000
--- a/abs/core-testing/mythtv/trunk/mythweb/dblogininit.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-<?
- $_SERVER["db_server"] = "localhost";
- $_SERVER["db_name"] = "mythconverg";
- $_SERVER["db_login"] = "mythtv";
- $_SERVER["db_password"] = "mythtv";
-?>
diff --git a/abs/core-testing/mythtv/trunk/mythweb/mythweb.install b/abs/core-testing/mythtv/trunk/mythweb/mythweb.install
old mode 100755
new mode 100644
index 9162d98..470cbd1
--- a/abs/core-testing/mythtv/trunk/mythweb/mythweb.install
+++ b/abs/core-testing/mythtv/trunk/mythweb/mythweb.install
@@ -1,35 +1,8 @@
-
-# arg 1:  the new package version
-pre_install () {
-/bin/true
-}
-
 post_install() {
-	cp /etc/lighttpd/lighttpd.conf /tmp
-	sed -e "s/# .*  \"mod_fastcgi\",/\"mod_fastcgi\"\,/g" /tmp/lighttpd.conf > /etc/lighttpd/lighttpd.conf
- 
-
-}
-pre_upgrade () {
- pre_install
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-  post_install
-
-  /bin/true
-}
-
-# arg 1:  the old package version
-pre_remove() {
-  /bin/true
-}
-
-# arg 1:  the old package version
-post_remove() {
-/bint/true
+	echo "You must create a symlink from /home/httpd/html/mythweb/video_dir"
+	echo "to your MythTV recordings directory. Don't forget to change the"
+	echo "permissions so that the webserver can read those files and create"
+	echo "thumbnails."  
 }
 
 op=$1
diff --git a/abs/core-testing/mythtv/trunk/mythweb/mythweblighttpd.patch b/abs/core-testing/mythtv/trunk/mythweb/mythweblighttpd.patch
deleted file mode 100755
index 6403a88..0000000
--- a/abs/core-testing/mythtv/trunk/mythweb/mythweblighttpd.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- database.php.orig	2007-12-31 21:25:30.000000000 +0000
-+++ database.php	2007-12-31 21:25:50.000000000 +0000
-@@ -18,6 +18,10 @@
-         custom_error("Please install the MySQL libraries for PHP.\n"
-                     .'The package is usually called something like php-mysql.');
-     }
-+     if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {
-+	      require_once 'dblogininit.inc';
-+	      }
-+	
- 
- // No database connection info defined?
-     if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {
diff --git a/abs/core-testing/mythtv/trunk/mythweb/xris/dblogininit.inc b/abs/core-testing/mythtv/trunk/mythweb/xris/dblogininit.inc
deleted file mode 100755
index c5395c5..0000000
--- a/abs/core-testing/mythtv/trunk/mythweb/xris/dblogininit.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-<?
- $_SERVER["db_server"] = "localhost";
- $_SERVER["db_name"] = "mythconverg";
- $_SERVER["db_login"] = "mythtv";
- $_SERVER["db_password"] = "mythtv";
-?>
diff --git a/abs/core-testing/mythtv/trunk/mythweb/xris/lighttpd.conf b/abs/core-testing/mythtv/trunk/mythweb/xris/lighttpd.conf
deleted file mode 100755
index ff4e7dd..0000000
--- a/abs/core-testing/mythtv/trunk/mythweb/xris/lighttpd.conf
+++ /dev/null
@@ -1,332 +0,0 @@
-# lighttpd configuration file
-
-############ Options you really have to take care of ####################
-
-## modules to load
-# at least mod_access and mod_accesslog should be loaded
-# all other module should only be loaded if really neccesary
-# - saves some time
-# - saves memory
-server.modules              = (
-                                "mod_rewrite",
-#                               "mod_redirect",
-#                               "mod_alias",
-                                "mod_access",
-#                               "mod_cml",
-#                               "mod_trigger_b4_dl",
-#                               "mod_auth",
-                                "mod_status",
-                                "mod_setenv",
-#fast_cgi needs to be enabled for mythweb, as all mythweb requests are passed to php-cgi.
-				"mod_fastcgi",
-#                               "mod_proxy",
-#                               "mod_simple_vhost",
-#                               "mod_evhost",
-#                               "mod_userdir",
-                                "mod_cgi",
-#                               "mod_compress",
-#                               "mod_ssi",
-#                               "mod_usertrack",
-#                               "mod_expire",
-#                               "mod_secdownload",
-#                               "mod_rrdtool",
-                                "mod_accesslog" )
-
-## a static document-root, for virtual-hosting take look at the
-## server.virtual-* options
-server.document-root        = "/data/srv/httpd/htdocs"
-
-## where to send error-messages to
-server.errorlog             = "/var/log/lighttpd/error.log"
-
-# files to check for if .../ is requested
-index-file.names            = ( "index.php", "index.html",
-                                "index.htm", "default.htm","mythweb.php")
-
-# mimetype mapping
-mimetype.assign             = (
-  ".pdf"          =>      "application/pdf",
-  ".sig"          =>      "application/pgp-signature",
-  ".spl"          =>      "application/futuresplash",
-  ".class"        =>      "application/octet-stream",
-  ".ps"           =>      "application/postscript",
-  ".torrent"      =>      "application/x-bittorrent",
-  ".dvi"          =>      "application/x-dvi",
-  ".gz"           =>      "application/x-gzip",
-  ".pac"          =>      "application/x-ns-proxy-autoconfig",
-  ".swf"          =>      "application/x-shockwave-flash",
-  ".tar.gz"       =>      "application/x-tgz",
-  ".tgz"          =>      "application/x-tgz",
-  ".tar"          =>      "application/x-tar",
-  ".zip"          =>      "application/zip",
-  ".mp3"          =>      "audio/mpeg",
-  ".m3u"          =>      "audio/x-mpegurl",
-  ".wma"          =>      "audio/x-ms-wma",
-  ".wax"          =>      "audio/x-ms-wax",
-  ".ogg"          =>      "application/ogg",
-  ".wav"          =>      "audio/x-wav",
-  ".gif"          =>      "image/gif",
-  ".jpg"          =>      "image/jpeg",
-  ".jpeg"         =>      "image/jpeg",
-  ".png"          =>      "image/png",
-  ".xbm"          =>      "image/x-xbitmap",
-  ".xpm"          =>      "image/x-xpixmap",
-  ".xwd"          =>      "image/x-xwindowdump",
-  ".css"          =>      "text/css",
-  ".html"         =>      "text/html",
-  ".htm"          =>      "text/html",
-  ".js"           =>      "text/javascript",
-  ".asc"          =>      "text/plain",
-  ".c"            =>      "text/plain",
-  ".cpp"          =>      "text/plain",
-  ".log"          =>      "text/plain",
-  ".conf"         =>      "text/plain",
-  ".text"         =>      "text/plain",
-  ".txt"          =>      "text/plain",
-  ".dtd"          =>      "text/xml",
-  ".xml"          =>      "text/xml",
-  ".mpeg"         =>      "video/mpeg",
-  ".mpg"          =>      "video/mpeg",
-  ".mov"          =>      "video/quicktime",
-  ".qt"           =>      "video/quicktime",
-  ".avi"          =>      "video/x-msvideo",
-  ".asf"          =>      "video/x-ms-asf",
-  ".asx"          =>      "video/x-ms-asf",
-  ".wmv"          =>      "video/x-ms-wmv",
-  ".bz2"          =>      "application/x-bzip",
-  ".tbz"          =>      "application/x-bzip-compressed-tar",
-  ".tar.bz2"      =>      "application/x-bzip-compressed-tar",
-  ".nuv"	  =>	  "video/nuppelvideo"
- )
-
-
-# Use the "Content-Type" extended attribute to obtain mime type if possible
-mimetype.use-xattr        = "enable"
-
-
-## send a different Server: header
-## be nice and keep it at lighttpd
-#server.tag                 = "lighttpd"
-
-#### accesslog module
-accesslog.filename          = "/var/log/lighttpd/access.log"
-
-## deny access the file-extensions
-#
-# ~    is for backupfiles from vi, emacs, joe, ...
-# .inc is often used for code includes which should in general not be part
-#      of the document-root
-url.access-deny             = ( "~", ".inc" )
-
-$HTTP["url"] =~ "\.pdf$" {
-  server.range-requests = "disable"
-}
-
-######### Options that are good to be but not neccesary to be changed #######
-
-## bind to port (default: 80)
-#server.port                = 80
-
-## bind to localhost (default: all interfaces)
-#server.bind                = "grisu.home.kneschke.de"
-
-## error-handler for status 404
-#server.error-handler-404   = "/error-handler.html"
-#server.error-handler-404   = "/error-handler.php"
-
-## to help the rc.scripts
-server.pid-file            = "/var/run/lighttpd.pid"
-
-
-###### virtual hosts
-##
-##  If you want name-based virtual hosting add the next three settings and load
-##  mod_simple_vhost
-##
-## document-root =
-##   virtual-server-root + virtual-server-default-host + virtual-server-docroot
-## or
-##   virtual-server-root + http-host + virtual-server-docroot
-##
-#simple-vhost.server-root   = "/home/lighttpd/vhosts/"
-#simple-vhost.default-host  = "lighttpd.localhost"
-#simple-vhost.document-root = "/pages/"
-##
-## Format: <errorfile-prefix><status-code>.html
-## -> ..../status-404.html for 'File not found'
-#server.errorfile-prefix    = "/home/weigon/projects/lighttpd/doc/status-"
-
-## virtual directory listings
-#server.dir-listing         = "enable"
-
-## enable debugging
-#debug.log-request-header   = "enable"
-#debug.log-response-header  = "enable"
-#debug.log-request-handling = "enable"
-#debug.log-file-not-found   = "enable"
-
-### only root can use these options
-#
-# chroot() to directory (default: no chroot() )
-#server.chroot              = "/"
-
-## change uid to <uid> (default: don't care)
-server.username             = "nobody"
-
-## change uid to <uid> (default: don't care)
-server.groupname            = "nobody"
-
-#### compress module
-#compress.cache-dir         = "/home/lighttpd/cache/"
-#compress.filetype          = ("text/plain", "text/html")
-
-#### proxy module
-## read proxy.txt for more info
-#proxy.server               = ( ".php" =>
-#                               ( "localhost" =>
-#                                 (
-#                                   "host" => "192.168.0.101",
-#                                   "port" => 80
-#                                 )
-#                               )
-#                             )
-
-
-
-
-## fastcgi module
-## read fastcgi.txt for more info
-## adjust the value of bin-path for your system.  
-## If you intend to process alot of requests at the same time, increase
-##  the value of min-procs and max-procs
-
-fastcgi.server = ( ".php" =>
- ( "localhost" =>
-   (
-     "socket" => "/tmp/php-fastcgi.socket",
-     "bin-path" => "/usr/bin/php-cgi",
-     "min-procs" => 0,
-     "max-procs" => 1,
-     "max-load-per-proc" => 1,
-     "idle-timeout" => 10,
-     # Fix PATH_INFO for PHP scripts that rely on it (like Wordpress and mythweb).
-      "broken-scriptfilename" => "enable"
-    )
- )
-)
-
-
-#the rewrite rule for mythweb.
-#This assumes that mythweb is installed at document.root/mythweb
-
- url.rewrite = (
-   "^/mythweb(/tv.*|/music.*|/video.*|/weather.*|/settings.*|/status.*|/backend_log.*)$" =>   "mythweb/mythweb.php/$1"
- )
-
-
-#### CGI module
-cgi.assign                 = ( ".pl"  => "/usr/bin/perl")
-
-
-
-#### SSL engine
-#$SERVER["socket"] == "0.0.0.0:443" {
-#  ssl.engine                  = "enable"
-#  ssl.pemfile                 = "/home/lighttpd/ssl/server.pem"
-#  server.errorlog             = "/var/log/lighttpd/error-ssl.log"
-#  accesslog.filename          = "/var/log/lighttpd/access-ssl.log"
-#  server.document-root        = "/home/lighttpd/html-ssl"
-#}
-
-
-
-#### status module
-status.status-url          = "/server-status"
-status.config-url          = "/server-config"
-
-#### auth module
-## read authentication.txt for more info
-#auth.backend               = "plain"
-#auth.backend.plain.userfile = "lighttpd.user"
-#auth.backend.plain.groupfile = "lighttpd.group"
-
-#auth.backend.ldap.hostname = "localhost"
-#auth.backend.ldap.base-dn  = "dc=my-domain,dc=com"
-#auth.backend.ldap.filter   = "(uid=$)"
-#auth.require               = ( "/server-status" =>
-#                               (
-#                                 "method"  => "digest",
-#                                 "realm"   => "download archiv",
-#                                 "require" => "user=jan"
-#                               ),
-#                               "/server-info" =>
-#                               (
-#                                 "method"  => "digest",
-#                                 "realm"   => "download archiv",
-#                                 "require" => "valid-user"
-#                               )
-#                             )
-
-#### url handling modules (rewrite, redirect, access)
-#url.rewrite                = ( "^/$"             => "/server-status" )
-#url.redirect               = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
-
-#
-# define a pattern for the host url finding
-# %% => % sign
-# %0 => domain name + tld
-# %1 => tld
-# %2 => domain name without tld
-# %3 => subdomain 1 name
-# %4 => subdomain 2 name
-#
-#evhost.path-pattern        = "/home/storage/dev/www/%3/htdocs/"
-
-#### expire module
-#expire.url                 = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")
-
-#### ssi
-#ssi.extension              = ( ".shtml" )
-
-#### rrdtool
-#rrdtool.binary             = "/usr/bin/rrdtool"
-#rrdtool.db-name            = "/var/www/lighttpd.rrd"
-
-#### setenv
-#setenv.add-request-header  = ( "TRAV_ENV" => "mysql://user@host/db" )
-#setenv.add-response-header = ( "X-Secret-Message" => "42" )
-## for mod_trigger_b4_dl
-# trigger-before-download.gdbm-filename = "/home/weigon/testbase/trigger.db"
-# trigger-before-download.memcache-hosts = ( "127.0.0.1:11211" )
-# trigger-before-download.trigger-url = "^/trigger/"
-# trigger-before-download.download-url = "^/download/"
-# trigger-before-download.deny-url = "http://127.0.0.1/index.html"
-# trigger-before-download.trigger-timeout = 10
-
-## for mod_cml
-## don't forget to add index.cml to server.indexfiles
-# cml.extension               = ".cml"
-# cml.memcache-hosts          = ( "127.0.0.1:11211" )
-
-#### variable usage:
-## variable name without "." is auto prefixed by "var." and becomes "var.bar"
-#bar = 1
-#var.mystring = "foo"
-
-## integer add
-#bar += 1
-## string concat, with integer cast as string, result: "www.foo1.com"
-#server.name = "www." + mystring + var.bar + ".com"
-## array merge
-#index-file.names = (foo + ".php") + index-file.names
-#index-file.names += (foo + ".php")
-
-#### include
-#include /etc/lighttpd/lighttpd-inc.conf
-## same as above if you run: "lighttpd -f /etc/lighttpd/lighttpd.conf"
-#include "lighttpd-inc.conf"
-
-#### include_shell
-#include_shell "echo var.a=1"
-## the above is same as:
-#var.a=1
diff --git a/abs/core-testing/mythtv/trunk/mythweb/xris/mythweblighttpd.patch b/abs/core-testing/mythtv/trunk/mythweb/xris/mythweblighttpd.patch
deleted file mode 100755
index bebc93e..0000000
--- a/abs/core-testing/mythtv/trunk/mythweb/xris/mythweblighttpd.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- init.php.orig	2006-11-23 21:37:13.000000000 +0000
-+++ init.php	2006-11-23 21:40:04.000000000 +0000
-@@ -75,7 +75,12 @@
-         custom_error("Please install the MySQL libraries for PHP.\n"
-                     .'The package is usually called something like php-mysql.');
-     }
--
-+    
-+    
-+// No database connection info defined?
-+    if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {
-+    require_once 'dblogininit.inc';
-+    }
- // No database connection info defined?
-     if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {
-         tailored_error('db_vars_error');
diff --git a/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD b/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
new file mode 100644
index 0000000..de2f1b2
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=mythzoneminder-svn
+pkgver=20019
+pkgrel=1
+pkgdesc="Integrates ZoneMinder into MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'zoneminder=1.23.3')
+conflicts=('mythzoneminder')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+	--enable-mythzoneminder || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}
-- 
cgit v0.12