From 7808b3fea49dbcf03b71d8900cef4a68f99a1ade Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Tue, 15 Sep 2009 19:43:30 -0700
Subject: mythinstall:Removed broken XE and added Mednafen.

---
 abs/core-testing/mythinstall/PKGBUILD            |  2 +-
 abs/core-testing/mythinstall/installsettings.cpp | 14 +++++++-------
 abs/core-testing/mythinstall/installsettings.h   |  2 +-
 3 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index 5a936da..fe1b2dd 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=1
-pkgrel=11
+pkgrel=12
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=i686
 depends=()
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 0a6afb5..61aaf26 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -1112,12 +1112,12 @@ static HostCheckBox *HostpluginmythgameMame()
     return gc;
 };
 
-static HostCheckBox *HostpluginmythgameXE()
+static HostCheckBox *HostpluginmythgameMednafen()
 {
-    HostCheckBox *gc = new HostCheckBox("HostpluginmythgameXE");
-    gc->setLabel(QObject::tr("XE"));
+    HostCheckBox *gc = new HostCheckBox("HostpluginmythgameMednafen");
+    gc->setLabel(QObject::tr("Mednafen"));
     gc->setValue(false);
-    gc->setHelpText(QObject::tr("Xe is a multi-system that emulates many console and handheld video game systems that are no longer on the market"));
+    gc->setHelpText(QObject::tr("Mednafen is a portable, utilizing OpenGL and SDL, command-line driven multi-system emulator with many advanced features."));
     return gc;
 };
 
@@ -1456,7 +1456,7 @@ class MythGamesettings: public TriggeredConfigurationGroup {
         settings->addChild(HostpluginmythgameZsnes());
         settings->addChild(HostpluginmythgameFceu());
         settings->addChild(HostpluginmythgameMame());
-        settings->addChild(HostpluginmythgameXE());
+        settings->addChild(HostpluginmythgameMednafen());
         settings->addChild(HostpluginmythgameROMDB());
 
 
@@ -3942,7 +3942,7 @@ void writesettings ()
         hostparm.ThisHostpluginmythstream= gContext->GetSetting("Hostpluginmythstream");
         hostparm.ThisHostpluginmythvodka= gContext->GetSetting("Hostpluginmythvodka");
         hostparm.ThisHostMiro= gContext->GetSetting("HostMiro");
-        hostparm.ThisHostpluginmythgameXE= gContext->GetSetting("HostpluginmythgameXE");
+        hostparm.ThisHostpluginmythgameMednafen= gContext->GetSetting("HostpluginmythgameMednafen");
         hostparm.ThisHostpluginmythgameROMDB= gContext->GetSetting("HostpluginmythgameROMDB");
         hostparm.ThisHostXine = gContext->GetSetting("HostXine");
         hostparm.ThisHostwebmin = gContext->GetSetting("Hostwebmin");
@@ -4190,7 +4190,7 @@ void writesettings ()
         myfile << "mythstream=\"" + hostparm.ThisHostpluginmythstream + "\"\n";
         myfile << "mythvodka=\"" +hostparm.ThisHostpluginmythvodka + "\"\n";
         myfile << "miro=\"" + hostparm.ThisHostMiro + "\"\n";
-        myfile << "xe=\"" + hostparm.ThisHostpluginmythgameXE + "\"\n";
+        myfile << "xe=\"" + hostparm.ThisHostpluginmythgameMednafen + "\"\n";
         myfile << "romdb=\"" + hostparm.ThisHostpluginmythgameROMDB + "\"\n";
         myfile << "xine=\"" + hostparm.ThisHostXine  + "\"\n";
         myfile << "webmin=\"" + hostparm.ThisHostwebmin  + "\"\n";
diff --git a/abs/core-testing/mythinstall/installsettings.h b/abs/core-testing/mythinstall/installsettings.h
index a177921..0df1d4e 100755
--- a/abs/core-testing/mythinstall/installsettings.h
+++ b/abs/core-testing/mythinstall/installsettings.h
@@ -451,7 +451,7 @@ struct HostParms
         QString ThisHostpluginmythstream;
         QString ThisHostpluginmythvodka;
         QString ThisHostMiro;
-        QString ThisHostpluginmythgameXE;
+        QString ThisHostpluginmythgameMednafen;
         QString ThisHostpluginmythgameROMDB;
         QString ThisHostXine;
         QString ThisHostwebmin;
-- 
cgit v0.12