From 05d391284794f549b8dd51540ae0f44fe89fbc69 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 14 Mar 2009 16:52:30 -0500
Subject: updated imagemagick to 6.4.9.10

---
 abs/core/imagemagick/ChangeLog | 62 ++++++++++++++++++++++++++++++++++++++++++
 abs/core/imagemagick/PKGBUILD  | 24 +++++++---------
 2 files changed, 72 insertions(+), 14 deletions(-)

diff --git a/abs/core/imagemagick/ChangeLog b/abs/core/imagemagick/ChangeLog
index 8b3a5fb..a3b253a 100644
--- a/abs/core/imagemagick/ChangeLog
+++ b/abs/core/imagemagick/ChangeLog
@@ -1,3 +1,65 @@
+2009-02-27  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.9.7-1
+	* Upstream update
+
+2009-02-07  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.9.2-1
+	* Upstream update
+
+2009-01-30  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.8.10-1
+	* Upstream update
+
+2008-12-29  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.8.2-1
+	* Upstream update
+
+2008-12-14  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.7.8-1
+	* Upstream update
+
+2008-12-05  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.7.0-1
+	* Upstream update
+	* Rebuild against heimdal 1.2.1
+
+2008-11-25  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.6.3-1
+	* Upstream update
+
+2008-11-14  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.5.6-1
+	* Upstream update
+
+2008-10-26  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.5.0-1
+	* Upstream update
+
+2008-10-18  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.4.9-1
+	* Upstream update
+
+2008-10-03  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.4.1-1
+	* Upstream update
+
+2008-09-06  Eric Belanger  <eric@archlinux.org>
+
+	* imagemagick 6.4.3.6-1
+	* Upstream update
+	* Added JPEG2000 support (close FS#10544)
+
 2008-08-19  Eric Belanger  <eric@archlinux.org>
 
 	* imagemagick 6.4.2.10-1
diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index 79555bf..4c0aba6 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 9867 2008-08-20 05:56:48Z eric $
+# $Id: PKGBUILD 28186 2009-02-28 05:23:34Z eric $
 # Maintainer: Eric Belanger <eric@archlinux.org>
 
 # NOTE: ImageMagick builds against an existing installation
@@ -8,39 +8,35 @@
 # install old package, build new package, install new package, rebuild
 
 pkgname=imagemagick
-pkgver=6.4.2.10
+pkgver=6.4.9.10
 pkgrel=1
 pkgdesc="An image viewing/manipulation program"
 arch=('i686' 'x86_64')
 url="http://www.imagemagick.org/"
 license=('custom')
-depends=('lcms' 'libwmf' 'librsvg' 'libxt' 'gcc-libs' 'ghostscript' 'openexr' 'libtool>=2.2' 'bzip2' 'libxml2')
+depends=('lcms' 'libwmf' 'librsvg' 'libxt' 'gcc-libs' 'ghostscript' 'openexr>=1.6.1' 'libtool>=2.2' 'heimdal>=1.2.1' 'bzip2' 'libxml2' 'jasper')
 #makedepends=('ghostscript' 'openexr')
 options=('!makeflags' '!docs')
 source=(ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.bz2 \
         libpng_mmx_patch_x86_64.patch add_delegate.patch)
-md5sums=('f60ae313a2cc2fcc980543165e7ebaf4' '069980fc2590c02aed86420996259302'\
-         '7f5851c4450b73d52df55c7e806cc316')
-sha1sums=('0c45712a07b0d337ac4130c3ad605566d013ea3f'
-          'e42f3acbe85b6098af75c5cecc9a254baaa0482c'
-          '19b40dcbc5bf8efb8ce7190fed17e2921de32ea5')
 
 build() {
-  cd ${srcdir}/ImageMagick-${pkgver%.*}
+  cd ${srcdir}/ImageMagick-${pkgver%.*}-${pkgver##*.}
 
   if [ "${CARCH}" = "x86_64" ]; then
     patch -Np1 < ../libpng_mmx_patch_x86_64.patch || return 1
   fi
 
   patch -p0 < ../add_delegate.patch || return 1
+  sed -i "s/with_autotrace='no'/with_autotrace='yes'/" configure || return 1
 
-  #LIBS=-lMagickWand ./configure --prefix=/usr --without-modules --disable-static --disable-openmp \
-  ./configure --prefix=/usr --without-modules --disable-static --disable-openmp \
-              --with-x --with-wmf --with-openexr \
+ # When there is a soname bump, remove 'LIBS=-lMagickWand' from configure line and build/install. Then, readd 'LIBS=-lMagickWand' and build/install twice.
+  LIBS=-lMagickWand ./configure --prefix=/usr --without-modules --disable-static --enable-openmp \
+              --with-x --with-wmf --with-openexr --with-xml \
               --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
               --with-perl --with-perl-options="INSTALLDIRS=vendor" \
-              --without-gvc --without-djvu --without-jp2 \
-               --without-fpx --without-dps || return 1
+              --without-gvc --without-djvu --with-jp2 \
+              --without-jbig --without-fpx --without-dps || return 1
 
   make || return 1
   make DESTDIR=${pkgdir} install || return 1
-- 
cgit v0.12