From cca47f4dd89c5b8f3fea9704ed5f91ccd41cc74c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 9 Mar 2009 12:42:53 -0500
Subject: Remove mouse support from vi and vim.  Vim should once again act like
 its old loveable self. Also updated to latest patchset.

Signed-off-by: James Meyer <james.meyer@operamail.com>
---
 abs/core-testing/vi/PKGBUILD           | 15 ++++++++++-----
 abs/core-testing/vi/__changelog        |  3 +++
 abs/core-testing/vi/fetch_patches.sh   |  5 +++--
 abs/extra-testing/vim/PKGBUILD         |  9 ++++++---
 abs/extra-testing/vim/__changelog      |  3 +++
 abs/extra-testing/vim/fetch_patches.sh |  5 +++--
 6 files changed, 28 insertions(+), 12 deletions(-)
 create mode 100644 abs/core-testing/vi/__changelog
 create mode 100644 abs/extra-testing/vim/__changelog

diff --git a/abs/core-testing/vi/PKGBUILD b/abs/core-testing/vi/PKGBUILD
index 5d6d984..75ffd94 100644
--- a/abs/core-testing/vi/PKGBUILD
+++ b/abs/core-testing/vi/PKGBUILD
@@ -3,9 +3,9 @@
 
 pkgname=vi
 _srcver=7.2
-_patchlevel=65
+_patchlevel=132
 pkgver=${_srcver}.${_patchlevel}
-pkgrel=1
+pkgrel=2
 pkgdesc="a highly configurable, improved version of the vi text editor (basic version)"
 arch=(i686 x86_64)
 license=('custom:vim')
@@ -20,9 +20,6 @@ source=(ftp://ftp.vim.org/pub/vim/unix/vim-${_srcver}.tar.bz2 \
         ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-extra.tar.gz \
         ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-lang.tar.gz \
         fetch_patches.sh fetch_runtime.sh)
-md5sums=('f0901284b338e448bfd79ccca0041254' '35e04482f07c57221c9a751aaa3b8dac' \
-         'd8884786979e0e520c112faf2e176f05' 'a3b03cd44b8ed78a99850d4cbfaafe55' \
-         '92e3dc8844d446c1ecd28e7257a47cb7')
 
 build()
 {
@@ -63,4 +60,12 @@ build()
   install -dm755 ${startdir}/pkg/usr/share/licenses/vim
   cd ${startdir}/pkg/usr/share/licenses/vim
   ln -s ../../vim/doc/uganda.txt license.txt
+
+#               Changes to remove mouse support  VERY IMPORTANT!
+  ########################################################################################
+   sed -i "s/mouse=a/mouse-=a/g" $startdir/pkg/etc/virc
+
+
+  ############################################################################
+
 }
diff --git a/abs/core-testing/vi/__changelog b/abs/core-testing/vi/__changelog
new file mode 100644
index 0000000..47cbb5f
--- /dev/null
+++ b/abs/core-testing/vi/__changelog
@@ -0,0 +1,3 @@
+Remove mouse support from  /etc/vimrc.  This new found ability is truely annoying.
+
+
diff --git a/abs/core-testing/vi/fetch_patches.sh b/abs/core-testing/vi/fetch_patches.sh
index 03e16e2..2ce1019 100644
--- a/abs/core-testing/vi/fetch_patches.sh
+++ b/abs/core-testing/vi/fetch_patches.sh
@@ -17,7 +17,7 @@ get_patches() {
   echo -e "\tfetching checksumfile for patches"
   wget ${_rpath}/MD5SUMS >/dev/null 2>&1
 
-  downloads=0
+  downloads=-1
   for _line in $(/bin/cat MD5SUMS); do
     downloads=$((${downloads} + 1))
     _md5=$(echo $_line | cut -d ' ' -f1)
@@ -42,7 +42,8 @@ get_patches() {
       return 1
     fi
   done
-
+  cd $startdir/src/patches
+  rm 7.2.001-100.gz
   ########
 
   if [ ${downloads} != ${_patchlevel} ]; then
diff --git a/abs/extra-testing/vim/PKGBUILD b/abs/extra-testing/vim/PKGBUILD
index d0355fc..7e3db29 100644
--- a/abs/extra-testing/vim/PKGBUILD
+++ b/abs/extra-testing/vim/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=vim
 _srcver=7.2
-_patchlevel=65
+_patchlevel=132
 pkgver=${_srcver}.${_patchlevel}
 pkgrel=1.5
 pkgdesc="a highly configurable, improved version of the vi text editor"
@@ -19,8 +19,6 @@ source=(ftp://ftp.vim.org/pub/vim/unix/vim-${_srcver}.tar.bz2 \
         ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-extra.tar.gz \
         ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-lang.tar.gz \
         fetch_patches.sh)
-md5sums=('f0901284b338e448bfd79ccca0041254' '35e04482f07c57221c9a751aaa3b8dac' \
-         'd8884786979e0e520c112faf2e176f05' 'a3b03cd44b8ed78a99850d4cbfaafe55')
 
 build()
 {
@@ -60,4 +58,9 @@ build()
     ${startdir}/pkg/etc/vimrc
   # clean all settings and controls -  served by vi package
   rm -rf ${startdir}/pkg/usr/share/vim
+
+#               Changes to remove mouse support  VERY IMPORTANT!
+##############################################################
+   sed -i "s/mouse=a/mouse-=a/g" $startdir/pkg/etc/vimrc
+#################################################################
 }
diff --git a/abs/extra-testing/vim/__changelog b/abs/extra-testing/vim/__changelog
new file mode 100644
index 0000000..47cbb5f
--- /dev/null
+++ b/abs/extra-testing/vim/__changelog
@@ -0,0 +1,3 @@
+Remove mouse support from  /etc/vimrc.  This new found ability is truely annoying.
+
+
diff --git a/abs/extra-testing/vim/fetch_patches.sh b/abs/extra-testing/vim/fetch_patches.sh
index 03e16e2..2ce1019 100644
--- a/abs/extra-testing/vim/fetch_patches.sh
+++ b/abs/extra-testing/vim/fetch_patches.sh
@@ -17,7 +17,7 @@ get_patches() {
   echo -e "\tfetching checksumfile for patches"
   wget ${_rpath}/MD5SUMS >/dev/null 2>&1
 
-  downloads=0
+  downloads=-1
   for _line in $(/bin/cat MD5SUMS); do
     downloads=$((${downloads} + 1))
     _md5=$(echo $_line | cut -d ' ' -f1)
@@ -42,7 +42,8 @@ get_patches() {
       return 1
     fi
   done
-
+  cd $startdir/src/patches
+  rm 7.2.001-100.gz
   ########
 
   if [ ${downloads} != ${_patchlevel} ]; then
-- 
cgit v0.12