From 9468324f1aa9972e479480b5ba8b91397dec8cc6 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 5 May 2009 18:55:08 -0500
Subject: LinHES-system/fluxbox:  Add unclutter-toggle.sh Closes FS#345

---
 abs/core-testing/LinHES-system/PKGBUILD            | 4 ++--
 abs/core-testing/LinHES-system/unclutter-toggle.sh | 8 ++++++++
 abs/core-testing/fluxbox/PKGBUILD                  | 4 +---
 abs/core-testing/fluxbox/keys                      | 2 +-
 4 files changed, 12 insertions(+), 6 deletions(-)
 create mode 100644 abs/core-testing/LinHES-system/unclutter-toggle.sh

diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 7ef4b5b..0fad05d 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=54
+pkgrel=55
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
@@ -8,7 +8,7 @@ install=LinHES.install
 pkgdesc="scripts and things related to having a automated system"
 depends=(linhes-sounds xdotool)
 backup=(etc/modprobe.d/alsa-base)
-binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh"
+binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh"
 
 source=(LinHES-session LinHES-profile.sh $binfiles alsa-base)
 
diff --git a/abs/core-testing/LinHES-system/unclutter-toggle.sh b/abs/core-testing/LinHES-system/unclutter-toggle.sh
new file mode 100644
index 0000000..0ead751
--- /dev/null
+++ b/abs/core-testing/LinHES-system/unclutter-toggle.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+PIDUNC=`pidof unclutter`
+if [ -n "${PIDUNC}" ];
+then
+    killall -9 unclutter
+else
+    /usr/X11R6/bin/unclutter -root -idle 1 -jitter 200 -noevents &
+fi
diff --git a/abs/core-testing/fluxbox/PKGBUILD b/abs/core-testing/fluxbox/PKGBUILD
index 87d1c89..b3a9a41 100644
--- a/abs/core-testing/fluxbox/PKGBUILD
+++ b/abs/core-testing/fluxbox/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=fluxbox
 pkgver=1.1.1
-pkgrel=4
+pkgrel=6
 pkgdesc="A lightweight and highly-configurable window manager"
 arch=('i686' 'x86_64')
 url="http://www.fluxbox.org"
@@ -14,8 +14,6 @@ makedepends=('pkgconfig')
 options=('!makeflags')
 source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2 \
         fluxbox.desktop keys)
-md5sums=('fa9fa8fe9a44f86522de5754f8b285ca' 'eeae9c88a2526ac0bd8afcd9ce97f9ed' '5afad3c817263ad0f976337e7df151bc')
-sha1sums=('6d49deb6c4c7d73f7567e1cf7d2575c7edc4825f' 'f3f83b8ce84d79c2f8670ef687e0dd89ab0552b8')
 
 build() {
   cd ${srcdir}/${pkgname}-${pkgver}
diff --git a/abs/core-testing/fluxbox/keys b/abs/core-testing/fluxbox/keys
index bfaceaa..fbacf75 100644
--- a/abs/core-testing/fluxbox/keys
+++ b/abs/core-testing/fluxbox/keys
@@ -24,4 +24,4 @@ Mod1 1 :ExecCommand sudo sv start mythbackend
 Mod1 2 :ExecCommand sudo sv stop mythbackend
 Mod1 3 :ExecCommand sudo sv restart mythbackend
 Mod1 h :ExecCommand MythVantage -h
-Mod1 Control u :ExecCommand killall -9 unclutter
+Mod1 Control u :ExecCommand /usr/LH/bin/unclutter-toggle.sh 
-- 
cgit v0.12