From aa37813e3606a4b55c842d15a5dde276cff4abeb Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 2 Apr 2009 14:10:33 -0500
Subject: runit-scripts: more work to fix hauppage

---
 abs/core-testing/runit-scripts/PKGBUILD            |  2 +-
 abs/core-testing/runit-scripts/runitscripts/1      |  9 ++++++-
 .../runit-scripts/runitscripts/services/lircd/run  | 28 ++++++++++++++--------
 3 files changed, 27 insertions(+), 12 deletions(-)

diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 4364e15..9fabfa3 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=1.8.0
-pkgrel=40
+pkgrel=47
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/1 b/abs/core-testing/runit-scripts/runitscripts/1
index 804ed56..6e4425d 100755
--- a/abs/core-testing/runit-scripts/runitscripts/1
+++ b/abs/core-testing/runit-scripts/runitscripts/1
@@ -1,12 +1,17 @@
 #!/bin/bash
 /etc/rc.sysinit
+. /etc/rc.conf
+. /etc/rc.d/functions
 hostname `cat /etc/hostname`
 /sbin/sysctl -p 2>/dev/null >/dev/null
-/usr/LH/bin/load-modules-mythvantage.sh
+#yes it's needed the 2nd time
+/usr/LH/bin/load-modules-mythvantage.sh >/dev/null
 rm /etc/dhcpc/dhcpcd*.pid  2>/dev/null
 rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
 rm -f /etc/runit/reboot 2>/dev/null
+stat_busy "Starting network"
 /etc/net/scripts/network.init start 2>/var/log/network.init.error >/var/log/network.init
+stat_done
 /usr/sbin/ethtool -s  eth0 wol g 2>/dev/null
 /usr/sbin/ethtool -s  eth1 wol g 2>/dev/null
 /usr/sbin/ethtool -s  eth2 wol g 2>/dev/null
@@ -14,6 +19,8 @@ rm -f /etc/runit/reboot 2>/dev/null
 if [ -e /etc/runit/1.local ]
 then
     #exec the file
+    stat_busy  /etc/runit/1.local
     /etc/runit/1.local
+    stat_done
 fi
 
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
index 242dcb3..1c5d8ff 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
@@ -2,6 +2,11 @@
 exec 2>&1
 #since what we do may not be enough
 #if your one of those people, this is where you place your stuff
+LOG=/tmp/lirc.log
+if [ -f $LOG ]
+then
+	rm -f $LOG
+fi
 if [ -f /etc/runit/lirc.sh ]
 then
     #program must not terminate.
@@ -21,7 +26,6 @@ else
 
     num_lirc=`ls -la /dev/lirc[0-9] |wc -l`
     num_lirc=$((num_lirc-1))
-    echo $num_lirc
 
     #/dev/ttys0 (COM1), port 0x3f8, irq 4
     #/dev/ttys1 (COM2), port 0x2f8, irq 3
@@ -44,7 +48,9 @@ else
                ;;
         esac
         /usr/bin/setserial /dev/$ReceiverSerialport uart none
+	sleep  .5
         /sbin/modprobe lirc_serial $FLAGS
+	sleep .5
     fi
     if [ x$HostBlasterType = xSerial ]
     then
@@ -63,7 +69,9 @@ else
                ;;
         esac
         /usr/bin/setserial /dev/$ReceiverSerialport uart none
+	sleep .5
         /sbin/modprobe lirc_serial $FLAGS
+	sleep .5
     fi
 
     dvico_detect
@@ -74,27 +82,27 @@ else
     do
         CMD="/usr/sbin/lircd -d /dev/lirc$i --output=/dev/lircd$i --pidfile=/var/run/lircd$i.pid --listen=876$i"
         echo $CMD
-        $CMD
+        $CMD >>$LOG 2>>$LOG
         LASTCMD="--connect=localhost:876$i   $LASTCMD    "
     done
     if [ $RunDvico = "true" -a $num_lirc -lt 0 ]
     then
       #only run dvicio
       LCMD="/usr/sbin/lircd -n -d /dev/usb/hiddev0 --driver=dvico  --output /dev/lircd"
-      echo $LCMD
-      exec $LCMD
+#      echo $LCMD
+      exec $LCMD >>$LOG 2>>$LOG
     elif [ $RunDvico = true -a $num_lirc -gt -1  ]
     then
         #chain them together
         i=$((i+1))
         CMD="/usr/sbin/lircd -d /dev/usb/hiddev0 --driver=dvico  --output=/dev/lircd$i --pidfile=/var/run/lircd$i.pid --listen=876$i"
-        echo $CMD
-        $CMD
+#        echo $CMD
+        $CMD >> $LOG
         LASTCMD="--connect=localhost:876$i   $LASTCMD    "
-        /usr/sbin/lircd -n -d /dev/lirc0 --output /dev/lircd  $LASTCMD
+        /usr/sbin/lircd -n -d /dev/lirc0 --output /dev/lircd  $LASTCMD  >>$LOG 2>>$LOG
     else
        LCMD="/usr/sbin/lircd -n -d /dev/lirc0 --output /dev/lircd  $LASTCMD"
-       echo $LCMD
-       exec $LCMD
+#       echo $LCMD
+       exec $LCMD >>$LOG 2>>$LOG
     fi
-fi
\ No newline at end of file
+fi
-- 
cgit v0.12