From e803239f44b43b2a425f47c1f1beb289be031f96 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Thu, 24 Dec 2009 20:49:26 -0800
Subject: Added script to update schema to reflect changes in 0.22.

---
 abs/core-testing/linhes-scripts/PKGBUILD                |  3 ++-
 .../linhes-scripts/update_schema_021_to_022.sh          | 17 +++++++++++++++++
 2 files changed, 19 insertions(+), 1 deletion(-)
 create mode 100644 abs/core-testing/linhes-scripts/update_schema_021_to_022.sh

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index 7dc200b..1da04cc 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=39
+pkgrel=40
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -33,6 +33,7 @@ linhes_update.sh
 linhes_update2.sh
 linhes_update3.sh
 install_hulu.sh
+update_schema_021_to_022.sh
 )
 
 build() {
diff --git a/abs/core-testing/linhes-scripts/update_schema_021_to_022.sh b/abs/core-testing/linhes-scripts/update_schema_021_to_022.sh
new file mode 100644
index 0000000..9ee3224
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/update_schema_021_to_022.sh
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+mysql mythconverg <<EOF
+update gameplayers set commandline = '/usr/bin/sdlmame -rp /myth/games/xmame/roms %s' where commandline = '/usr/game/mame -rp /myth/games/xmame/roms %s';
+update settings set data = '/myth/video_stuff/coverart' where value = 'VideoArtworkDir';
+update settings set data = '/myth/video_stuff/fanart' where value = 'mythvideo.fanartDir';
+update settings set data = '/myth/video_stuff/screenshots' where value = 'mythvideo.screenshotDir';
+update settings set data = '/myth/video_stuff/banners' where value = 'mythvideo.bannerDir';
+update settings set data = '/myth/video_stuff/trailers' where value = 'mythvideo.TrailersDir';
+update settings set data = '1' where value = 'mythvideo.TrailersRandomEnabled';
+update settings set data = '1' where value = 'mythvideo.EnableAlternatePlayer';
+update settings set data = '/myth/video_stuff/screenshots' where value = 'ScreenShotPath';
+update settings set data = '/myth/games/screenshots' where value = 'mythgame.screenshotdir';
+update settings set data = '/myth/games/fanart' where value = 'mythgame.fanartdir';
+update settings set data = '/myth/games/boxart' where value = 'mythgame.boxartdir';
+update settings set data = '3' where value = 'OverrideExitMenu';
+EOF
-- 
cgit v0.12