From e0fe3f974d42eeccc4f1d2d36eafd35d3502c0fa Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 18 Feb 2009 23:12:57 -0600
Subject: rebuilt WOL to remove info dir.

---
 abs/extra-testing/wol/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/extra-testing/wol/PKGBUILD b/abs/extra-testing/wol/PKGBUILD
index 1981453..a9bb4eb 100755
--- a/abs/extra-testing/wol/PKGBUILD
+++ b/abs/extra-testing/wol/PKGBUILD
@@ -1,7 +1,7 @@
 # Contributor: Markus Volkmann <mcfock@counterstrike.de>
 pkgname=wol
 pkgver=0.7.1
-pkgrel=2
+pkgrel=3
 pkgdesc="wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant."
 license="GPL"
 url="http://ahh.sourceforge.net/wol/"
-- 
cgit v0.12


From ca44dd939e49fd8dbe1058f04e7d1d31826b0c15 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 18 Feb 2009 23:14:30 -0600
Subject: Create /var/log/mythtv on upgrades and install.

---
 abs/core-testing/LinHES-config/PKGBUILD             |  2 +-
 abs/core-testing/LinHES-config/install_proxy.sh     |  5 ++++-
 abs/core-testing/mythtv/stable/mythtv/PKGBUILD      |  2 +-
 .../mythtv/stable/mythtv/mythtv.install             | 21 +++++++++++++++++++--
 4 files changed, 25 insertions(+), 5 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index ec0c0069..cbcdf8d 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=267
+pkgrel=268
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index 75ca6f0..3f626a1 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -216,6 +216,8 @@ full_install () {
 
         chmod -R 775   ${mountpoint}$SE
         chmod 775 "$mountpoint"/etc/systemconfig
+        mkdir -p "$mountpoint"/var/log/mythtv
+        chown mythtv "$mountpoint"/var/log/mythtv
         #copy over any updates that might have occured
         #cp -rp   $MV_ROOT/bin/*.sh "$mountpoint"$MV_ROOT/bin/
         cp_and_log   "$MV_ROOT/bin/*.sh" "$mountpoint"$MV_ROOT/bin/
@@ -329,7 +331,8 @@ function upgrade () {
             cp_and_log  /new_boot/etc.old/shadow /new_boot/etc/
             cp_and_log  /new_boot/etc.old/group   /new_boot/etc/
         fi
-
+        mkdir -p "$mountpoint"/var/log/mythtv
+        chown mythtv "$mountpoint"/var/log/mythtv
         if [  x$rootfs = "xDo_not_format" ]
         then
             rootfs=`grep \/\  /tmp/etc/fstab |awk ' { print $3 } '`
diff --git a/abs/core-testing/mythtv/stable/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
index 1e5b87d..941452f 100644
--- a/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.21
-pkgrel=36
+pkgrel=39
 pkgdesc="A Homebrew PVR project"
 arch=('i686' 'x86_64')
 depends=('bash' 'mysql-clients>=5.0' 'qt3' 'lame' 'lirc-utils' 'ffmpeg' \
diff --git a/abs/core-testing/mythtv/stable/mythtv/mythtv.install b/abs/core-testing/mythtv/stable/mythtv/mythtv.install
index c460f19..87507a5 100644
--- a/abs/core-testing/mythtv/stable/mythtv/mythtv.install
+++ b/abs/core-testing/mythtv/stable/mythtv/mythtv.install
@@ -1,11 +1,28 @@
 # arg 1:  the new package version
 post_install() {
-   echo "See \"MythTV\" on the Archlinux Wiki for installation information - Extensive!!"
+	if [ ! -d /var/log/mythtv ]
+	then
+		mkdir -p /var/log/mythv
+		chown -R mythtv /var/log/mythtv
+		echo "---" > /var/log/mythtv/mythbackend.log
+		chown mythtv /var/log/mythtv/mythbackend.log
+
+	fi
+}
+
+post_upgrade() {
+	if [ ! -d /var/log/mythtv ]
+	then
+		mkdir -p /var/log/mythv
+		chown -R mythtv /var/log/mythtv
+	fi
 }
 
+
 # arg 1:  the old package version
 post_remove() {
-   echo -e "NOTE: mysql database was not removed. To remove run:\nmysql -u root -e 'drop database mythconverg;'"
+	/bin/true
+
 }
 
 op=$1
-- 
cgit v0.12


From a6c74e9e0b37d26ba7525d62602b812f7a6db61a Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 18 Feb 2009 23:22:35 -0600
Subject: Use /usr/share/sounds/alsa/Front_Center.wav as the test file for
 playback.

---
 abs/core-testing/LinHES-config/PKGBUILD       | 2 +-
 abs/core-testing/LinHES-config/soundconfig.sh | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index cbcdf8d..ebe19fa 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=268
+pkgrel=269
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/soundconfig.sh b/abs/core-testing/LinHES-config/soundconfig.sh
index 8985a06..75998d6 100755
--- a/abs/core-testing/LinHES-config/soundconfig.sh
+++ b/abs/core-testing/LinHES-config/soundconfig.sh
@@ -6,7 +6,8 @@ echo $@ >/tmp/audio.call
 BASE=""
 . /etc/profile
 #TEMPLATES="/usr/share/templates"
-TESTFILE="$TEMPLATES/audio/space_battle_A.wav"
+#TESTFILE="$TEMPLATES/audio/space_battle_A.wav"
+TESTFILE="/usr/share/sounds/alsa/Front_Center.wav"
 OSSinstalled="false"
 
 function testaudio () {
-- 
cgit v0.12