From fcef9772de4f4a6e3f0cb95b6b7611c6cf1da4ae Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Fri, 18 Sep 2009 02:48:19 -0700
Subject: linhes-scripts:clean ups.

---
 abs/core-testing/linhes-scripts/PKGBUILD          | 2 +-
 abs/core-testing/linhes-scripts/linhes_update.sh  | 4 ++--
 abs/core-testing/linhes-scripts/linhes_update2.sh | 3 ++-
 3 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index 60291cf..99f70dd 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=32
+pkgrel=33
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
diff --git a/abs/core-testing/linhes-scripts/linhes_update.sh b/abs/core-testing/linhes-scripts/linhes_update.sh
index 121f683..3b455e0 100644
--- a/abs/core-testing/linhes-scripts/linhes_update.sh
+++ b/abs/core-testing/linhes-scripts/linhes_update.sh
@@ -12,6 +12,7 @@ dsply ()  {
 chck ()  {
 	sudo pacman -Sy
 	sudo pacman -Qu > /tmp/check_update
+	sudo grep Target /tmp/check_update > /tmp/to_be_upgraded
 	if grep -q no\ upgrades\ found /tmp/check_update
 		then
 		killall osd_cat
@@ -32,7 +33,6 @@ chck ()  {
   		mv /tmp/linhes.xml.tmp /usr/share/mythtv/linhes.xml
   		dsply
 	fi
-	grep Target /tmp/check_update > /tmp/to_be_upgraded
-}
+	}
 dsply
 chck
diff --git a/abs/core-testing/linhes-scripts/linhes_update2.sh b/abs/core-testing/linhes-scripts/linhes_update2.sh
index c002e07..20f32b9 100644
--- a/abs/core-testing/linhes-scripts/linhes_update2.sh
+++ b/abs/core-testing/linhes-scripts/linhes_update2.sh
@@ -3,7 +3,8 @@ echo -e "Performing updates." | osd_cat -p middle -s 5 -f"-adobe-courier-bold-*-
 sudo pacman -Syuf --noconfirm && sudo killall -9 osd_cat
 if grep -q Check\ for\ updates /usr/share/mythtv/linhes.xml
 then
-exit
+rm -fr /tmp/to_be_upgraded
+echo -e "Update complete." | osd_cat -p middle -s 5 -f"-adobe-courier-bold-*-*-*-34-*-*-*-*-*" -d 5 -A centre
 else
 mv /usr/share/mythtv/linhes.xml /tmp/linhes.xml.tmp
 sed -e '/\#UpdatesAv/,/\#UpdatesAv/d' < /tmp/linhes.xml.tmp > /usr/share/mythtv/linhes.xml
-- 
cgit v0.12