From aaf57d4cbe3d887150208ada4f56f03696af51b9 Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Sun, 22 Feb 2009 18:12:35 -0500
Subject: bumped svn revision

---
 abs/core-testing/mythtv/trunk/mythtv/PKGBUILD      |  8 +-
 .../mythtv/hdpvr_audio_codec_selection-v1.1.diff   | 96 ----------------------
 2 files changed, 4 insertions(+), 100 deletions(-)
 delete mode 100644 abs/core-testing/mythtv/trunk/mythtv/hdpvr_audio_codec_selection-v1.1.diff

diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 2c7d4c7..1ffef4e 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv-svn
-pkgver=20019
-pkgrel=3
+pkgver=20042
+pkgrel=1
 pkgdesc="A personal video recorder for Linux"
 url="http://www.mythtv.org"
 license="GPL"
@@ -15,8 +15,8 @@ groups=('pvr')
 #MAKEFLAGS="-j6"
 install='mythtv.install'
 
-patchs=('smolt_jump.patch' 'hdpvr_audio_codec_selection-v1.1.diff')
-#patchs=('svn_main_menu_popup.patch' 'smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'hdpvr_audio_codec_selection-v1.1.diff')
+patchs=('smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch')
+#patchs=('svn_main_menu_popup.patch' 'smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch')
 source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` )
 arch=('i686' 'x86_64')
 #md5sums=()
diff --git a/abs/core-testing/mythtv/trunk/mythtv/hdpvr_audio_codec_selection-v1.1.diff b/abs/core-testing/mythtv/trunk/mythtv/hdpvr_audio_codec_selection-v1.1.diff
deleted file mode 100644
index 7589dd3..0000000
--- a/abs/core-testing/mythtv/trunk/mythtv/hdpvr_audio_codec_selection-v1.1.diff
+++ /dev/null
@@ -1,96 +0,0 @@
-Index: libs/libmythtv/mpegrecorder.cpp
-===================================================================
---- libs/libmythtv/mpegrecorder.cpp	(revision 19989)
-+++ libs/libmythtv/mpegrecorder.cpp	(working copy)
-@@ -285,6 +285,13 @@
-                     QString("%1 is invalid").arg(value));
-         }
-     }
-+    else if (opt == "audiocodec")
-+    {
-+        if (value == "AAC Hardware Encoder")
-+            audtype = 4;
-+        else if (value == "AC3 Hardware Encoder")
-+            audtype = 5;
-+    }
-     else
-     {
-         RecorderBase::SetOption(opt, value);
-@@ -340,6 +347,8 @@
-     SetIntOption(profile, "medium_mpeg4peakbitrate");
-     SetIntOption(profile, "high_mpeg4avgbitrate");
-     SetIntOption(profile, "high_mpeg4peakbitrate");
-+
-+    SetStrOption(profile, "audiocodec");
- }
- 
- // same as the base class, it just doesn't complain if an option is missing
-@@ -829,6 +838,22 @@
-     {
-         maxbitrate = high_mpeg4peakbitrate;
-         bitrate    = high_mpeg4avgbitrate;
-+
-+        // query supported audio codecs
-+        struct v4l2_queryctrl qctrl;
-+        qctrl.id = V4L2_CID_MPEG_AUDIO_ENCODING;
-+
-+        if (ioctl(chanfd, VIDIOC_QUERYCTRL, &qctrl) < 0)
-+        {
-+            VERBOSE(VB_IMPORTANT, LOC_WARN +
-+                    "Unable to get supported audio codecs." + ENO);
-+        }
-+        else
-+        {
-+            uint audio_encoding = max(min(audtype-1, qctrl.maximum), qctrl.minimum);
-+            add_ext_ctrl(ext_ctrls, V4L2_CID_MPEG_AUDIO_ENCODING,
-+                         audio_encoding);
-+        }
-     }
-     maxbitrate = std::max(maxbitrate, bitrate);
- 
-Index: libs/libmythtv/recordingprofile.cpp
-===================================================================
---- libs/libmythtv/recordingprofile.cpp	(revision 19988)
-+++ libs/libmythtv/recordingprofile.cpp	(working copy)
-@@ -424,6 +424,15 @@
-         params->addChild(new SampleRate(parent));
-         params->addChild(new BTTVVolume(parent));
-         addTarget("Uncompressed", params);
-+
-+        params = new VerticalConfigurationGroup(false);
-+        params->setLabel("AC3 Hardware Encoder");
-+        addTarget("AC3 Hardware Encoder", params);
-+
-+        params = new VerticalConfigurationGroup(false);
-+        params->setLabel("AAC Hardware Encoder");
-+        addTarget("AAC Hardware Encoder", params);
-+
-     };
- 
-     void selectCodecs(QString groupType)
-@@ -432,6 +441,11 @@
-         {
-             if (groupType == "MPEG")
-                codecName->addSelection("MPEG-2 Hardware Encoder");
-+            else if (groupType == "HDPVR")
-+            {
-+                codecName->addSelection("AC3 Hardware Encoder");
-+                codecName->addSelection("AAC Hardware Encoder");
-+            }
-             else
-             {
-                 // V4L, TRANSCODE (and any undefined types)
-@@ -1260,11 +1274,8 @@
-         videoSettings = new VideoCompressionSettings(*this, profileName);
-         addChild(videoSettings);
- 
--        if (type.toUpper() != "HDPVR")
--        {
--            audioSettings = new AudioCompressionSettings(*this, profileName);
--            addChild(audioSettings);
--        }
-+        audioSettings = new AudioCompressionSettings(*this, profileName);
-+        addChild(audioSettings);
- 
-         if (!profileName.isEmpty() && profileName.left(11) == "Transcoders")
-         {
-- 
cgit v0.12