From 896e8723af0a99e741d6d767c13b4aa52f20820c Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verison.net>
Date: Thu, 18 Mar 2010 23:59:29 +0000
Subject: bluez: Updated to v4.62

---
 abs/extra-testing/bluez/PKGBUILD        | 10 ++---
 abs/extra-testing/bluez/__Changelog     |  4 ++
 abs/extra-testing/bluez/runit.bluetooth | 65 +++++++++++++++++++++++++++++++++
 3 files changed, 74 insertions(+), 5 deletions(-)
 create mode 100644 abs/extra-testing/bluez/__Changelog
 create mode 100644 abs/extra-testing/bluez/runit.bluetooth

diff --git a/abs/extra-testing/bluez/PKGBUILD b/abs/extra-testing/bluez/PKGBUILD
index 9e8f13b..46af613 100644
--- a/abs/extra-testing/bluez/PKGBUILD
+++ b/abs/extra-testing/bluez/PKGBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
 pkgname=bluez
-pkgver=4.30
+pkgver=4.62
 pkgrel=1
 pkgdesc="Libraries and tools for the Bluetooth protocol stack"
 url="http://www.bluez.org/"
@@ -16,7 +16,7 @@ backup=(etc/bluetooth/{main,rfcomm,audio,network,input}.conf
         etc/conf.d/bluetooth)
 source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
         'bluetooth.conf.d'
-        'rc.bluetooth')
+        'runit.bluetooth')
 build() {
   cd "$srcdir/$pkgname-$pkgver"
   ./configure --prefix=/usr \
@@ -45,9 +45,9 @@ build() {
   install -D -m644 "$srcdir/$pkgname-$pkgver/network/network.conf" "$pkgdir/etc/bluetooth/" || return 1
   install -D -m644 "$srcdir/$pkgname-$pkgver/input/input.conf"     "$pkgdir/etc/bluetooth/" || return 1
   install -D -m644 "$srcdir/$pkgname-$pkgver/audio/audio.conf"     "$pkgdir/etc/bluetooth/" || return 1
-  install -D -m755 "$srcdir/rc.bluetooth"                          "$pkgdir/etc/rc.d/bluetooth" || return 1
+  install -D -m755 "$srcdir/runit.bluetooth"                       "$pkgdir/etc/sv/bluetooth/run" || return 1
   install -D -m644 "$srcdir/bluetooth.conf.d"                      "$pkgdir/etc/conf.d/bluetooth" || return 1
 }
-md5sums=('5c37fb99c03f40269b9245eec3e7b7f4'
+md5sums=('3c2187a97f5b43ae84b4bbd4b34671e0'
          'd12be5b494525bb1ba6eac5c3983dd3e'
-         '03d4f2463b1b580e8d2ada3767140685')
+         'af1037c8e96dda60a1fea29140afb8f4')
diff --git a/abs/extra-testing/bluez/__Changelog b/abs/extra-testing/bluez/__Changelog
new file mode 100644
index 0000000..af8c597
--- /dev/null
+++ b/abs/extra-testing/bluez/__Changelog
@@ -0,0 +1,4 @@
+# by mihanson
+I really have no idea how this bluetooth stuff works.  If anyone wants to
+take a stab at getting this working properly with runit, feel free.  I
+only need this package to get mythpywii working.
diff --git a/abs/extra-testing/bluez/runit.bluetooth b/abs/extra-testing/bluez/runit.bluetooth
new file mode 100644
index 0000000..4b443db
--- /dev/null
+++ b/abs/extra-testing/bluez/runit.bluetooth
@@ -0,0 +1,65 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+DAEMON_NAME="bluetoothd"
+HID2HCI_NAME="hid2hci"
+HIDD_NAME="hidd"
+RFCOMM_NAME="rfcomm"
+PAND_NAME="pand"
+DUND_NAME="dund"
+
+DAEMON_EXEC="/usr/sbin/bluetoothd -n"
+HID2HCI_EXEC="/usr/sbin/hid2hci"
+HIDD_EXEC="/usr/bin/hidd"
+RFCOMM_EXEC="/usr/bin/rfcomm"
+PAND_EXEC="/usr/bin/pand"
+DUND_EXEC="/usr/bin/dund"
+
+DAEMON_ENABLE="true"
+HID2HCI_ENABLE="false"
+HIDD_ENABLE="false"
+RFCOMM_ENABLE="false"
+DUND_ENABLE="false"
+PAND_ENABLE="false"
+
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+HIDD_OPTIONS="-n"
+DUND_OPTIONS="-n"
+PAND_OPTIONS="-n"
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+    stat_runit "Starting bluetooth subsystem:"
+    if [ "$DAEMON_ENABLE" = "true" -a -x "$DAEMON_EXEC" ] ; then
+      exec $DAEMON_EXEC
+    fi
+#    if [ "$HID2HCI_ENABLE" = "true" -a -x "$HID2HCI_EXEC" ] ; then
+#      stat_append " $HID2HCI_NAME"
+#      $HID2HCI_EXEC --tohci > /dev/null 2>&1 || true
+#    fi
+#    if [ "$SDPD_ENABLE" = "true" -a -x "$SDPD_EXEC" ] ; then
+#      stat_append " $SDPD_NAME"
+#      $SDPD_EXEC
+#    fi
+#    if [ "$HIDD_ENABLE" = "true" -a -x "$HIDD_EXEC" ]; then
+#      stat_append " $HIDD_NAME"
+#      $HIDD_EXEC $HIDD_OPTIONS --server
+#    fi
+#    if [ "$RFCOMM_ENABLE" = "true" -a -x "$RFCOMM_EXEC" -a -f "$RFCOMM_CONFIG" ]; then
+#      stat_append " $RFCOMM_NAME"
+#      $RFCOMM_EXEC -f $RFCOMM_CONFIG bind all
+#    fi
+#    if [ "$DUND_ENABLE" = "true" -a -x "$DUND_EXEC" -a -n "$DUND_OPTIONS" ]; then
+#      stat_append " $DUND_NAME"
+#      $DUND_EXEC $DUND_OPTIONS
+#    fi
+#    if [ "$PAND_ENABLE" = "true" -a -x "$PAND_EXEC" -a -n "$PAND_OPTIONS" ]; then
+#      stat_append " $PAND_NAME"
+#      $PAND_EXEC $PAND_OPTIONS
+#    fi
-- 
cgit v0.12