From 796f8e605258d511b4358b56c686a0317174b003 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 4 Sep 2010 22:55:44 -0700
Subject: rpcbind:Bumped/Updated for LinHES 7.

---
 abs/core-testing/rpcbind/PKGBUILD | 26 ++++++++++++++++++++++++++
 abs/core-testing/rpcbind/rpcbind  | 39 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 65 insertions(+)
 create mode 100644 abs/core-testing/rpcbind/PKGBUILD
 create mode 100755 abs/core-testing/rpcbind/rpcbind

diff --git a/abs/core-testing/rpcbind/PKGBUILD b/abs/core-testing/rpcbind/PKGBUILD
new file mode 100644
index 0000000..11d8a91
--- /dev/null
+++ b/abs/core-testing/rpcbind/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 54912 2009-10-11 20:12:23Z giovanni $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=rpcbind
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="portmap replacement which supports RPC over various protocols"
+arch=(i686 x86_64)
+depends=('bash' 'glibc' 'libtirpc')
+url="http://rpcbind.sourceforge.net"
+license=('custom')
+replaces=('portmap')
+source=(http://downloads.sourceforge.net/sourceforge/rpcbind/rpcbind-0.2.0.tar.bz2 
+        rpcbind)
+md5sums=('1a77ddb1aaea8099ab19c351eeb26316'
+         '78a963654f57cbb209e228884767836e')
+
+build() {
+  cd $srcdir/$pkgname-$pkgver
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=$pkgdir install || return 1
+  # install daemon 
+  install -D -m755 $srcdir/rpcbind $pkgdir/etc/rc.d/rpcbind
+  # install license
+  install -D -m644 COPYING $pkgdir/usr/share/licenses/rpcbind/COPYING
+}
diff --git a/abs/core-testing/rpcbind/rpcbind b/abs/core-testing/rpcbind/rpcbind
new file mode 100755
index 0000000..87c5b50
--- /dev/null
+++ b/abs/core-testing/rpcbind/rpcbind
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID="$(pidof -o %PPID /usr/bin/rpcbind)"
+case "$1" in
+  start)
+    stat_busy "Starting rpcbind"
+    [ -z "$PID" ] && /usr/bin/rpcbind &>/dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      PID=$(pidof -o %PPID /usr/bin/rpcbind)
+      echo $PID > /var/run/rpcbind.pid
+      add_daemon rpcbind
+      stat_done
+    fi
+    ;;
+  stop)
+    stat_busy "Stopping rpcbind"
+    [ ! -z "$PID" ]  && kill $PID &> /dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      rm /var/run/rpcbind.pid
+      rm_daemon rpcbind
+      stat_done
+    fi
+    ;;
+  restart)
+    $0 stop
+    sleep 1
+    $0 start
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart}"  
+esac
+exit 0
-- 
cgit v0.12