From b7786e64fc9032a51b722bf7b7a472937be8713b Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 19 Jan 2009 13:57:52 -0600
Subject: if the destination drive is part of a volume then remove the VG. This
 closes FS#136

---
 abs/core-testing/LinHES-config/PKGBUILD             |  2 +-
 abs/core-testing/LinHES-config/install_functions.sh | 16 ++++++++++++++--
 2 files changed, 15 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 30aa48b..0b85ff6 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=218
+pkgrel=220
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index 52434fa..5e295ac 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -464,9 +464,20 @@ dogrub() {
     echo "GRUB was successfully installed."
 }
 
+function removevg () {
+    LIST=`pvscan |grep $1|tr -s " " |cut -d" " -f 5`
+    for vg in $LIST
+    do
+        echo "Removing vg $vg"
+        vgremove -f -v $vg
+    done
+
 
 
 
+}
+
+
 case $1 in
         partition_it )
     #drive  ROOT DATA(ALL) SWAP(NO)
@@ -474,8 +485,9 @@ case $1 in
                 do
                 umount $i
                 done
-        swap=`cat /etc/fstab |grep $disk|grep swap|awk ' { print $1 } '`
-        swapoff $swap
+                swap=`cat /etc/fstab |grep $disk|grep swap|awk ' { print $1 } '`
+                swapoff $swap
+                removevg $disk
                 partition_it $3 $4 $5
                 exit 0
 
-- 
cgit v0.12