From 5651b03574d2dc2d117840022d01326885d7392f Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 5 Sep 2009 15:43:09 -0700
Subject: MythInstall:Added MythZoneMinder to list of installable software.

---
 abs/core-testing/mythinstall/PKGBUILD            |  2 +-
 abs/core-testing/mythinstall/installsettings.cpp | 13 +++++++++++++
 abs/core-testing/mythinstall/installsettings.h   |  1 +
 abs/core-testing/mythtv/stable/mythtv/PKGBUILD   |  2 +-
 4 files changed, 16 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index c614fac..5a936da 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=1
-pkgrel=10
+pkgrel=11
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=i686
 depends=()
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 3942460..0a6afb5 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -1344,6 +1344,16 @@ static HostCheckBox *HostXscreensaver()
 };
 
 
+static HostCheckBox *Hostpluginmythzoneminder()
+{
+    HostCheckBox *gc = new HostCheckBox("Hostpluginmythzoneminder");
+    gc->setLabel(QObject::tr("mythzoneminder"));
+    gc->setValue(false);
+    gc->setHelpText(QObject::tr("check to enable mythzoneminder"));
+    return gc;
+};
+
+
 // -------------End plugins--------------------------------
 
 
@@ -3923,6 +3933,7 @@ void writesettings ()
         hostparm.ThisHostpluginmythsmolt = gContext->GetSetting("Hostpluginmythsmolt");
         hostparm.ThisHostpluginmythvideo = gContext->GetSetting("Hostpluginmythvideo");
         hostparm.ThisHostpluginmythweather = gContext->GetSetting("Hostpluginmythweather");
+        hostparm.ThisHostpluginmythzoneminder = gContext->GetSetting("Hostpluginmythzoneminder");
         hostparm.ThisHostpluginmythgameFceu = gContext->GetSetting("HostpluginmythgameFceu");
         hostparm.ThisHostpluginmythgameZsnes = gContext->GetSetting("HostpluginmythgameZsnes");
         hostparm.ThisHostpluginmythgameMame = gContext->GetSetting("HostpluginmythgameMame");
@@ -4168,6 +4179,7 @@ void writesettings ()
         myfile << "mythsmolt=\"" + hostparm.ThisHostpluginmythsmolt + "\"\n";
         myfile << "mythvideo=\"" + hostparm.ThisHostpluginmythvideo + "\"\n";
         myfile << "mythweather=\"" + hostparm.ThisHostpluginmythweather + "\"\n";
+        myfile << "mythzoneminder=\"" + hostparm.ThisHostpluginmythzoneminder + "\"\n";
 
         myfile << "fceu=\"" + hostparm.ThisHostpluginmythgameFceu + "\"\n";
         myfile << "zsnes=\"" + hostparm.ThisHostpluginmythgameZsnes + "\"\n";
@@ -4427,6 +4439,7 @@ MythInstallSettings::MythInstallSettings()
                     GridShowPlugin2->addChild(Hostpluginmythphone());
                     GridShowPlugin2->addChild(Hostpluginmythsmolt());
                     GridShowPlugin2->addChild(Hostpluginmythweather());
+                    GridShowPlugin2->addChild(Hostpluginmythzoneminder());
 
                     ConfigurationGroup *GridShowPlugin4 = new GridConfigurationGroup(2);
                     GridShowPlugin4->addChild(Hostpluginmythappletrailers());
diff --git a/abs/core-testing/mythinstall/installsettings.h b/abs/core-testing/mythinstall/installsettings.h
index c140f3d..a177921 100755
--- a/abs/core-testing/mythinstall/installsettings.h
+++ b/abs/core-testing/mythinstall/installsettings.h
@@ -442,6 +442,7 @@ struct HostParms
         QString ThisHostpluginmythsmolt;
         QString ThisHostpluginmythvideo;
         QString ThisHostpluginmythweather;
+        QString ThisHostpluginmythzoneminder;
         QString ThisHostpluginmythgameFceu;
         QString ThisHostpluginmythgameZsnes;
         QString ThisHostpluginmythgameMame;
diff --git a/abs/core-testing/mythtv/stable/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
index f6114c4..4b67da4 100644
--- a/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.21
-pkgrel=81
+pkgrel=82
 pkgdesc="A Homebrew PVR project"
 arch=('i686' 'x86_64')
 depends=('bash' 'mysql-clients>=5.0' 'qt3' 'lame' 'lirc-utils' 'ffmpeg'
-- 
cgit v0.12