From 79b3ed9852a1d7614902ef746a9234336c9e014a Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 21 Sep 2010 04:33:07 +0000
Subject: pyparted,iplib,decorator: python modules arch sync

---
 abs/core-testing/python-decorator/LICENSE.txt | 26 ++++++++++++++++++++++++
 abs/core-testing/python-decorator/PKGBUILD    | 29 +++++++++++++++++++++++++++
 abs/core-testing/python-iplib/PKGBUILD        |  5 +++--
 abs/core-testing/python-parted/PKGBUILD       | 11 ++++++++--
 4 files changed, 67 insertions(+), 4 deletions(-)
 create mode 100644 abs/core-testing/python-decorator/LICENSE.txt
 create mode 100644 abs/core-testing/python-decorator/PKGBUILD

diff --git a/abs/core-testing/python-decorator/LICENSE.txt b/abs/core-testing/python-decorator/LICENSE.txt
new file mode 100644
index 0000000..a6a4929
--- /dev/null
+++ b/abs/core-testing/python-decorator/LICENSE.txt
@@ -0,0 +1,26 @@
+Copyright (c) 2007, Michele Simionato
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+  Redistributions of source code must retain the above copyright 
+  notice, this list of conditions and the following disclaimer.
+  Redistributions in bytecode form must reproduce the above copyright
+  notice, this list of conditions and the following disclaimer in
+  the documentation and/or other materials provided with the
+  distribution. 
+
+  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+  HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+  INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+  BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+  OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+  ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
+  TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
+  USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+  DAMAGE.
diff --git a/abs/core-testing/python-decorator/PKGBUILD b/abs/core-testing/python-decorator/PKGBUILD
new file mode 100644
index 0000000..a7cd692
--- /dev/null
+++ b/abs/core-testing/python-decorator/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Pierre Chapuis <catwell at archlinux dot us>
+
+pkgname=python-decorator
+pkgver=3.2.0
+pkgrel=1
+pkgdesc='Python Decorator module'
+arch=('any')
+url='http://pypi.python.org/pypi/decorator'
+license=('BSD')
+depends=('python')
+source=("http://pypi.python.org/packages/source/d/decorator/decorator-${pkgver}.tar.gz"
+        'LICENSE.txt')
+md5sums=('6208cd51365083c168ab3a04426a646b'
+         '0ca76d2c707f09dbb04acc425ea1a08b')
+
+build() {
+  cd decorator-${pkgver}
+
+  python setup.py build
+}
+
+package() {
+  cd decorator-${pkgver}
+
+  python setup.py install --root=${pkgdir} --optimize=1
+
+  install -D -m644 ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/abs/core-testing/python-iplib/PKGBUILD b/abs/core-testing/python-iplib/PKGBUILD
index 9171293..9909832 100755
--- a/abs/core-testing/python-iplib/PKGBUILD
+++ b/abs/core-testing/python-iplib/PKGBUILD
@@ -1,15 +1,16 @@
 pkgname=python-iplib
-pkgver=1.0
+pkgver=1.1
 pkgrel=1
 pkgdesc="IPlib is a Python module useful to convert amongst many different notations and to manage couples of address/netmask in the CIDR notation."
 url="http://www.pymedia.org"
 license=""
 depends=('python')
 makedepends=('python>=2.3')
-source=(http://erlug.linux.it/~da/soft/iplib/iplib-1.0.tar.gz)
+source=(http://erlug.linux.it/~da/soft/iplib/iplib-1.1.tar.gz)
 
  arch=('i686')
 build() {
 	  cd $startdir/src/iplib*
            yes "" | python setup.py install --root=$startdir/pkg --prefix=/usr
       }
+md5sums=('3437ddbfc1986b2d06e7f4a0724ac5a0')
diff --git a/abs/core-testing/python-parted/PKGBUILD b/abs/core-testing/python-parted/PKGBUILD
index 8d2ef38..759bddf 100644
--- a/abs/core-testing/python-parted/PKGBUILD
+++ b/abs/core-testing/python-parted/PKGBUILD
@@ -1,11 +1,12 @@
 pkgname=python-parted
 __pkgname=pyparted
 pkgver=2.0.12
-pkgrel=1
+pkgver=3.4
+pkgrel=2
 pkgdesc="Python bindings for libparted"
 arch=(i686 x86_64)
 license=('LGPL' 'MPL')
-depends=('python' 'parted')
+depends=('python' 'parted' 'python-decorator')
 options=('!libtool')
 source=(https://fedorahosted.org/releases/p/y/pyparted/pyparted-${pkgver}.tar.gz)
 url="https://fedorahosted.org/pyparted/"
@@ -16,3 +17,9 @@ build() {
   make || return 1
   make DESTDIR="${pkgdir}" install || return 1
 }
+md5sums=('8fc485db0b88e59bbdfc4be8ba4068fa')
+md5sums=('cc064f12110a6f0d0c236ee7b18fee88')
+md5sums=('f244958142c9fd3ff5ee95f578e2f76d')
+md5sums=('7f5d06bd6336f3a699840d8639ab8a0d')
+md5sums=('f244958142c9fd3ff5ee95f578e2f76d')
+md5sums=('cc064f12110a6f0d0c236ee7b18fee88')
-- 
cgit v0.12