From 7b82b52a0bee32c7c17a3482578f034d15dfae07 Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Tue, 17 Feb 2009 17:37:25 -0500
Subject: Further R6 integration progress.  Ready for integration testing.

---
 abs/core-testing/tweaker/bin/twk_cpu.pl          |   2 +-
 abs/core-testing/tweaker/bin/twk_general.pl      | 162 +++++++++--------------
 abs/core-testing/tweaker/bin/twk_linux.pl        |  65 ---------
 abs/core-testing/tweaker/bin/twk_localization.pl |   2 +
 4 files changed, 68 insertions(+), 163 deletions(-)
 delete mode 100755 abs/core-testing/tweaker/bin/twk_linux.pl

diff --git a/abs/core-testing/tweaker/bin/twk_cpu.pl b/abs/core-testing/tweaker/bin/twk_cpu.pl
index c6d87ab..fabef10 100755
--- a/abs/core-testing/tweaker/bin/twk_cpu.pl
+++ b/abs/core-testing/tweaker/bin/twk_cpu.pl
@@ -85,7 +85,7 @@ sub implement_option {
 	    }
 	    case "medium" {
 		change_or_make_setting('AutoCommflagWhileRecording', '0') || exit -1;
-		change_or_make_setting('Theme', 'blootubelite-wide') || exit -1; # Moderate eye candy, moderate performance
+		change_or_make_setting('Theme', 'LinHES') || exit -1; # Moderate eye candy, moderate performance
 		#change_or_make_setting('PreferredMPEG2Decoder', 'libmpeg2') || exit -1; # Least CPU usage, lowest quality
 		#change_or_make_entry("displayprofiles", [["pref_decoder", "libmpeg2"]], [["profilegroupid", "1"], ["profileid", "1"]]) || exit -1; # Least CPU usage, lowest quality
 		change_or_make_setting('DefaultVideoPlaybackProfile', 'CPU+') || exit -1; # best playback defaults for average hardware
diff --git a/abs/core-testing/tweaker/bin/twk_general.pl b/abs/core-testing/tweaker/bin/twk_general.pl
index 89e75a6..c72e093 100755
--- a/abs/core-testing/tweaker/bin/twk_general.pl
+++ b/abs/core-testing/tweaker/bin/twk_general.pl
@@ -92,8 +92,8 @@ sub implement_option {
 	    #
 	    change_or_make_entry("videotypes", [["playcommand", "mplayer-resumer.pl -fs -zoom -vc theora,fftheora, -vo xv %s"]], [["extension", "ogg"]]);
 	    change_or_make_entry("videotypes", [["playcommand", "mplayer-resumer.pl -fs -zoom -vc theora,fftheora, -vo xv %s"]], [["extension", "theora"]]);
-	    foreach my $video_ext ("mp2", "tp", "ts", "m2p", "nuv") {
-		change_or_make_entry("videotypes", [["playcommand", "Internal"]], [["extension", $video_ext]]);
+	    foreach my $video_ext ("mp2", "tp", "ts", "m2p", "nuv", "mkv") {
+		change_or_make_entry("videotypes", [["playcommand", "Internal"], ["f_ignore", "0"], ["use_default", "1"]], [["extension", $video_ext]]);
 	    }
 	    foreach my $non_video_ext ("jpg", "par2") {
 		change_or_make_entry("videotypes", [["f_ignore", "1"]], [["extension", $non_video_ext]]);
@@ -118,36 +118,6 @@ sub implement_option {
 		     join("','",($players[3][0], $players[3][3], $players[3][0], "action/puzzle", "2006", "Frozen Bubble Team", "/usr/games", $players[3][4]))."');");
 
 	    #
-	    # smart music playlists
-	    #
-	    # categoryid, name
-	    change_or_make_entry("music_smartplaylist_categories", [["name", "Decades"]], [["categoryid", 1]]);
-	    change_or_make_entry("music_smartplaylist_categories", [["name", "Favorite Tracks"]], [["categoryid", 2]]);
-	    change_or_make_entry("music_smartplaylist_categories", [["name", "New Tracks"]], [["categoryid", 3]]);
-
-	    foreach my $decade (60, 70, 80, 90, 100) {
-		my $id = ($decade / 10) - 5;
-		my $query = "INSERT INTO music_smartplaylist_items (smartplaylistid, field, operator, value1, value2) VALUES ($id, 'Year', 'is between'," . ($decade+1900) . "," . ($decade+1909) . ");";
-		do_query($query);
-		$query = "INSERT INTO music_smartplaylists (name, categoryid, matchtype, orderby, limitto) VALUES ('". ($decade+1900) . "\\'s', 1, 'All', 'Artist (A)', 0);";
-		do_query($query);
-	    }
-
-	    my @other_lists = (
-		[
-		 ( 'Rating', 'is greater than', '7', 'Favorite Tracks', 2, 'Artist (A), Album (A)', 0 ),
-		 ( 'Play Count', 'is greater than', '0', '100 Most Played Tracks', 2, 'Play Count (D)', 100 ),
-		 ( 'Play Count', 'is equal to', '0', 'Never Played Tracks', 3, 'Artist (A), Album (A)', 0 )
-		]);
-
-	    my $id=6;
-	    foreach my $other_list (@other_lists) {
-		change_or_make_entry("music_smartplaylist_items", [["field", @$other_list[0]], ["operator", @$other_list[1]], ["value1", @$other_list[2]]], [["smartplaylistid", $id]]);
-		change_or_make_entry("music_smartplaylists", [["name", @$other_list[3]], ["categoryid", @$other_list[4]], ["matchtype", "All"], ["orderby", @$other_list[5]], ["limitto", @$other_list[6]]], [["smartplaylistid", $id]]);
-		$id++;
-	    }
-
-	    #
 	    # default playgroup with time-related settings
 	    #
 	    change_or_make_entry("playgroup", [["skipahead", 10], ["skipback", 5], ["timestretch", 100], ["jump", 1]], [["name", "Default"]]);
@@ -155,19 +125,15 @@ sub implement_option {
 	    #
 	    # useful recording profiles and transcoding options
 	    #
-	    change_or_make_entry("profilegroups", [["name", "Software Encoders (v4l based)"], ["cardtype", "V4L"], ["is_default", 1]], [["id", 1]]);
-	    change_or_make_entry("profilegroups", [["name", "MPEG-2 Encoders (PVR-x50, PVR-500)"], ["cardtype", "MPEG"], ["is_default", 1]], [["id", 2]]);
-	    change_or_make_entry("profilegroups", [["name", "Hardware MJPEG Encoders (Matrox G200-TV, Miro DC10, etc)"], ["cardtype", "MJPEG"], ["is_default", 1]], [["id", 3]]);
-	    change_or_make_entry("profilegroups", [["name", "Hardware HDTV"], ["cardtype", "HDTV"], ["is_default", 1]], [["id", 4]]);
-	    change_or_make_entry("profilegroups", [["name", "Hardware DVB Encoders"], ["cardtype", "DVB"], ["is_default", 1]], [["id", 5]]);
-	    change_or_make_entry("profilegroups", [["name", "Transcoders"], ["cardtype", "TRANSCODE"], ["is_default", 1]], [["id", 6]]);
-	    change_or_make_entry("profilegroups", [["name", "FireWire Input"], ["cardtype", "FIREWIRE"], ["is_default", 1]], [["id", 7]]);
-	    change_or_make_entry("profilegroups", [["name", "USB Mpeg-4 Encoder (Plextor ConvertX, etc)"], ["cardtype", "GO7007"], ["is_default", 1]], [["id", 8]]);
-	    change_or_make_entry("profilegroups", [["name", "DBOX2 Input"], ["cardtype", "DBOX2"], ["is_default", 1]], [["id", 9]]);
-	    change_or_make_entry("profilegroups", [["name", "Freebox Input"], ["cardtype", "Freebox"], ["is_default", 1]], [["id", 10]]);
-	    change_or_make_entry("profilegroups", [["name", "HDHomeRun Recorders"], ["cardtype", "HDHOMERUN"], ["is_default", 1]], [["id", 11]]);
-	    change_or_make_entry("profilegroups", [["name", "CRC IP Recorders"], ["cardtype", "CRC_IP"], ["is_default", 1]], [["id", 12]]);
+	    change_or_make_entry("profilegroups", [["name", "MPEG-2 Encoders (PVR-x50, PVR-500)"], ["cardtype", "MPEG"], ["is_default", 1]], [["id", 2]]); # rename the default entry for improved usability
 
+	    #
+	    # Websites for mythbrowser
+	    #
+	    change_or_make_entry("websites", [["grp", "LinHeS"], ["dsc", ""], ["updated", ""]], [["url", "http://knoppmyth.net"]]);
+	    change_or_make_entry("websites", [["grp", "LinHeS"], ["dsc", ""], ["updated", ""]], [["url", "http://knoppmythwiki.org"]]);
+
+	    
 	    do_query("INSERT INTO codecparams (profile, name, value) VALUES (21, 'transcodelossless', 0)");
 	    do_query("INSERT INTO codecparams (profile, name, value) VALUES (21, 'transcoderesize', 0)");
 	    do_query("INSERT INTO codecparams (profile, name, value) VALUES (21, 'mpeg4bitrate', 2200)");
@@ -255,60 +221,10 @@ sub implement_option {
 	    do_query("INSERT INTO codecparams (profile, name, value) VALUES (29, 'mp3quality', 7)");
 	    do_query("INSERT INTO codecparams (profile, name, value) VALUES (29, 'volume', 100)");
 
-	    # I don't know why we have so many of these.  Only profilegroup 6 seems to matter.
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 1]], [["id", 1]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 1]], [["id", 2]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 1]], [["id", 3]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 1]], [["id", 4]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 2]], [["id", 5]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 2]], [["id", 6]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 2]], [["id", 7]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 2]], [["id", 8]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 3]], [["id", 9]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 3]], [["id", 10]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 3]], [["id", 11]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 3]], [["id", 12]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 4]], [["id", 13]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 4]], [["id", 14]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 4]], [["id", 15]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 4]], [["id", 16]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 5]], [["id", 17]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 5]], [["id", 18]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 5]], [["id", 19]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 5]], [["id", 20]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'RTjpeg/MPEG4'], ["profilegroup", 6], ["videocodec", "MPEG-4"], ["audiocodec", "Uncompressed"]], [["id", 21]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'MPEG2'], ["profilegroup", 6], ["videocodec", "MPEG-4"], ["audiocodec", "Uncompressed"]], [["id", 22]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 8]], [["id", 23]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 8]], [["id", 24]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 8]], [["id", 25]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 8]], [["id", 26]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 6]], [["id", 27]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Medium Quality'], ["profilegroup", 6], ["videocodec", "MPEG-4"], ["audiocodec", "Uncompressed"]], [["id", 28]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 6], ["videocodec", "MPEG-4"], ["audiocodec", "MP3"]], [["id", 29]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 10]], [["id", 30]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 10]], [["id", 31]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 10]], [["id", 32]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 10]], [["id", 33]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 11]], [["id", 34]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 11]], [["id", 35]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 11]], [["id", 36]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 11]], [["id", 37]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 12]], [["id", 38]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 12]], [["id", 39]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 12]], [["id", 40]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 12]], [["id", 41]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 7]], [["id", 42]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 7]], [["id", 43]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 7]], [["id", 44]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 7]], [["id", 45]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Default'], ["profilegroup", 9]], [["id", 46]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Live TV'], ["profilegroup", 9]], [["id", 47]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'High Quality'], ["profilegroup", 9]], [["id", 48]]);
-	    change_or_make_entry("recordingprofiles", [["name", 'Low Quality'], ["profilegroup", 9]], [["id", 49]]);
-
 	    #
 	    # settings
 	    #
+	    change_or_make_setting('AlwaysStreamFiles', '1'); # new in R6
 	    change_or_make_setting('AutoCommercialSkip', '1');
 	    change_or_make_setting('AutoExpireWatchedPriority', '1');
 	    change_or_make_setting('BackendServerPort', '6543');
@@ -321,6 +237,8 @@ sub implement_option {
 	    change_or_make_setting('DefaultRipQuality', '1');
 	    change_or_make_setting('DefaultTranscoder', '28'); # change this number if you redefine the transcoders above
 	    change_or_make_setting('Deinterlace', '1');
+	    change_or_make_setting('DeletesFollowLinks', '1');
+	    change_or_make_setting('DisableFirewireReset', '0');
 	    change_or_make_setting('EITCrawIdleStart','60');
 	    change_or_make_setting('EITIgnoresSource','0');
 	    change_or_make_setting('EITTimeOffset','Auto');
@@ -331,7 +249,36 @@ sub implement_option {
 	    change_or_make_setting('EndOfRecordingExitPrompt','1');
 	    change_or_make_setting('GalleryDir', $SQL_DirPics);
 	    change_or_make_setting('GalleryRecursiveSlideshow', '1');
-	    change_or_make_setting('HaltCommand', 'sudo halt');
+	    change_or_make_setting('HaltCommand', 'sudo /sbin/halt');
+	    change_or_make_setting('HostAudiotype','ALSA');
+	    change_or_make_setting('HostMiro','1');
+	    change_or_make_setting('HostMyhostname','type_hostname_here');
+	    change_or_make_setting('HostXine','1');
+	    change_or_make_setting('Hostpluginmythappletrailers','1');
+	    change_or_make_setting('Hostpluginmytharchive','1');
+	    change_or_make_setting('Hostpluginmythbrowser','1');
+	    change_or_make_setting('Hostpluginmythcontrols','1');
+	    change_or_make_setting('Hostpluginmythflix','1');
+	    change_or_make_setting('Hostpluginmythgallery','1');
+	    change_or_make_setting('Hostpluginmythgame','1');
+	    change_or_make_setting('HostpluginmythgameFceu','1');
+	    change_or_make_setting('HostpluginmythgameMame','1');
+	    change_or_make_setting('HostpluginmythgameMame','1');
+	    change_or_make_setting('HostpluginmythgameROMDB','1');
+	    change_or_make_setting('HostpluginmythgameXE','1');
+	    change_or_make_setting('HostpluginmythgameZsnes','1');
+	    change_or_make_setting('HostpluginmythgameZsnes','1');
+	    change_or_make_setting('Hostpluginmythmovietime','1');
+	    change_or_make_setting('Hostpluginmythmusic','1');
+	    change_or_make_setting('Hostpluginmythnews','1');
+	    change_or_make_setting('Hostpluginmythphone','1');
+	    change_or_make_setting('Hostpluginmythsmolt','1');
+	    change_or_make_setting('Hostpluginmythstream','1');
+	    change_or_make_setting('Hostpluginmythvideo','1');
+	    change_or_make_setting('Hostpluginmythvideo_dvdcss','0');
+	    change_or_make_setting('Hostpluginmythvideo_dvdcss','0');
+	    change_or_make_setting('Hostpluginmythvodka','1');
+	    change_or_make_setting('Hostpluginmythweather','1');
 	    change_or_make_setting('JobAllowCommFlag', '1');
 	    change_or_make_setting('JobAllowTranscode', '1');
 	    change_or_make_setting('JobAllowUserJob1', '1');
@@ -345,6 +292,9 @@ sub implement_option {
 	    change_or_make_setting('JobQueueWindowStart','00:00');
 	    change_or_make_setting('JobsRunOnRecordHost','0');
 	    change_or_make_setting('LiveTVInAllPrograms','1');
+	    change_or_make_setting('MasterMixerVolume','100');
+	    change_or_make_setting('MasterServerIP', '127.0.0.1');
+	    change_or_make_setting('MasterServerPort', '6543');
 	    change_or_make_setting('MediaChangeEvents','1');
 	    change_or_make_setting('MonitorDrives', '1');
 	    change_or_make_setting('MusicLocation', $SQL_DirMusic);
@@ -356,6 +306,8 @@ sub implement_option {
 	    change_or_make_setting('MythFillDatabasePath', '/usr/bin/nice -n 19 /usr/bin/mythfilldatabase');
 	    change_or_make_setting('MythFillEnabled', '1');
 	    change_or_make_setting('MythTVtv', $SQL_DirTV);
+	    change_or_make_setting('NetworkControlEnabled', '1');
+	    change_or_make_setting('PCMMixerVolume', '50');
 	    change_or_make_setting('PVR350VideoDev', '/dev/video16');
 	    change_or_make_setting('PlayBoxShading', '0');
 	    change_or_make_setting('PlayMode', 'none');
@@ -363,11 +315,15 @@ sub implement_option {
 	    change_or_make_setting('PlaybackPreviewLowCPU', '1');
 #	    change_or_make_setting('PlaybackReturnPrompt', '1');
 #	    change_or_make_setting('PlaybackReturnPrompt', '2');
+	    change_or_make_setting('RebootCommand', 'sudo /sbin/reboot');
 	    change_or_make_setting('RecordFilePrefix',$SQL_DirTV);
 	    change_or_make_setting('SelectChangesChannel', '1');
+	    change_or_make_setting('ServerHaltCommand', 'sudo /sbin/halt -p');
 	    change_or_make_setting('ShowWholeTree', '1');
 	    change_or_make_setting('SmartChannelChange', '1');
+	    change_or_make_setting('StartupSecsBeforeRecording', '120');
 	    change_or_make_setting('TruncateDeletesSlowly', '1');
+	    change_or_make_setting('UseOutputPictureControls', '1');
 	    change_or_make_setting('UserJob1', 'myth2ipod -cut \"%DIR%\" \"%FILE%\"');
 	    change_or_make_setting('UserJob2', 'myt2xvid3 -cut \"%DIR%\" \"%FILE%\"');
 	    change_or_make_setting('UserJobDesc1', 'Encode for iPod');
@@ -389,14 +345,26 @@ sub implement_option {
 	    change_or_make_setting('WebBrowserScrollSpeed','4');
 	    change_or_make_setting('WebBrowserZoomLevel','20');
 	    change_or_make_setting('WebcamDevice','/dev/video');
+	    change_or_make_setting('WOLbackendCommand','');
+	    change_or_make_setting('WOLbackendConnectRetry','5');
+	    change_or_make_setting('WOLslaveBackendsCommand','');
+	    change_or_make_setting('WakeupTimeFormat','hh:mm yyyy-MM-dd');
+	    change_or_make_setting('WatchTVGuide','0');
+	    change_or_make_setting('WeatherDBSchemaVer','1000');
+	    change_or_make_setting('WebBrowserCommand','/usr/bin/mythbrowser');
+	    change_or_make_setting('WebBrowserHideScrollbars','0');
+	    change_or_make_setting('WebBrowserScrollMode','1');
+	    change_or_make_setting('WebBrowserScrollSpeed','4');
+	    change_or_make_setting('WebBrowserZoomLevel','20');
+	    change_or_make_setting('XineramaScreen','0');
 	    change_or_make_setting('blockSDWUwithoutClient','1');
+	    change_or_make_setting('idleWaitForRecordingTime','15');
 	    change_or_make_setting('mythdvd.DVDPlayerCommand', 'Internal');
 	    change_or_make_setting('mythvideo.VideoTreeRemember', '1');
 	    change_or_make_setting('mythfilldatabaseLastRunStart','');
 	    change_or_make_setting('mythfilldatabaseLastRunEnd','');
 	    change_or_make_setting('mythfilldatabaseLastRunStatus','');
 
-	    
 
 #	    # As much of MythWeather as we can automate for now
 	    my $units = 0;
diff --git a/abs/core-testing/tweaker/bin/twk_linux.pl b/abs/core-testing/tweaker/bin/twk_linux.pl
deleted file mode 100755
index f8b46fb..0000000
--- a/abs/core-testing/tweaker/bin/twk_linux.pl
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/usr/bin/perl -w
-
-# Copyright 2007-2009 Robert ("Bob") Igo of StormLogic, LLC and mythic.tv.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program.  If not, see <http://www.gnu.org/licenses/>.
-
-use Switch;
-use Tweaker::Script;
-package Tweaker::Script;
-
-set_known_options( 'all' );
-
-# Try to implement the given option.
-sub implement_option {
-    my($option) = @_;
-
-    my $command;
-    my $apacheconf = "/etc/apache2/apache2.conf";
-    # Linux-centric tweaks
-
-    my @commands = (
-	# erases any previous ServerName and adds a new one
-	"sed -i 's/ServerName.*//g' $apacheconf && echo -n \"ServerName \" >> $apacheconf && hostname >> $apacheconf",
-	# make autofs run automatically
-	"/etc/init.d/autofs stop && /etc/init.d/autofs start && /usr/sbin/update-rc.d -f autofs remove && /usr/sbin/update-rc.d autofs start 45 3 5 .",
-	# set up NTP
-	"/etc/init.d/ntp restart && /usr/sbin/update-rc.d -f ntp remove && /usr/sbin/update-rc.d ntp defaults 85"
-	);
-    
-    foreach my $command (@commands) {
-	if (my $result = execute_shell_command($command)) {
-	    my $logger = get_logger('tweaker.script');
-	    $logger->info("result: $result");
-	}
-    }
-}
-
-# Try to get a Recommendation Level for $option.
-sub poll_options {
-    my($option) = @_;
-    recommendation_level("recommended", "These tweaks benefit all users.");
-}
-
-# Unimplemented in 0.7
-sub check_option {
-    help;
-}
-
-# Unimplemented in 0.7
-sub count_iterations {
-    help;
-}
-
-process_parameters;
diff --git a/abs/core-testing/tweaker/bin/twk_localization.pl b/abs/core-testing/tweaker/bin/twk_localization.pl
index 572ee06..fc84440 100755
--- a/abs/core-testing/tweaker/bin/twk_localization.pl
+++ b/abs/core-testing/tweaker/bin/twk_localization.pl
@@ -37,11 +37,13 @@ sub implement_option {
 		change_or_make_setting('Language', 'EN') || exit -1;
 		change_or_make_setting('ISO639Language0', 'eng') || exit -1;
 		change_or_make_setting('ISO639Language1', 'eng') || exit -1;
+		change_or_make_setting('MythArchiveVideoFormat', 'NTSC') || exit -1;
 	    }
 	    case "GB_English" {
 		change_or_make_setting('Language', 'EN_GB') || exit -1;
 		change_or_make_setting('ISO639Language0', 'eng') || exit -1;
 		change_or_make_setting('ISO639Language1', 'eng') || exit -1;
+		change_or_make_setting('MythArchiveVideoFormat', 'PAL') || exit -1;
 	    }
 	}
     } else {
-- 
cgit v0.12