From 5c5c2effa0a2ba11497c60bf1c04e1fd09148836 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 23 Oct 2008 22:53:41 -0500
Subject: change php/lighttpd configs to support mythweb.

---
 abs/core-testing/libmcrypt/PKGBUILD            |  22 ++
 abs/core-testing/libmcrypt/aclocal-fixes.patch |  11 +
 abs/core-testing/lighttpd/PKGBUILD             |  30 ++-
 abs/core-testing/lighttpd/lighttpd.conf        | 347 +++++++++++++++++++++++++
 abs/core-testing/php/PKGBUILD                  |  56 ++--
 abs/core-testing/php/php.ini                   |  10 +-
 6 files changed, 428 insertions(+), 48 deletions(-)
 create mode 100644 abs/core-testing/libmcrypt/PKGBUILD
 create mode 100644 abs/core-testing/libmcrypt/aclocal-fixes.patch
 create mode 100644 abs/core-testing/lighttpd/lighttpd.conf

diff --git a/abs/core-testing/libmcrypt/PKGBUILD b/abs/core-testing/libmcrypt/PKGBUILD
new file mode 100644
index 0000000..bdacb84
--- /dev/null
+++ b/abs/core-testing/libmcrypt/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=libmcrypt
+pkgver=2.5.8
+pkgrel=1
+pkgdesc="A library which provides a uniform interface to several symmetric encryption algorithms"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('glibc')
+options=('!libtool')
+source=(http://heanet.dl.sourceforge.net/mcrypt/${pkgname}-${pkgver}.tar.bz2)
+url="http://mcrypt.sourceforge.net/"
+md5sums=('c4f491dd411a09e9de3b8702ea6f73eb')
+
+build() {
+  cd ${startdir}/src/${pkgname}-${pkgver}
+  ./configure --prefix=/usr 
+  make || return 1
+  make DESTDIR=${startdir}/pkg install
+}
diff --git a/abs/core-testing/libmcrypt/aclocal-fixes.patch b/abs/core-testing/libmcrypt/aclocal-fixes.patch
new file mode 100644
index 0000000..f001a18
--- /dev/null
+++ b/abs/core-testing/libmcrypt/aclocal-fixes.patch
@@ -0,0 +1,11 @@
+--- lib/libmcrypt.m4.orig	2006-03-05 13:47:22.000000000 +0000
++++ lib/libmcrypt.m4	2006-03-05 13:47:39.000000000 +0000
+@@ -14,7 +14,7 @@
+ dnl AM_PATH_LIBMCRYPT([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
+ dnl Test for libmcrypt, and define LIBMCRYPT_CFLAGS and LIBMCRYPT_LIBS
+ dnl
+-AC_DEFUN(AM_PATH_LIBMCRYPT,
++AC_DEFUN([AM_PATH_LIBMCRYPT],
+ [dnl
+ dnl Get the cflags and libraries from the libmcrypt-config script
+ dnl
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index 2c0132b..65de89d 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id: PKGBUILD 13948 2008-09-30 12:03:07Z douglas $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-
 pkgname=lighttpd
 pkgver=1.4.20
-pkgrel=1
+pkgrel=3
 pkgdesc='a secure, fast, compliant and very flexible web-server'
 license=('custom')
 arch=('i686' 'x86_64')
@@ -22,7 +19,7 @@ backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd')
 options=('!libtool' 'emptydirs')
 install='lighttpd.install'
 source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
-        'lighttpd.rc.d' 'lighttpd.logrotate.d')
+        'lighttpd.rc.d' 'lighttpd.logrotate.d' lighttpd.conf)
 
 md5sums=('ed6ee0bb714f393219a32768d86984d8'
          'bd690eee0d9e51857448770a151023b0'
@@ -54,18 +51,23 @@ build() {
 	install -D -m755 ../lighttpd.rc.d $pkgdir/etc/rc.d/lighttpd
 	install -D -m644 ../lighttpd.logrotate.d $pkgdir/etc/logrotate.d/lighttpd
 	install -d -m755 $pkgdir/var/run/lighttpd/
+	install -d -m755 $pkgdir/var/run/lighttpd/
 	install -d -m755 -o http -g http $pkgdir/var/log/lighttpd/
 
-	install -D -m644 doc/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
 
-	# set sane defaults
-	sed -e 's|/srv/www/htdocs/|/srv/http/|' \
-	    -e 's|/srv/www/|/srv/http/|' \
-	    -e 's|#server.username            = "wwwrun"|server.username            = "http"|' \
-	    -e 's|#server.groupname           = "wwwrun"|server.groupname           = "http"|' \
-	    -e 's|#server.pid-file            = "/var/run/lighttpd.pid"|server.pid-file            = "/var/run/lighttpd/lighttpd.pid"|' \
-	    -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
-	    -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
 
+	# set sane defaults
+	#sed -e 's|/srv/www/htdocs/|/srv/http/|' \
+	#    -e 's|/srv/www/|/srv/http/|' \
+	#    -e 's|#server.username            = "wwwrun"|server.username            = "http"|' \
+	#    -e 's|#server.groupname           = "wwwrun"|server.groupname           = "http"|' \
+	#    -e 's|#server.pid-file            = "/var/run/lighttpd.pid"|server.pid-file            = "/var/run/lighttpd/lighttpd.pid"|' \
+	#    -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
+	#    -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+	install -D -m644 $startdir/src/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
 	install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
 }
+
+#changelog
+#remove ldap
+#add custom lighttpd.conf
diff --git a/abs/core-testing/lighttpd/lighttpd.conf b/abs/core-testing/lighttpd/lighttpd.conf
new file mode 100644
index 0000000..df5990b
--- /dev/null
+++ b/abs/core-testing/lighttpd/lighttpd.conf
@@ -0,0 +1,347 @@
+# lighttpd configuration file
+#
+# use it as a base for lighttpd 1.0.0 and above
+#
+# $Id: lighttpd.conf,v 1.7 2004/11/03 22:26:05 weigon Exp $
+
+############ Options you really have to take care of ####################
+
+## modules to load
+# at least mod_access and mod_accesslog should be loaded
+# all other module should only be loaded if really neccesary
+# - saves some time
+# - saves memory
+server.modules              = (
+                               "mod_rewrite",
+#                               "mod_redirect",
+#                               "mod_alias",
+                                "mod_access",
+#                               "mod_cml",
+#                               "mod_trigger_b4_dl",
+#                               "mod_auth",
+#                               "mod_status",
+                               "mod_setenv",
+                               "mod_fastcgi",
+#                               "mod_proxy",
+#                               "mod_simple_vhost",
+#                               "mod_evhost",
+#                               "mod_userdir",
+                               "mod_cgi",
+#                               "mod_compress",
+#                               "mod_ssi",
+#                               "mod_usertrack",
+#                               "mod_expire",
+#                               "mod_secdownload",
+#                               "mod_rrdtool",
+                                "mod_accesslog" )
+
+## a static document-root, for virtual-hosting take look at the
+## server.virtual-* options
+server.document-root        = "/srv/http/"
+
+## where to send error-messages to
+server.errorlog             = "/var/log/lighttpd/error.log"
+
+# files to check for if .../ is requested
+index-file.names            = ( "index.php", "index.html",
+                                "index.htm", "default.htm" , "mythweb.php" )
+
+## set the event-handler (read the performance section in the manual)
+# server.event-handler = "freebsd-kqueue" # needed on OS X
+
+# mimetype mapping
+mimetype.assign             = (
+  ".pdf"          =>      "application/pdf",
+  ".sig"          =>      "application/pgp-signature",
+  ".spl"          =>      "application/futuresplash",
+  ".class"        =>      "application/octet-stream",
+  ".ps"           =>      "application/postscript",
+  ".torrent"      =>      "application/x-bittorrent",
+  ".dvi"          =>      "application/x-dvi",
+  ".gz"           =>      "application/x-gzip",
+  ".pac"          =>      "application/x-ns-proxy-autoconfig",
+  ".swf"          =>      "application/x-shockwave-flash",
+  ".tar.gz"       =>      "application/x-tgz",
+  ".tgz"          =>      "application/x-tgz",
+  ".tar"          =>      "application/x-tar",
+  ".zip"          =>      "application/zip",
+  ".mp3"          =>      "audio/mpeg",
+  ".m3u"          =>      "audio/x-mpegurl",
+  ".wma"          =>      "audio/x-ms-wma",
+  ".wax"          =>      "audio/x-ms-wax",
+  ".ogg"          =>      "application/ogg",
+  ".wav"          =>      "audio/x-wav",
+  ".gif"          =>      "image/gif",
+  ".jar"          =>      "application/x-java-archive",
+  ".jpg"          =>      "image/jpeg",
+  ".jpeg"         =>      "image/jpeg",
+  ".png"          =>      "image/png",
+  ".xbm"          =>      "image/x-xbitmap",
+  ".xpm"          =>      "image/x-xpixmap",
+  ".xwd"          =>      "image/x-xwindowdump",
+  ".css"          =>      "text/css",
+  ".html"         =>      "text/html",
+  ".htm"          =>      "text/html",
+  ".js"           =>      "text/javascript",
+  ".asc"          =>      "text/plain",
+  ".c"            =>      "text/plain",
+  ".cpp"          =>      "text/plain",
+  ".log"          =>      "text/plain",
+  ".conf"         =>      "text/plain",
+  ".text"         =>      "text/plain",
+  ".txt"          =>      "text/plain",
+  ".dtd"          =>      "text/xml",
+  ".xml"          =>      "text/xml",
+  ".mpeg"         =>      "video/mpeg",
+  ".mpg"          =>      "video/mpeg",
+  ".mov"          =>      "video/quicktime",
+  ".qt"           =>      "video/quicktime",
+  ".avi"          =>      "video/x-msvideo",
+  ".asf"          =>      "video/x-ms-asf",
+  ".asx"          =>      "video/x-ms-asf",
+  ".wmv"          =>      "video/x-ms-wmv",
+  ".bz2"          =>      "application/x-bzip",
+  ".tbz"          =>      "application/x-bzip-compressed-tar",
+  ".tar.bz2"      =>      "application/x-bzip-compressed-tar",
+  # default mime type
+  ""              =>      "application/octet-stream",
+ )
+
+# Use the "Content-Type" extended attribute to obtain mime type if possible
+#mimetype.use-xattr        = "enable"
+
+
+## send a different Server: header
+## be nice and keep it at lighttpd
+# server.tag                 = "lighttpd"
+
+#### accesslog module
+accesslog.filename          = "/var/log/lighttpd/access.log"
+
+## deny access the file-extensions
+#
+# ~    is for backupfiles from vi, emacs, joe, ...
+# .inc is often used for code includes which should in general not be part
+#      of the document-root
+url.access-deny             = ( "~", ".inc" )
+
+$HTTP["url"] =~ "\.pdf$" {
+  server.range-requests = "disable"
+}
+
+##
+# which extensions should not be handle via static-file transfer
+#
+# .php, .pl, .fcgi are most often handled by mod_fastcgi or mod_cgi
+static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
+
+######### Options that are good to be but not neccesary to be changed #######
+
+## bind to port (default: 80)
+#server.port                = 81
+
+## bind to localhost (default: all interfaces)
+#server.bind                = "127.0.0.1"
+
+## error-handler for status 404
+#server.error-handler-404   = "/error-handler.html"
+#server.error-handler-404   = "/error-handler.php"
+
+## to help the rc.scripts
+server.pid-file            = "/var/run/lighttpd/lighttpd.pid"
+
+
+###### virtual hosts
+##
+##  If you want name-based virtual hosting add the next three settings and load
+##  mod_simple_vhost
+##
+## document-root =
+##   virtual-server-root + virtual-server-default-host + virtual-server-docroot
+## or
+##   virtual-server-root + http-host + virtual-server-docroot
+##
+#simple-vhost.server-root   = "/srv/http/vhosts/"
+#simple-vhost.default-host  = "www.example.org"
+#simple-vhost.document-root = "/htdocs/"
+
+
+##
+## Format: <errorfile-prefix><status-code>.html
+## -> ..../status-404.html for 'File not found'
+#server.errorfile-prefix    = "/usr/share/lighttpd/errors/status-"
+#server.errorfile-prefix    = "/srv/http/errors/status-"
+
+## virtual directory listings
+#dir-listing.activate       = "enable"
+## select encoding for directory listings
+#dir-listing.encoding        = "utf-8"
+
+## enable debugging
+#debug.log-request-header   = "enable"
+#debug.log-response-header  = "enable"
+#debug.log-request-handling = "enable"
+#debug.log-file-not-found   = "enable"
+
+### only root can use these options
+#
+# chroot() to directory (default: no chroot() )
+#server.chroot              = "/"
+
+## change uid to <uid> (default: don't care)
+server.username            = "http"
+
+## change uid to <uid> (default: don't care)
+server.groupname           = "http"
+
+#### compress module
+#compress.cache-dir         = "/var/cache/lighttpd/compress/"
+#compress.filetype          = ("text/plain", "text/html")
+
+#### proxy module
+## read proxy.txt for more info
+#proxy.server               = ( ".php" =>
+#                               ( "localhost" =>
+#                                 (
+#                                   "host" => "192.168.0.101",
+#                                   "port" => 80
+#                                 )
+#                               )
+#                             )
+
+#### fastcgi module
+## read fastcgi.txt for more info
+## for PHP don't forget to set cgi.fix_pathinfo = 1 in the php.ini
+ fastcgi.server = (
+        ".php" => ((
+            "bin-path" => "/usr/bin/php-cgi",
+            "socket"   => "/var/run/lighttpd/mythtv-php-fcgi.socket",
+            "broken-scriptfilename" => "enable",
+            "bin-environment" => (
+                "db_server"   => "localhost",
+                "db_name"     => "mythconverg",
+                "db_login"    => "mythtv",
+                "db_password" => "mythtv"
+            )
+        ))
+    )
+
+     setenv.add-environment = (
+             "db_server"   => "localhost",
+             "db_name"     => "mythconverg",
+             "db_login"    => "mythtv",
+             "db_password" => "mythtv"
+)	
+#### CGI module
+cgi.assign                 = ( ".pl"  => "/usr/bin/perl",
+                               ".cgi" => "/bin/bash" )
+
+   url.rewrite-once = (
+        "^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
+       "^/mythweb/(pl(/.*)?)$" => "/mythweb/mythweb.pl/$1",
+       "^/mythweb/(.+)$"       => "/mythweb/mythweb.php/$1",
+       "^/mythweb/(.*)$"       => "/mythweb/mythweb.php"
+   )
+
+
+
+#### SSL engine
+#ssl.engine                 = "enable"
+#ssl.pemfile                = "/etc/ssl/private/lighttpd.pem"
+
+#### status module
+#status.status-url          = "/server-status"
+#status.config-url          = "/server-config"
+
+#### auth module
+## read authentication.txt for more info
+#auth.backend               = "plain"
+#auth.backend.plain.userfile = "lighttpd.user"
+#auth.backend.plain.groupfile = "lighttpd.group"
+
+#auth.backend.ldap.hostname = "localhost"
+#auth.backend.ldap.base-dn  = "dc=my-domain,dc=com"
+#auth.backend.ldap.filter   = "(uid=$)"
+
+#auth.require               = ( "/server-status" =>
+#                               (
+#                                 "method"  => "digest",
+#                                 "realm"   => "download archiv",
+#                                 "require" => "user=jan"
+#                               ),
+#                               "/server-config" =>
+#                               (
+#                                 "method"  => "digest",
+#                                 "realm"   => "download archiv",
+#                                 "require" => "valid-user"
+#                               )
+#                             )
+
+#### url handling modules (rewrite, redirect, access)
+#url.rewrite                = ( "^/$"             => "/server-status" )
+#url.redirect               = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
+#### both rewrite/redirect support back reference to regex conditional using %n
+#$HTTP["host"] =~ "^www\.(.*)" {
+#  url.redirect            = ( "^/(.*)" => "http://%1/$1" )
+#}
+
+#
+# define a pattern for the host url finding
+# %% => % sign
+# %0 => domain name + tld
+# %1 => tld
+# %2 => domain name without tld
+# %3 => subdomain 1 name
+# %4 => subdomain 2 name
+#
+#evhost.path-pattern        = "/srv/http/vhosts/%3/htdocs/"
+
+#### expire module
+#expire.url                 = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")
+
+#### ssi
+#ssi.extension              = ( ".shtml" )
+
+#### rrdtool
+#rrdtool.binary             = "/usr/bin/rrdtool"
+#rrdtool.db-name            = "/var/lib/lighttpd/lighttpd.rrd"
+
+#### setenv
+#setenv.add-request-header  = ( "TRAV_ENV" => "mysql://user@host/db" )
+#setenv.add-response-header = ( "X-Secret-Message" => "42" )
+
+## for mod_trigger_b4_dl
+# trigger-before-download.gdbm-filename = "/var/lib/lighttpd/trigger.db"
+# trigger-before-download.memcache-hosts = ( "127.0.0.1:11211" )
+# trigger-before-download.trigger-url = "^/trigger/"
+# trigger-before-download.download-url = "^/download/"
+# trigger-before-download.deny-url = "http://127.0.0.1/index.html"
+# trigger-before-download.trigger-timeout = 10
+
+## for mod_cml
+## don't forget to add index.cml to server.indexfiles
+# cml.extension               = ".cml"
+# cml.memcache-hosts          = ( "127.0.0.1:11211" )
+
+#### variable usage:
+## variable name without "." is auto prefixed by "var." and becomes "var.bar"
+#bar = 1
+#var.mystring = "foo"
+
+## integer add
+#bar += 1
+## string concat, with integer cast as string, result: "www.foo1.com"
+#server.name = "www." + mystring + var.bar + ".com"
+## array merge
+#index-file.names = (foo + ".php") + index-file.names
+#index-file.names += (foo + ".php")
+
+#### include
+#include /etc/lighttpd/lighttpd-inc.conf
+## same as above if you run: "lighttpd -f /etc/lighttpd/lighttpd.conf"
+#include "lighttpd-inc.conf"
+
+#### include_shell
+#include_shell "echo var.a=1"
+## the above is same as:
+#var.a=1
diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index 68ece33..c9c92ac 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id: PKGBUILD 4664 2008-07-08 13:58:05Z allan $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-
 pkgname=php
 pkgver=5.2.6
-pkgrel=4
+pkgrel=6
 _suhosinver=0.9.6.2
 pkgdesc='A high-level scripting language'
 arch=('i686' 'x86_64')
@@ -12,10 +9,15 @@ url='http://www.php.net'
 backup=('etc/php/php.ini')
 install=php.install
 depends=('glibc' 'readline' 'ncurses' 'libxml2' 'pcre')
-makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' \
-             'libpng' 'libjpeg' 'sqlite3' 'unixodbc' 'net-snmp' \
-             'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'freetype2' 'libjpeg' \
+#makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' \
+#             'libpng' 'libjpeg' 'sqlite3' 'unixodbc' 'net-snmp' \
+#       	'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'freetype2' 'libjpeg' \
+#             'curl' 'libxslt' 'pam' 'openssl' 'bzip2' 'gdbm' 'db>=4.7')
+
+makedepends=('mysql' 'libpng' 'libjpeg' 'sqlite3' \
+       	'libmcrypt' 'libtool' 'freetype2' 'libjpeg' \
              'curl' 'libxslt' 'pam' 'openssl' 'bzip2' 'gdbm' 'db>=4.7')
+
 optdepends=('bzip2: bz2' \
             'curl: curl' \
             'gdbm: dba' \
@@ -40,11 +42,7 @@ options=('emptydirs')
 source=("http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2" \
         "http://download.suhosin.org/suhosin-patch-${pkgver}-${_suhosinver}.patch.gz" \
         'php.ini' 'apache.conf' 'db-configure.patch')
-md5sums=('7380ffecebd95c6edb317ef861229ebd'
-         'f2ec986341a314c271259dbe4d940858'
-         '0ee1dad48f7d67af3d2c78ca6eed68ba'
-         '96ca078be6729b665be8a865535a97bf'
-         '74e5ce5a02488ec91b1c59f539e42936')
+
 
 build() {
 	phpconfig="--prefix=/usr \
@@ -78,9 +76,9 @@ build() {
 	--with-jpeg-dir=shared,/usr \
 	--with-png-dir=shared,/usr \
 	--with-gettext=shared \
-	--with-imap=shared \
-	--with-imap-ssl=shared \
-	--with-ldap=shared \
+	--without-imap \
+	--without-imap-ssl \
+	--without-ldap \
 	--enable-mbstring=shared \
 	--with-mcrypt=shared \
 	--with-mysql=shared \
@@ -88,22 +86,22 @@ build() {
 	--with-mysql=shared \
 	--with-mysqli=shared \
 	--with-ncurses=shared \
-	--with-unixODBC=shared,/usr \
+	--without-unixODBC \
 	--enable-pdo=shared \
 	--with-pdo-mysql=shared \
 	--with-pdo-sqlite=shared \
-	--with-pdo-odbc=shared,unixODBC,/usr \
-	--with-pdo-pgsql=shared \
+	--without-pdo-odbc \
+	--without-pdo-pgsql \
 	--with-sqlite=shared \
-	--with-pgsql=shared \
+	--without-pgsql \
 	--enable-shmop=shared \
-	--with-snmp=shared \
+	--without-snmp \
 	--enable-soap=shared \
 	--enable-sqlite-utf8=shared \
 	--enable-sysvmsg=shared \
 	--enable-sysvsem=shared \
 	--enable-sysvshm=shared \
-	--with-tidy=shared \
+	--without-tidy \
 	--with-xsl=shared \
 	--enable-zip=shared \
 	--enable-posix=shared \
@@ -118,7 +116,7 @@ build() {
 	--enable-json=shared \
 	--with-iconv=shared \
 	--with-xmlrpc=shared \
-	--with-pspell=shared \
+	--without-pspell \
 	--with-freetype-dir=shared,/usr \
 	--with-mime-magic=shared \
 	"
@@ -164,11 +162,11 @@ build() {
 	install -D -m755 sapi/cgi/php-cgi ${pkgdir}/usr/bin/php-cgi || return 1
 
 	# mod_php
-	./configure ${phpconfig} \
-		--with-apxs2 \
-		--disable-cli \
-		${phpextensions} || return 1
-	make || return 1
-	install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
-	install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
+#	./configure ${phpconfig} \
+#		--with-apxs2 \
+#		--disable-cli \
+#		${phpextensions} || return 1
+#	make || return 1
+#	install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
+#	install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
 }
diff --git a/abs/core-testing/php/php.ini b/abs/core-testing/php/php.ini
index 7f78d4a..7d5c1de 100644
--- a/abs/core-testing/php/php.ini
+++ b/abs/core-testing/php/php.ini
@@ -302,7 +302,7 @@ expose_php = Off
 max_execution_time = 30     ; Maximum execution time of each script, in seconds
 max_input_time = 60	; Maximum amount of time each script may spend parsing request data
 ;max_input_nesting_level = 64 ; Maximum input variable nesting level
-memory_limit = 32M      ; Maximum amount of memory a script may consume (32MB)
+memory_limit = 64M      ; Maximum amount of memory a script may consume (32MB)
 
 
 ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
@@ -337,7 +337,7 @@ memory_limit = 32M      ; Maximum amount of memory a script may consume (32MB)
 ;
 ;   - Show all errors, except for notices and coding standards warnings
 ;
-;error_reporting = E_ALL & ~E_NOTICE
+error_reporting = E_ALL & ~E_NOTICE
 ;
 ;   - Show all errors, except for notices
 ;
@@ -368,7 +368,7 @@ error_reporting  =  E_ALL
 ;
 ; Default
 ;
-display_errors = Off
+display_errors = on
 
 ; Even when display_errors is on, errors that occur during PHP's startup
 ; sequence are not displayed.  It's strongly recommended to keep
@@ -1270,7 +1270,7 @@ extension=gettext.so
 ;extension=ldap.so
 ;extension=mcrypt.so
 ;extension=mime_magic.so
-;extension=mysql.so
+extension=mysql.so
 ;extension=mysqli.so
 ;extension=ncurses.so
 ;extension=odbc.so
@@ -1281,7 +1281,7 @@ extension=gettext.so
 ;extension=pdo_pgsql.so
 ;extension=pdo_sqlite.so
 ;extension=pgsql.so
-;extension=posix.so
+extension=posix.so
 ;extension=pspell.so
 extension=session.so
 ;extension=shmop.so
-- 
cgit v0.12