From a1f1b06ebbe1fa0c63f21480ea5504e6f4dbebd7 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 14 Feb 2009 03:07:02 -0800
Subject: For volume leveling.

---
 abs/extra-testing/fftw/PKGBUILD              | 48 ++++++++++++++++++++++++++++
 abs/extra-testing/fftw/fftw.install          | 22 +++++++++++++
 abs/extra-testing/ladspa/PKGBUILD            | 25 +++++++++++++++
 abs/extra-testing/ladspa/hardcode-path.patch | 28 ++++++++++++++++
 abs/extra-testing/swh-plugins/PKGBUILD       | 28 ++++++++++++++++
 5 files changed, 151 insertions(+)
 create mode 100644 abs/extra-testing/fftw/PKGBUILD
 create mode 100644 abs/extra-testing/fftw/fftw.install
 create mode 100644 abs/extra-testing/ladspa/PKGBUILD
 create mode 100644 abs/extra-testing/ladspa/hardcode-path.patch
 create mode 100644 abs/extra-testing/swh-plugins/PKGBUILD

diff --git a/abs/extra-testing/fftw/PKGBUILD b/abs/extra-testing/fftw/PKGBUILD
new file mode 100644
index 0000000..1556108
--- /dev/null
+++ b/abs/extra-testing/fftw/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id: PKGBUILD 20304 2008-12-02 10:48:00Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=fftw
+pkgver=3.2
+pkgrel=1
+pkgdesc="A library for computing the discrete Fourier transform (DFT)"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.fftw.org/"
+depends=('glibc')
+options=(!libtool)
+source=(http://www.fftw.org/${pkgname}-${pkgver}.tar.gz)
+install=fftw.install
+
+# notes:
+# http://www.fftw.org/fftw2_doc/fftw_6.html#SEC69
+# http://www.fftw.org/faq/section2.html#singleprec
+# http://www.fftw.org/fftw3_doc/Precision.html#Precision
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  
+ # build & install double precision
+  ./configure F77=gfortran --prefix=/usr \
+              --enable-shared || return 1
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+  make clean 
+
+  # build & install long double precission
+  ./configure F77=gfortran --prefix=/usr \
+   --enable-long-double  --enable-shared || return 1
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+  make clean
+
+  # build + install single precision
+  ./configure F77=gfortran --prefix=/usr \
+              --enable-float --enable-shared || return 1
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+
+  # handle info files
+  rm -f $pkgdir/usr/share/info/dir
+  gzip $pkgdir/usr/share/info/*
+}
diff --git a/abs/extra-testing/fftw/fftw.install b/abs/extra-testing/fftw/fftw.install
new file mode 100644
index 0000000..a3748aa
--- /dev/null
+++ b/abs/extra-testing/fftw/fftw.install
@@ -0,0 +1,22 @@
+info_dir=/usr/share/info
+info_files=(fftw3.info)
+
+post_install() {
+  for f in ${info_files[@]}; do
+    install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+  done
+}
+
+post_upgrade() {
+        post_install
+}
+
+pre_remove() {
+  for f in ${info_files[@]}; do
+    install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+  done
+}
+
+
+
+
diff --git a/abs/extra-testing/ladspa/PKGBUILD b/abs/extra-testing/ladspa/PKGBUILD
new file mode 100644
index 0000000..c734ca0
--- /dev/null
+++ b/abs/extra-testing/ladspa/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 18545 2008-11-06 23:58:57Z jgc $
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=ladspa
+pkgver=1.13
+pkgrel=2
+pkgdesc="Linux Audio Developer's Simple Plugin API (LADSPA)"
+arch=("i686" "x86_64")
+license=('LGPL')
+url="http://www.ladspa.org/"
+depends=('gcc-libs>=4.3')
+source=(http://www.ladspa.org/download/${pkgname}_sdk_${pkgver}.tgz
+	hardcode-path.patch)
+md5sums=('671be3e1021d0722cadc7fb27054628e'
+         '27743258232d828575d66940e6de2858')
+
+build() {
+  cd "${srcdir}/${pkgname}_sdk/src"
+  patch -Np1 -i "${srcdir}/hardcode-path.patch" || return 1
+  sed -i -e 's/mkdirhier/mkdir -p/' makefile || return 1
+  make targets || return 1
+  make INSTALL_PLUGINS_DIR="${pkgdir}/usr/lib/ladspa/" \
+       INSTALL_INCLUDE_DIR="${pkgdir}/usr/include/" \
+       INSTALL_BINARY_DIR="${pkgdir}/usr/bin/" install || return 1
+}
diff --git a/abs/extra-testing/ladspa/hardcode-path.patch b/abs/extra-testing/ladspa/hardcode-path.patch
new file mode 100644
index 0000000..821c200
--- /dev/null
+++ b/abs/extra-testing/ladspa/hardcode-path.patch
@@ -0,0 +1,28 @@
+--- src/search.c.orig	2008-11-07 00:38:18.000000000 +0100
++++ src/search.c	2008-11-07 00:50:51.000000000 +0100
+@@ -83,6 +83,8 @@
+ 	dlclose(pcFilename);
+ 	free(pcFilename);
+       }
++    } else {
++      free(pcFilename);
+     }
+   }
+ }
+@@ -99,13 +101,10 @@
+ 
+   pcLADSPAPath = getenv("LADSPA_PATH");
+   if (!pcLADSPAPath) {
+-    fprintf(stderr,
+-	    "Warning: You do not have a LADSPA_PATH "
+-	    "environment variable set.\n");
+-    return;
++    pcStart = "/usr/lib/ladspa/";
++  } else {
++    pcStart = pcLADSPAPath;
+   }
+-  
+-  pcStart = pcLADSPAPath;
+   while (*pcStart != '\0') {
+     pcEnd = pcStart;
+     while (*pcEnd != ':' && *pcEnd != '\0')
diff --git a/abs/extra-testing/swh-plugins/PKGBUILD b/abs/extra-testing/swh-plugins/PKGBUILD
new file mode 100644
index 0000000..69157a1
--- /dev/null
+++ b/abs/extra-testing/swh-plugins/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 8773 2008-08-16 05:51:00Z eric $
+#Maintainer: Damir Perisa <damir.perisa@bluewin.ch>
+#Contributor: Robert Emil Berge
+
+pkgname=swh-plugins
+pkgver=0.4.15
+pkgrel=1
+pkgdesc="LADSPA Plugin-Collection from plugin.org.uk"
+arch=(i686 x86_64)
+url="http://plugin.org.uk/"
+depends=('fftw' 'ladspa')
+groups=('ladspa-plugins')
+source=(http://plugin.org.uk/releases/$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=('2fbdccef2462ea553901acd429fa3573')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+
+#Arch64 fix, -fPIC seems to be the only option
+if [ "$CARCH" = "x86_64" ]; then
+      export CFLAGS="$CFLAGS -fPIC"
+      export CXXFLAGS="$CFLAGS"
+fi
+
+ ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=$startdir/pkg install
+}
-- 
cgit v0.12