From e5ea690f0271ee1306394a38138072b2e2b66d1b Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Tue, 7 Jul 2009 20:33:14 -0400
Subject: xbmc-svn: bumped to 21337

---
 abs/extra-testing/community/xbmc-svn/CHANGELOG     |  4 +++
 abs/extra-testing/community/xbmc-svn/PKGBUILD      | 15 +++-------
 .../community/xbmc-svn/xbmc-safe-fullscreen.patch  | 35 ----------------------
 3 files changed, 8 insertions(+), 46 deletions(-)
 delete mode 100644 abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch

diff --git a/abs/extra-testing/community/xbmc-svn/CHANGELOG b/abs/extra-testing/community/xbmc-svn/CHANGELOG
index 258e5ef..ddcbd53 100644
--- a/abs/extra-testing/community/xbmc-svn/CHANGELOG
+++ b/abs/extra-testing/community/xbmc-svn/CHANGELOG
@@ -1,5 +1,9 @@
 xbmc-svn Change log:
 --------------------
+2nd July 2009
+21333   haggy: updated to current svn head which has media flagging support if your skin
+               supports it (the shipped PM3HD does already, also Aeon and MediaStream redux)
+
 3rd June 2009
 20896   haggy: enabled external libs for every lib supported despite python and ffmpeg
                enabling external python breaks python support in xbmc due to Arch's python
diff --git a/abs/extra-testing/community/xbmc-svn/PKGBUILD b/abs/extra-testing/community/xbmc-svn/PKGBUILD
index 57efdca..74d2b7e 100644
--- a/abs/extra-testing/community/xbmc-svn/PKGBUILD
+++ b/abs/extra-testing/community/xbmc-svn/PKGBUILD
@@ -5,7 +5,7 @@
 # for his xbmc-vdpau-vdr PKGBUILD at https://archvdr.svn.sourceforge.net/svnroot/archvdr/trunk/archvdr/xbmc-vdpau-vdr/PKGBUILD
 
 pkgname=xbmc-svn
-pkgver=20948
+pkgver=21337
 pkgrel=1
 pkgdesc="XBMC Media Center from SVN (linuxport branch)"
 provides=('xbmc')
@@ -27,13 +27,10 @@ optdepends=('lirc: remote controller support'
             'unrar: access compressed files without unpacking them')
 install=("${pkgname}.install")
 source=('libcurl-not-in-lib64.patch'
-        'xbmc-safe-fullscreen.patch'
 	'Lircmap.xml')
 noextract=('libcurl-not-in-lib64.patch'
-           'xbmc-safe-fullscreen.patch'
 	   'Lircmap.xml')
 md5sums=('ac1244a5b4aad0e7d59e86a0d318df1b'
-         '809c684287b68621d3b19923bb57adfe'
 	 '3f93186f1ea4aad73011d00754c7265a')
 
 options=(!makeflags)
@@ -52,15 +49,10 @@ build() {
         msg "Checking out SVN tree of -r$pkgver"
         svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod || return 1
     fi
-    msg "Done. Starting make..."
 
     # Apply patches
     cd "$srcdir/$_svnmod"
 
-    # Experimental safe fullscreen patch from the forums (by motd2k)
-    msg "Patching with xbmc-safe-fullscreen.patch"
-    patch -p0 < "$srcdir/xbmc-safe-fullscreen.patch" || return 1
-
     # Arch's libcurl lives in /usr/lib, not /usr/lib64 - fix the path:
     msg "Patching with libcurl-not-in-lib64.patch" 
     patch -p0 < "$srcdir/libcurl-not-in-lib64.patch" || return 1
@@ -71,6 +63,8 @@ build() {
     libtoolize --copy --force
     ./autogen.sh --enable-static --with-pic
 
+    cd "$srcdir/$_svnmod"
+
     # Configure XBMC
     #
     # Note on external-libs:
@@ -81,8 +75,7 @@ build() {
     #   - We don't want to rely on AUR packages, so we also don't use libass
     #     as long as it's in AUR
     msg "Configuring XBMC" 
-    cd "$srcdir/$_svnmod"
-    make distclean
+    make clean
     ./configure --prefix=${_prefix} \
                 --enable-external-libmad \
                 --enable-external-liba52 \
diff --git a/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch b/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
deleted file mode 100644
index 2da0c91..0000000
--- a/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: xbmc/Application.cpp
-===================================================================
---- xbmc/Application.cpp	(revision 20059)
-+++ xbmc/Application.cpp	(working copy)
-@@ -877,6 +877,8 @@
- #endif
- 
-   // set GUI res and force the clear of the screen
-+  if (g_guiSettings.GetBool("videoscreen.safefull"))
-+    g_guiSettings.m_LookAndFeelResolution = AUTORES;
-   g_graphicsContext.SetVideoResolution(g_guiSettings.m_LookAndFeelResolution, TRUE, true);
- 
- #ifdef _WIN32PC
-@@ -953,6 +955,9 @@
-   time(&seconds);
-   srand((unsigned int)seconds);
- 
-+  if (g_guiSettings.GetBool("videoscreen.safefull"))
-+    g_graphicsContext.ToggleFullScreenRoot();
-+
-   return CXBApplicationEx::Create(hWnd);
- }
- 
-Index: GUISettings.cpp
-===================================================================
---- xbmc/GUISettings.cpp	(revision 20824)
-+++ xbmc/GUISettings.cpp	(working copy)
-@@ -651,6 +651,7 @@
- #else
-   AddInt(6, "videoscreen.vsync", 13105, DEFAULT_VSYNC, VSYNC_DISABLED, 1, VSYNC_DRIVER, SPIN_CONTROL_TEXT);
- #endif
-+  AddBool(7, "videoscreen.safefull", 13121, false);
-   AddCategory(7, "filelists", 14018);
-   AddBool(1, "filelists.hideparentdiritems", 13306, false);
-   AddBool(2, "filelists.hideextensions", 497, false);
-- 
cgit v0.12