From 89b1295c5748aa24898ae8ba710b9d85a2b83b81 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 4 Feb 2009 00:05:43 -0800
Subject: Added miro.install to create /myth/miro and symlink appropriately to
 ~/.miro.

---
 abs/extra-testing/miro/PKGBUILD     |  2 +-
 abs/extra-testing/miro/miro.install | 24 ++++++++++++++++++++++--
 2 files changed, 23 insertions(+), 3 deletions(-)

diff --git a/abs/extra-testing/miro/PKGBUILD b/abs/extra-testing/miro/PKGBUILD
index e653901..8167dc4 100644
--- a/abs/extra-testing/miro/PKGBUILD
+++ b/abs/extra-testing/miro/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=miro
 pkgver=1.2.8
-pkgrel=4
+pkgrel=5
 pkgdesc="The free and open source internet TV platform"
 arch=('i686' 'x86_64')
 url="http://www.getmiro.com"
diff --git a/abs/extra-testing/miro/miro.install b/abs/extra-testing/miro/miro.install
index 1f1121f..4ee823b 100644
--- a/abs/extra-testing/miro/miro.install
+++ b/abs/extra-testing/miro/miro.install
@@ -12,10 +12,30 @@ post_install() {
   echo "" >> /tmp/is.xml.tmp
   echo "</mythmenu>" >> /tmp/is.xml.tmp
   mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
+  if [ -d /myth/democracy ]
+  then
+	  ln -s /myth/democracy /home/mythtv/.miro
+	  ln -s /myth/miro/Movies /myth/video/Miro
+	  exit 1
+  else
+	  if [ -d /myth/miro ]
+	  then
+		  ln -s /myth/miro /home/mythtv/.miro
+		  ln -s /myth/miro/Movies /myth/video/Miro
+		  exit 1
+	  else
+		  if [ ! -d /myth/miro -o /myth/democracy ]
+		  then
+			  mkdir -p /myth/miro/Movies
+			  ln -s /myth/miro /home/mythtv/.miro
+			  ln -s /myth/miro/Movies /home/mythtv/Movies
+			  ln -s /myth/miro/Movies /myth/video/Miro
+		  fi
+	  fi
+  fi
 }
 post_remove() {
-	mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
-	sed -e '/\#Miro/,/\#Miro/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
+	rm -fr /home/mythtv/.miro /myth/video/Miro /myth/miro /myth/democracy
 }
 
 op=$1
-- 
cgit v0.12