From 03f66cf733f73ecc62b9a71f569b03453f895ea4 Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Tue, 2 Jun 2009 15:29:09 -0400
Subject: Incremental tweaker fixes.

---
 abs/core-testing/tweaker/PKGBUILD          | 2 +-
 abs/core-testing/tweaker/bin/twk_audio.pl  | 3 ++-
 abs/core-testing/tweaker/bin/twk_cpu.pl    | 4 ++--
 abs/core-testing/tweaker/bin/twk_keymap.sh | 2 --
 4 files changed, 5 insertions(+), 6 deletions(-)

diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index f546293..78052f8 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=tweaker
 pkgver=1
-pkgrel=29
+pkgrel=30
 pkgdesc=""
 arch=('i686' 'x86_64')
 
diff --git a/abs/core-testing/tweaker/bin/twk_audio.pl b/abs/core-testing/tweaker/bin/twk_audio.pl
index eec7992..42a90d1 100755
--- a/abs/core-testing/tweaker/bin/twk_audio.pl
+++ b/abs/core-testing/tweaker/bin/twk_audio.pl
@@ -243,7 +243,8 @@ sub implement_option {
 
 	# Now, do what works for all sound devices.
 	
-	my $command = "su - mythtv -c \"aumix -v 70 -m 0 -l 0 -l R -w 70\""; # ok for analog and digital
+	#my $command = "su - mythtv -c \"aumix -v 70 -m 0 -l 0 -l R -w 70\""; # ok for analog and digital
+	my $command = "su - mythtv -c \"amixer -c 1 -- sset Master playback -20dB\""; # ok for analog and digital
 
 	if (my $error = execute_shell_command($command)) {
 	    $logger->error("ERROR: $error");
diff --git a/abs/core-testing/tweaker/bin/twk_cpu.pl b/abs/core-testing/tweaker/bin/twk_cpu.pl
index fb256cb..118bac1 100755
--- a/abs/core-testing/tweaker/bin/twk_cpu.pl
+++ b/abs/core-testing/tweaker/bin/twk_cpu.pl
@@ -84,7 +84,7 @@ sub implement_option {
 #		}
 	    }
 	    case "medium" {
-		change_or_make_setting('AutoCommflagWhileRecording', '0') || exit -1;
+		change_or_make_setting('AutoCommflagWhileRecording', '1') || exit -1;
 		change_or_make_setting('Theme', 'LinHES') || exit -1; # Moderate eye candy, moderate performance
 		#change_or_make_setting('PreferredMPEG2Decoder', 'libmpeg2') || exit -1; # Least CPU usage, lowest quality
 		#change_or_make_entry("displayprofiles", [["pref_decoder", "libmpeg2"]], [["profilegroupid", "1"], ["profileid", "1"]]) || exit -1; # Least CPU usage, lowest quality
@@ -94,7 +94,7 @@ sub implement_option {
 	    case "high" {
 		change_or_make_setting('AutoCommflagWhileRecording', '1') || exit -1;
 		# ??? Interacts with screen aspect ratio
-		change_or_make_setting('Theme', 'LinHES') || exit -1; # High eye candy, potentially low performance
+		change_or_make_setting('Theme', 'LinHES') || exit -1; # Moderate eye candy, moderate performance
 		#change_or_make_entry("displayprofiles", [["pref_decoder", "ffmpeg"]], [["profilegroupid", "1"], ["profileid", "1"]]) || exit -1; # Most CPU usage, best quality
 		#change_or_make_setting('PreferredMPEG2Decoder', 'ffmpeg') || exit -1; # Most CPU usage, best quality
 		change_or_make_setting('DefaultVideoPlaybackProfile', 'CPU++') || exit -1; # best playback defaults for powerful hardware
diff --git a/abs/core-testing/tweaker/bin/twk_keymap.sh b/abs/core-testing/tweaker/bin/twk_keymap.sh
index 7e4ef8b..2aa38ee 100755
--- a/abs/core-testing/tweaker/bin/twk_keymap.sh
+++ b/abs/core-testing/tweaker/bin/twk_keymap.sh
@@ -69,5 +69,3 @@ else
     echo "ERROR: /etc/mplayer/input.conf is missing, which is unexpected."
     exit -1
 fi
-
-echo "Tweaked keymap"
\ No newline at end of file
-- 
cgit v0.12