From 065ac482f15d766fea7a2a8cd5e763d642ca3a9a Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 8 Sep 2009 10:36:58 -0500
Subject: linhes-config: send mysql errors to /dev/null ref FS#505

---
 abs/core-testing/LinHES-config/PKGBUILD             | 2 +-
 abs/core-testing/LinHES-config/install_functions.sh | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 4d01bbe..bc36fc0 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=91
+pkgrel=94
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index 4df2e8c..83a2bed 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -16,8 +16,8 @@ found_remote=1
 function update_db_settings () {
 
  printhl "  setting database value $1 to $2 for $hostname"
- $MYSQLCMD_C "delete from settings where value='${1}' and hostname=\"$hostname\";"
- $MYSQLCMD_C "REPLACE INTO  settings set value='${1}', data='${2}' , hostname=\"$hostname\";"
+ $MYSQLCMD_C "delete from settings where value='${1}' and hostname=\"$hostname\";"  2>/dev/null
+ $MYSQLCMD_C "REPLACE INTO  settings set value='${1}', data='${2}' , hostname=\"$hostname\";" 2>/dev/null
 }
 
 function random_theme () {
@@ -296,7 +296,7 @@ function request_dhcp(){
                 update_db_settings HostNETMASK$ndev "$TEMPVAR"
                 TEMPVAR=`grep new_routers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
                 update_db_settings HostGW$ndev "$TEMPVAR"
-                TEMPVAR=`grep new_domain_name_servers /tmp/dhcpinfo.$ndev |cut  -d\= -f2| tr -d\"|tr -d\'|cut -d" " -f 1`
+                TEMPVAR=`grep new_domain_name_servers /tmp/dhcpinfo.$ndev |cut  -d\= -f2| tr -d \"|tr -d \'|cut -d" " -f 1`
                 update_db_settings HostDNS$ndev "$TEMPVAR"
             fi
         fi
-- 
cgit v0.12