From 8d3d5fc17ddda68793375eb9910213eee8f1bf67 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 9 Jan 2018 15:07:58 +0000
Subject: LinHES-system: mythwelcome-config.py: change some settings so daily
 wake is respected

---
 abs/core/LinHES-system/PKGBUILD                 | 6 +++---
 abs/core/LinHES-system/mythwelcome-config.py    | 6 +++---
 abs/core/LinHES-system/mythwelcome-set-alarm.sh | 6 +++---
 3 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 5d4252b..5ecc711 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.5.1
-pkgrel=1
+pkgrel=2
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -135,8 +135,8 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
          '28f29578e5b3ba84fdf2aa57cf475bcf'
          '4a1fda884dcd7d65fb2690fbdbd92a83'
          '29f451783db3220b612e00c29e3ded73'
-         '0b80d8e364652b144324f7c3e0f04ecb'
-         '3b27dd20cc35dce9bdad017087c9cf15'
+         '7fe42dfc99af42a45440c9c3954c3c19'
+         '411b2c22c66833cc8e85021992409f1f'
          '410795ef9039e4c6c0484e706ecfd567'
          'eb879fee9603a05d5420d4ce8ed9e450'
          '02c810c2f47b7c4495fdacaf54189473'
diff --git a/abs/core/LinHES-system/mythwelcome-config.py b/abs/core/LinHES-system/mythwelcome-config.py
index 5a8727f..f3f96fc 100755
--- a/abs/core/LinHES-system/mythwelcome-config.py
+++ b/abs/core/LinHES-system/mythwelcome-config.py
@@ -25,7 +25,7 @@ if mythdb.settings[localhostname].HostSystemType == u'Master_backend':
     else:
         mythdb.settings.NULL.idleTimeoutSecs = u'0'
 
-mythdb.settings.NULL.WakeupTimeFormat = u'time_t'
-mythdb.settings.NULL.SetWakeuptimeCommand = u'sudo /usr/LH/bin/mythwelcome-set-alarm.sh $time'
-mythdb.settings.NULL.ServerHaltCommand = u'sudo /usr/bin/poweroff'
+mythdb.settings.NULL.WakeupTimeFormat = u'yyyy-MM-ddThh:mm:ss'
+mythdb.settings.NULL.SetWakeuptimeCommand = u'/usr/bin/mythshutdown --setwakeup $time'
+mythdb.settings.NULL.ServerHaltCommand = u'/usr/bin/mythshutdown --shutdown'
 mythdb.settings.NULL.preSDWUCheckCommand = u'/usr/LH/bin/idle.py -s -d -l'
diff --git a/abs/core/LinHES-system/mythwelcome-set-alarm.sh b/abs/core/LinHES-system/mythwelcome-set-alarm.sh
index 09ad062..7b10372 100755
--- a/abs/core/LinHES-system/mythwelcome-set-alarm.sh
+++ b/abs/core/LinHES-system/mythwelcome-set-alarm.sh
@@ -13,9 +13,9 @@
 
 # Configure mythtv-setup Shutdown/Wakeup Options page:
 # Idletimeout (secs):             any value greater that 0
-# Wakeup time format:             time_t
-# Set wakeup time command:        sudo /usr/LH/bin/mythwelcome-set-alarm.sh $time
-# Server Halt command:            sudo /usr/bin/poweroff
+# Wakeup time format:             yyyy-MM-ddThh:mm:ss
+# Set wakeup time command:        /usr/bin/mythshutdown --setwakeup $time
+# Server Halt command:            /usr/bin/mythshutdown --shutdown
 # Pre shutdown check command:     /usr/bin/mythshutdown --check
 
 echo 0 > /sys/class/rtc/rtc0/wakealarm      #this clears your alarm
-- 
cgit v0.12