From 888e9e9e92900cdbc8e5846dad7f66776509eaff Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 25 Jan 2009 19:03:05 -0800
Subject: More fixes for FFTW.

---
 abs/core-testing/fftw2/PKGBUILD | 19 ++++++++++++++++++-
 1 file changed, 18 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/fftw2/PKGBUILD b/abs/core-testing/fftw2/PKGBUILD
index e582172..a826ce8 100644
--- a/abs/core-testing/fftw2/PKGBUILD
+++ b/abs/core-testing/fftw2/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=fftw2
 pkgver=2.1.5
-pkgrel=6
+pkgrel=7
 pkgdesc="FFTW is a C subroutine library for computing the discrete Fourier transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. This is package is offering backwards compatibility version 2.x.y. of fftw."
 arch=(i686 x86_64)
 url="http://www.fftw.org/"
@@ -36,4 +36,21 @@ build() {
   ln -s sfftw_threads.h fftw_threads.h
   ln -s srfftw.h rfftw.h
   ln -s srfftw_threads.h rfftw_threads.h
+  cd $startdir/pkg/usr/lib
+  ln -s libsfftw.a libfftw.a
+  ln -s libsfftw.so libfftw.so
+  ln -s libsfftw.so.2 libfftw.so.2
+  ln -s libsfftw.so.2.0.7 libfftw.so.2.0.7
+  ln -s libsfftw_threads.a libfftw_threads.a
+  ln -s libsfftw_threads.so libfftw_threads.so
+  ln -s libsfftw_threads.so.2 libfftw_threads.so.2
+  ln -s libsfftw_threads.so.2.0.7 libfftw_threads.so.2.0.7
+  ln -s libsrfftw.a librfftw.a
+  ln -s libsrfftw.so librfftw.so
+  ln -s libsrfftw.so.2 librfftw.so.2
+  ln -s libsrfftw.so.2.0.7 librfftw.so.2.0.7
+  ln -s libsrfftw_threads.a librfftw_threads.a
+  ln -s libsrfftw_threads.so librfftw_threads.so
+  ln -s libsrfftw_threads.so.2 librfftw_threads.so.2
+  ln -s libsrfftw_threads.so.2.0.7 librfftw_threads.so.2.0.7
 }
-- 
cgit v0.12