From 94624c5151e04fd638a71fb94a7503a12cc443c5 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sat, 25 Jul 2009 15:52:17 +0930
Subject: ddcxinfo: add googled patch to make it build

---
 abs/core-testing/ddcxinfo/PKGBUILD   |  6 ++++--
 abs/core-testing/ddcxinfo/lrmi.patch | 18 ++++++++++++++++++
 2 files changed, 22 insertions(+), 2 deletions(-)
 create mode 100644 abs/core-testing/ddcxinfo/lrmi.patch

diff --git a/abs/core-testing/ddcxinfo/PKGBUILD b/abs/core-testing/ddcxinfo/PKGBUILD
index 94707ef..b358c0c 100644
--- a/abs/core-testing/ddcxinfo/PKGBUILD
+++ b/abs/core-testing/ddcxinfo/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=ddcxinfo
 pkgver=0.6.19
-pkgrel=2
+pkgrel=3
 pkgdesc="DDC readout using the VESA BIOS extension"
 url="http://www.t2-project.org/packages/ddcxinfo.html"
 license="GPL"
@@ -11,12 +11,14 @@ replaces=()
 backup=()
 arch=('i686')
 install=
-source=(http://www.kanotix.com/files/debian/pool/main/d/ddcxinfo-kanotix/$pkgname-kanotix_$pkgver.tar.gz)
+source=(http://www.kanotix.com/files/debian/pool/main/d/ddcxinfo-kanotix/$pkgname-kanotix_$pkgver.tar.gz
+        lrmi.patch)
 
 
 build() {
   cd $startdir/src/$pkgname-kanotix-$pkgver
   mkdir -p  $startdir/pkg/usr/sbin
+  patch -p1 < $startdir/src/lrmi.patch
   make DESTDIR=$startdir/pkg install
   cp svgamodes $startdir/pkg/usr/sbin/
   chmod +s $startdir/pkg/usr/sbin/ddcprobe
diff --git a/abs/core-testing/ddcxinfo/lrmi.patch b/abs/core-testing/ddcxinfo/lrmi.patch
new file mode 100644
index 0000000..ca735fa
--- /dev/null
+++ b/abs/core-testing/ddcxinfo/lrmi.patch
@@ -0,0 +1,18 @@
+Common subdirectories: ddcxinfo-kanotix-0.6.19-orig/debian and ddcxinfo-kanotix-0.6.19/debian
+diff -u ddcxinfo-kanotix-0.6.19-orig/lrmi.c ddcxinfo-kanotix-0.6.19/lrmi.c
+--- ddcxinfo-kanotix-0.6.19-orig/lrmi.c	2009-07-25 06:15:09.000000000 +0000
++++ ddcxinfo-kanotix-0.6.19/lrmi.c	2009-07-25 06:17:22.000000000 +0000
+@@ -170,6 +170,13 @@
+ 		}
+ 	}
+ 
++#ifndef TF_MASK
++#define TF_MASK X86_EFLAGS_TF
++#define IF_MASK X86_EFLAGS_IF
++#define IOPL_MASK X86_EFLAGS_IOPL
++#define VIF_MASK X86_EFLAGS_VIF
++#define VIP_MASK X86_EFLAGS_VIP
++#endif
+ 
+ #define DEFAULT_VM86_FLAGS 	(IF_MASK | IOPL_MASK)
+ #define DEFAULT_STACK_SIZE 	0x1000
-- 
cgit v0.12