From e47d97e366a8eae8d5d71ef692b930fcfd953e53 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 15 Jun 2009 15:35:46 -0500
Subject: rrd_stats: add pkg to repo. the configfile needs to be tweaked for
 each install, but the basics are there.

---
 abs/extra-testing/rrd_stats/PKGBUILD          |   2 +-
 abs/extra-testing/rrd_stats/rrd_stats.install |  61 +++++++++++++++++++++-----
 abs/extra-testing/rrd_stats/rrd_stats.tgz     | Bin 6603 -> 6598 bytes
 3 files changed, 51 insertions(+), 12 deletions(-)

diff --git a/abs/extra-testing/rrd_stats/PKGBUILD b/abs/extra-testing/rrd_stats/PKGBUILD
index 8e027d5..a171aa6 100644
--- a/abs/extra-testing/rrd_stats/PKGBUILD
+++ b/abs/extra-testing/rrd_stats/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=rrd_stats
 pkgver=1
-pkgrel=9
+pkgrel=11
 pkgdesc="graph system stats"
 arch=('i686' 'x86_64')
 url=""
diff --git a/abs/extra-testing/rrd_stats/rrd_stats.install b/abs/extra-testing/rrd_stats/rrd_stats.install
index be3d2e9..d6aa4ed 100644
--- a/abs/extra-testing/rrd_stats/rrd_stats.install
+++ b/abs/extra-testing/rrd_stats/rrd_stats.install
@@ -1,22 +1,61 @@
 post_install() {
-	line="*/5 * * * *       /usr/local/bin/rrd_hddtemp.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_disk.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_traffic.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_mem.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_cpu.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
+	PFIX="/data/srv/httpd/htdocs/rrd"
+	if [ ! -e $PFIX/index.html.orig ]
+	then
+		mv $PFIX/index.html  $PFIX/index.html.orig
+		ln -s $PFIX/index-rrd.html $PFIX/index.html
+	fi
+
+	ct=`crontab -l`
+	echo $ct | grep -q rrd_hddtemp.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_hddtemp.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+
+	echo $ct | grep -q rrd_disk.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_disk.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi	
+
+	echo $ct | grep -q rrd_traffic.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_traffic.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+	
+	echo $ct | grep -q rrd_mem.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_mem.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+	
+	echo $ct | grep -q rrd_cpu.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_cpu.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+
 }
 
 post_upgrade() {
- 	/bin/true
+ 	post_install $1
 }
 
 
 pre_remove() {
 	crontab -l | grep -v rrd_ | crontab - 
+	PFIX="/data/srv/httpd/htdocs/rrd"
+	if [  -e $PFIX/index.html.orig ]
+	then
+		rm $PFIX/index.html
+		mv $PFIX/index.html.orig  $PFIX/index.html
+	fi
 
 }
diff --git a/abs/extra-testing/rrd_stats/rrd_stats.tgz b/abs/extra-testing/rrd_stats/rrd_stats.tgz
index 66d2e06..2d66428 100644
Binary files a/abs/extra-testing/rrd_stats/rrd_stats.tgz and b/abs/extra-testing/rrd_stats/rrd_stats.tgz differ
-- 
cgit v0.12