From e2f581d7a980085e0078e01f1a38886ab88127ec Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 15 Jan 2009 08:57:37 -0600
Subject: change data location back to /data/srv/mysql

add Xosd to lcdproc.
---
 abs/core-testing/mysql/PKGBUILD       | 7 +------
 abs/core-testing/mysql/__changelog    | 7 +++++++
 abs/core-testing/mysql/my.cnf         | 4 ++--
 abs/core-testing/mysql/mysqld         | 2 +-
 abs/core-testing/mysql/mysqld.conf.d  | 2 +-
 abs/extra-testing/lcdproc/PKGBUILD    | 4 ++--
 abs/extra-testing/lcdproc/__changelog | 1 +
 7 files changed, 15 insertions(+), 12 deletions(-)
 create mode 100644 abs/core-testing/mysql/__changelog
 create mode 100644 abs/extra-testing/lcdproc/__changelog

diff --git a/abs/core-testing/mysql/PKGBUILD b/abs/core-testing/mysql/PKGBUILD
index 4def9e3..8c9763a 100644
--- a/abs/core-testing/mysql/PKGBUILD
+++ b/abs/core-testing/mysql/PKGBUILD
@@ -3,7 +3,7 @@
 # Contributor: judd <jvinet@zeroflux.org>
 pkgname=mysql
 pkgver=5.0.75
-pkgrel=1
+pkgrel=2
 pkgdesc="A fast SQL database server"
 arch=(i686 x86_64)
 backup=(etc/my.cnf etc/conf.d/mysqld)
@@ -48,8 +48,3 @@ build() {
   install -D -m644 ../mysqld.conf.d ${startdir}/pkg/etc/conf.d/mysqld
   rm -f ${startdir}/pkg/usr/bin/mysql_config
 }
-md5sums=('a234f0a60a7f8c290d9875cba3a2c5a2'
-         'e892aac36cbeb57f0e003ec0936afb3b'
-         '247e9fa664bccaca62ca0e42a6cfae20'
-         '0ee035590ffc61d32de994f461fd2bd2'
-         '4a9077fc95ec6db1d5420e0cdc74d31c')
diff --git a/abs/core-testing/mysql/__changelog b/abs/core-testing/mysql/__changelog
new file mode 100644
index 0000000..5e620ec
--- /dev/null
+++ b/abs/core-testing/mysql/__changelog
@@ -0,0 +1,7 @@
+my.cnf
+-enable networking
+-datadir /data/srv/mysql
+
+mysqld
+	-redirect output to /dev/null
+	--skip-name-resolve 
\ No newline at end of file
diff --git a/abs/core-testing/mysql/my.cnf b/abs/core-testing/mysql/my.cnf
index 927b9c8..7202fcd 100644
--- a/abs/core-testing/mysql/my.cnf
+++ b/abs/core-testing/mysql/my.cnf
@@ -20,7 +20,7 @@ socket		= /tmp/mysql.sock
 [mysqld]
 port		= 3306
 socket		= /tmp/mysql.sock
-datadir		= /var/lib/mysql
+datadir		= /data/srv/mysql
 skip-locking
 key_buffer = 16M
 max_allowed_packet = 1M
@@ -35,7 +35,7 @@ myisam_sort_buffer_size = 8M
 # Note that using this option without enabling named pipes on Windows
 # (via the "enable-named-pipe" option) will render mysqld useless!
 # 
-skip-networking
+#skip-networking
 
 # Replication Master Server (default)
 # binary logging is required for replication
diff --git a/abs/core-testing/mysql/mysqld b/abs/core-testing/mysql/mysqld
index 843397e..7bada3d 100755
--- a/abs/core-testing/mysql/mysqld
+++ b/abs/core-testing/mysql/mysqld
@@ -31,7 +31,7 @@ case "$1" in
   start)
     stat_busy "Starting MySQL"
     if [ -z "$PID" ]; then
-       /usr/bin/mysqld_safe --datadir=$MYSQLD_ROOT &>/dev/null &
+       /usr/bin/mysqld_safe --skip-name-resolve --datadir=$MYSQLD_ROOT >/dev/null 2>/dev/null &
       if [ $? -gt 0 ]; then
         stat_fail
         exit 1
diff --git a/abs/core-testing/mysql/mysqld.conf.d b/abs/core-testing/mysql/mysqld.conf.d
index 04752b1..10b7098 100644
--- a/abs/core-testing/mysql/mysqld.conf.d
+++ b/abs/core-testing/mysql/mysqld.conf.d
@@ -1 +1 @@
-MYSQLD_ROOT="/var/lib/mysql"
+MYSQLD_ROOT="/data/srv/mysql"
diff --git a/abs/extra-testing/lcdproc/PKGBUILD b/abs/extra-testing/lcdproc/PKGBUILD
index 6619eb9..7ee6e50 100644
--- a/abs/extra-testing/lcdproc/PKGBUILD
+++ b/abs/extra-testing/lcdproc/PKGBUILD
@@ -1,11 +1,11 @@
 # Contributor: Bernhard Walle <bernhard.walle@gmx.de>
 pkgname=lcdproc
 pkgver=0.5.2
-pkgrel=0
+pkgrel=2
 pkgdesc="LCDproc is a utility to drive one or more LCD (and LCD-like) devices attached to a host."
 url="http://lcdproc.omnipotent.net/"
 license="GPL"
-depends=(libusb serdisplib libftdi autoconf automake lirc libnxml libmrss pkgconfig)
+depends=(libusb serdisplib libftdi autoconf automake lirc libnxml libmrss pkgconfig xosd)
 backup=(etc/LCDd.conf)
 arch=(i686 x86_64)
 source=(http://switch.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
diff --git a/abs/extra-testing/lcdproc/__changelog b/abs/extra-testing/lcdproc/__changelog
new file mode 100644
index 0000000..52c2d35
--- /dev/null
+++ b/abs/extra-testing/lcdproc/__changelog
@@ -0,0 +1 @@
+add xosd
\ No newline at end of file
-- 
cgit v0.12